summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2005-06-19 16:04:26 +0000
committerJonathan Smith <smithj@gentoo.org>2005-06-19 16:04:26 +0000
commit1d9b87b5923849b6c6e78571ad3f5bdc6084dd32 (patch)
tree0f34dff44057bf2487b5a0d9a2d112c7b8dbc823 /x11-misc/basket
parentFixed and marked stable for hppa. (diff)
downloadgentoo-2-1d9b87b5923849b6c6e78571ad3f5bdc6084dd32.tar.gz
gentoo-2-1d9b87b5923849b6c6e78571ad3f5bdc6084dd32.tar.bz2
gentoo-2-1d9b87b5923849b6c6e78571ad3f5bdc6084dd32.zip
version bump for #81369 using the ebuild on the homepage with a few modifications
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-misc/basket')
-rw-r--r--x11-misc/basket/ChangeLog9
-rw-r--r--x11-misc/basket/Manifest13
-rw-r--r--x11-misc/basket/basket-0.5.0.ebuild31
-rw-r--r--x11-misc/basket/files/basket-0.5.0-noarts.patch98
-rw-r--r--x11-misc/basket/files/digest-basket-0.5.01
5 files changed, 141 insertions, 11 deletions
diff --git a/x11-misc/basket/ChangeLog b/x11-misc/basket/ChangeLog
index 84674dee7779..01c55fe39432 100644
--- a/x11-misc/basket/ChangeLog
+++ b/x11-misc/basket/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/basket
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/basket/ChangeLog,v 1.6 2005/06/16 20:37:45 smithj Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/basket/ChangeLog,v 1.7 2005/06/19 16:04:26 smithj Exp $
+
+*basket-0.5.0 (19 Jun 2005)
+
+ 19 Jun 2005; Jonathan Smith <smithj@gentoo.org>
+ +files/basket-0.5.0-noarts.patch, +basket-0.5.0.ebuild:
+ version bump for #81369 using the ebuild on the homepage with a few
+ modifications
16 Jun 2005; Jonathan Smith <smithj@gentoo.org> basket-0.4.0d.ebuild:
updated homepage
diff --git a/x11-misc/basket/Manifest b/x11-misc/basket/Manifest
index a00982f0370c..e39477e26080 100644
--- a/x11-misc/basket/Manifest
+++ b/x11-misc/basket/Manifest
@@ -1,14 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 1a713a78b6966dc406a8dfb8667231f1 ChangeLog 747
MD5 cdb11033a3fa6525334cecf938961c07 metadata.xml 166
MD5 3a5128d624103803bd71227425b11a08 basket-0.4.0d.ebuild 503
+MD5 0adf0ce7649bfb7475464171d4be5eee basket-0.5.0.ebuild 615
MD5 8433b9ef958f62f31c4a2b5c3c45b520 files/digest-basket-0.4.0d 65
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCseNml5AvwDPiUowRAs8gAJwJMBWEGBB3V7O78/pLhniOYqxtqgCgmolv
-T96sSB0hXMciLUC+6RnrYx0=
-=qkSG
------END PGP SIGNATURE-----
+MD5 770706f890ef65821f7eaa27000313e4 files/basket-0.5.0-noarts.patch 3468
+MD5 1a9c1e6cd25c2910634165d0a87ed671 files/digest-basket-0.5.0 79
diff --git a/x11-misc/basket/basket-0.5.0.ebuild b/x11-misc/basket/basket-0.5.0.ebuild
new file mode 100644
index 000000000000..a5b307802ebc
--- /dev/null
+++ b/x11-misc/basket/basket-0.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/basket/basket-0.5.0.ebuild,v 1.1 2005/06/19 16:04:26 smithj Exp $
+
+inherit eutils kde
+
+need-kde 3.3
+need-qt 3
+
+IUSE="arts"
+DESCRIPTION="A DropDrawers clone. Multiple information organizer"
+HOMEPAGE="http://basket.kde.org/"
+SRC_URI="http://basket.kde.org/downloads/index.php?file=${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="virtual/x11
+ arts? ( kde-base/arts )"
+
+DOCS="AUTHORS ChangeLog INSTALL NEWS REDME TODO"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # patch from basket developer to solve compilation
+ # problemes on systems without arts
+ ! use arts && epatch ${FILESDIR}/${P}-noarts.patch
+}
+
diff --git a/x11-misc/basket/files/basket-0.5.0-noarts.patch b/x11-misc/basket/files/basket-0.5.0-noarts.patch
new file mode 100644
index 000000000000..b071fadcbd6d
--- /dev/null
+++ b/x11-misc/basket/files/basket-0.5.0-noarts.patch
@@ -0,0 +1,98 @@
+diff -Naur basket-0.5.0-orig/src/item.cpp basket-0.5.0/src/item.cpp
+--- basket-0.5.0-orig/src/item.cpp 2005-03-09 17:38:27.000000000 +0000
++++ basket-0.5.0/src/item.cpp 2005-03-31 22:59:11.000000000 +0000
+@@ -46,9 +46,6 @@
+ #include <kfiledialog.h>
+ #include <qfile.h>
+ #include <kurifilter.h>
+-#include <arts/kartsdispatcher.h>
+-//#include <arts/kplayobjectfactory.h>
+-//#include <arts/kartsserver.h>
+
+ #include <kaction.h>
+ #include <kglobalsettings.h>
+@@ -219,8 +216,6 @@
+ connect( m_check->checkBox(), SIGNAL(clicked()), this, SLOT(slotChecked()) );
+ connect( &m_selectTimer, SIGNAL(timeout()), this, SLOT(select()) );
+
+- m_playObj = 0L;
+- m_playServer = 0L;
+ m_previous = 0L;
+ m_next = 0L;
+ m_isSelected = false;
+@@ -598,15 +593,6 @@
+ if ( Settings::singleClick() && kapp->activePopupWidget() == 0L )
+ m_selectTimer.start(KGlobalSettings::autoSelectDelay(), true);
+ }
+- if (m_type == Sound) {
+- KArtsDispatcher *dispatcher = new KArtsDispatcher(); // Needed for m_playObj
+- dispatcher = dispatcher; // To avoid "warning: unused variable `KArtsDispatcher*dispatcher'" warning
+- if (!m_playServer)
+- m_playServer = new KArtsServer();
+- m_playFactory = new KDE::PlayObjectFactory(m_playServer);
+- m_playObj = m_playFactory->createPlayObject(fullPath(), true);
+- m_playObj->play();
+- }
+ }
+
+ void Item::leaveEvent(QEvent*)
+@@ -614,12 +600,6 @@
+ m_selectTimer.stop();
+ OnClickAction::stopHoverFeedback();
+
+- if (m_playObj) {
+- m_playObj->halt();
+- delete m_playObj;
+- delete m_playFactory;
+- m_playObj = 0L;
+- }
+ }
+
+ void Item::mousePressEvent(QMouseEvent *event)
+diff -Naur basket-0.5.0-orig/src/item.h basket-0.5.0/src/item.h
+--- basket-0.5.0-orig/src/item.h 2005-01-14 01:04:37.000000000 +0000
++++ basket-0.5.0/src/item.h 2005-03-31 22:59:11.000000000 +0000
+@@ -32,9 +32,6 @@
+ #include <qcolor.h>
+ #include <kurl.h>
+ #include <kio/jobclasses.h>
+-#include <arts/kplayobject.h>
+-#include <arts/kplayobjectfactory.h>
+-#include <arts/kartsserver.h>
+
+ #include "onclickaction.h"
+
+@@ -254,9 +251,6 @@
+ bool m_canDrag;
+ QPoint m_pressPos;
+ bool m_wasPressed;
+- KArtsServer *m_playServer;
+- KDE::PlayObject *m_playObj;
+- KDE::PlayObjectFactory *m_playFactory;
+
+ int m_x;
+ int m_y;
+diff -Naur basket-0.5.0-orig/src/Makefile.am basket-0.5.0/src/Makefile.am
+--- basket-0.5.0-orig/src/Makefile.am 2005-03-08 12:05:12.000000000 +0000
++++ basket-0.5.0/src/Makefile.am 2005-03-31 23:02:23.000000000 +0000
+@@ -22,7 +22,7 @@
+ # the application source, library search path, and link libraries
+
+ basket_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+-basket_LDADD = -lartskde -lkio $(LIB_KDEUI) $(LIB_KDECORE) $(LIB_QT) $(LIBSOCKET)
++basket_LDADD = -lkio $(LIB_KDEUI) $(LIB_KDECORE) $(LIB_QT) $(LIBSOCKET)
+
+ # this is where the desktop file will go
+ shelldesktopdir = $(kde_appsdir)/Utilities
+diff -Naur basket-0.5.0-orig/src/Makefile.in basket-0.5.0/src/Makefile.in
+--- basket-0.5.0-orig/src/Makefile.in 2005-03-09 20:27:29.000000000 +0000
++++ basket-0.5.0/src/Makefile.in 2005-03-31 23:02:43.000000000 +0000
+@@ -264,7 +264,7 @@
+
+ # the application source, library search path, and link libraries
+ basket_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+-basket_LDADD = -lartskde -lkio $(LIB_KDEUI) $(LIB_KDECORE) $(LIB_QT) $(LIBSOCKET)
++basket_LDADD = -lkio $(LIB_KDEUI) $(LIB_KDECORE) $(LIB_QT) $(LIBSOCKET)
+
+ # this is where the desktop file will go
+ shelldesktopdir = $(kde_appsdir)/Utilities
diff --git a/x11-misc/basket/files/digest-basket-0.5.0 b/x11-misc/basket/files/digest-basket-0.5.0
new file mode 100644
index 000000000000..67421ca96e4f
--- /dev/null
+++ b/x11-misc/basket/files/digest-basket-0.5.0
@@ -0,0 +1 @@
+MD5 1495261da3dbfc243a8340cd9c5723c2 index.php?file=basket-0.5.0.tar.gz 961055