summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-24 05:01:18 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-24 05:01:18 +0000
commitf0450138485c44e6ccaefbaf9b401f1b247e5b10 (patch)
tree03b824f5a009288d0952f1c576f071fc37ba7ec5 /x11-misc/alacarte
parentInherit user for enewuser/etc... (diff)
downloadgentoo-2-f0450138485c44e6ccaefbaf9b401f1b247e5b10.tar.gz
gentoo-2-f0450138485c44e6ccaefbaf9b401f1b247e5b10.tar.bz2
gentoo-2-f0450138485c44e6ccaefbaf9b401f1b247e5b10.zip
Version bump, first fully gnome3-compatible release.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/alacarte')
-rw-r--r--x11-misc/alacarte/ChangeLog11
-rw-r--r--x11-misc/alacarte/alacarte-0.13.3.ebuild89
-rw-r--r--x11-misc/alacarte/files/alacarte-0.13.3-cursor-changed-selection-none.patch42
-rw-r--r--x11-misc/alacarte/files/alacarte-0.13.3-icon-crash.patch26
-rw-r--r--x11-misc/alacarte/files/alacarte-0.13.3-no-pygtk-checks.patch79
5 files changed, 246 insertions, 1 deletions
diff --git a/x11-misc/alacarte/ChangeLog b/x11-misc/alacarte/ChangeLog
index 5b77424d9596..25df4ea9416d 100644
--- a/x11-misc/alacarte/ChangeLog
+++ b/x11-misc/alacarte/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-misc/alacarte
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/ChangeLog,v 1.113 2012/05/05 04:53:41 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/ChangeLog,v 1.114 2012/05/24 05:01:18 tetromino Exp $
+
+*alacarte-0.13.3 (24 May 2012)
+
+ 24 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +alacarte-0.13.3.ebuild,
+ +files/alacarte-0.13.3-cursor-changed-selection-none.patch,
+ +files/alacarte-0.13.3-icon-crash.patch,
+ +files/alacarte-0.13.3-no-pygtk-checks.patch:
+ Version bump, first fully gnome3-compatible release.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> alacarte-0.12.4.ebuild,
alacarte-0.13.2.ebuild, alacarte-0.13.2-r50.ebuild:
diff --git a/x11-misc/alacarte/alacarte-0.13.3.ebuild b/x11-misc/alacarte/alacarte-0.13.3.ebuild
new file mode 100644
index 000000000000..72fee004482d
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-0.13.3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/alacarte-0.13.3.ebuild,v 1.1 2012/05/24 05:01:18 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="xml"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit autotools eutils gnome2 python
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="http://live.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+COMMON_DEPEND="dev-python/pygobject:3
+ >=gnome-base/gnome-menus-3.2.0.1:3[introspection]
+"
+# gnome-panel needed for gnome-desktop-item-edit
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gnome-panel
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ python_pkg_setup
+}
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=676699
+ epatch "${FILESDIR}/${P}-no-pygtk-checks.patch"
+ # https://bugzilla.gnome.org/show_bug.cgi?id=676700
+ epatch "${FILESDIR}/${P}-icon-crash.patch"
+ # https://bugzilla.gnome.org/show_bug.cgi?id=676702
+ epatch "${FILESDIR}/${P}-cursor-changed-selection-none.patch"
+ eautoreconf
+
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ python_clean_py-compile_files
+
+ python_copy_sources
+}
+
+src_configure() {
+ configure() {
+ G2CONF="${G2CONF} PYTHON=$(PYTHON -a)"
+ gnome2_src_configure
+ }
+ python_execute_function -s configure
+}
+
+src_compile() {
+ python_execute_function -s gnome2_src_compile
+}
+
+src_test() {
+ python_execute_function -s -d
+}
+
+src_install() {
+ python_execute_function -s gnome2_src_install
+ python_clean_installation_image
+ python_convert_shebangs -r 2 "${ED}"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize Alacarte
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup Alacarte
+}
diff --git a/x11-misc/alacarte/files/alacarte-0.13.3-cursor-changed-selection-none.patch b/x11-misc/alacarte/files/alacarte-0.13.3-cursor-changed-selection-none.patch
new file mode 100644
index 000000000000..b1f9cfef42d1
--- /dev/null
+++ b/x11-misc/alacarte/files/alacarte-0.13.3-cursor-changed-selection-none.patch
@@ -0,0 +1,42 @@
+From e265c5b46cfa259b03ca08672023b8ef0d0e2ea9 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Thu, 24 May 2012 00:54:20 -0400
+Subject: [PATCH] MainWindow: treeview.get_selection() in cursor-changed
+ callbacks can return None
+
+https://bugzilla.gnome.org/show_bug.cgi?id=676702
+---
+ Alacarte/MainWindow.py | 10 ++++++++--
+ 1 files changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/Alacarte/MainWindow.py b/Alacarte/MainWindow.py
+index be460e1..fd18064 100644
+--- a/Alacarte/MainWindow.py
++++ b/Alacarte/MainWindow.py
+@@ -366,7 +366,10 @@ class MainWindow(object):
+ GObject.timeout_add(100, self.waitForEditProcess, process, file_path)
+
+ def on_menu_tree_cursor_changed(self, treeview):
+- menus, iter = treeview.get_selection().get_selected()
++ selection = treeview.get_selection()
++ if selection is None:
++ return
++ menus, iter = selection.get_selected()
+ if iter is None:
+ return
+ menu_path = menus.get_path(iter)
+@@ -424,7 +427,10 @@ class MainWindow(object):
+ self.item_store[path][0] = not self.item_store[path][0]
+
+ def on_item_tree_cursor_changed(self, treeview):
+- items, iter = treeview.get_selection().get_selected()
++ selection = treeview.get_selection()
++ if selection is None:
++ return
++ items, iter = selection.get_selected()
+ if iter is None:
+ return
+ item = items[iter][3]
+--
+1.7.8.6
+
diff --git a/x11-misc/alacarte/files/alacarte-0.13.3-icon-crash.patch b/x11-misc/alacarte/files/alacarte-0.13.3-icon-crash.patch
new file mode 100644
index 000000000000..2b3dfe6225c9
--- /dev/null
+++ b/x11-misc/alacarte/files/alacarte-0.13.3-icon-crash.patch
@@ -0,0 +1,26 @@
+From 8fd2c4b9939a9adf5b9bfad9df17ee8bbeac2c2c Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Thu, 24 May 2012 00:04:55 -0400
+Subject: [PATCH] util: avoid crashing if a .desktop file has no icon defined
+
+https://bugzilla.gnome.org/show_bug.cgi?id=676700
+---
+ Alacarte/util.py | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/Alacarte/util.py b/Alacarte/util.py
+index 8501a35..bcd4bca 100644
+--- a/Alacarte/util.py
++++ b/Alacarte/util.py
+@@ -138,6 +138,8 @@ def getIcon(item):
+ else:
+ app_info = item.get_app_info()
+ gicon = app_info.get_icon()
++ if gicon is None:
++ return None
+
+ icon_theme = Gtk.IconTheme.get_default()
+ info = icon_theme.lookup_by_gicon(gicon, 24, 0)
+--
+1.7.8.6
+
diff --git a/x11-misc/alacarte/files/alacarte-0.13.3-no-pygtk-checks.patch b/x11-misc/alacarte/files/alacarte-0.13.3-no-pygtk-checks.patch
new file mode 100644
index 000000000000..15c5526fc048
--- /dev/null
+++ b/x11-misc/alacarte/files/alacarte-0.13.3-no-pygtk-checks.patch
@@ -0,0 +1,79 @@
+From 14d2b9a75a0cd6dd7e611caa37dee93b5ac5c3cd Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Wed, 23 May 2012 23:34:36 -0400
+Subject: [PATCH] configure: Remove old pygtk/pygobject-2 checks
+
+https://bugzilla.gnome.org/show_bug.cgi?id=676699
+---
+ configure.ac | 48 +-----------------------------------------------
+ 1 files changed, 1 insertions(+), 47 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index db5495f..378fa6c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -8,9 +8,6 @@ AC_CONFIG_HEADERS([config.h])
+ AM_INIT_AUTOMAKE([1.7])
+ AM_MAINTAINER_MODE
+
+-m4_define(required_pygobject_version, 2.15.1)
+-m4_define(required_pygtk_version, 2.13.0)
+-
+ dnl put the ACLOCAL flags in the makefile
+ ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
+
+@@ -23,50 +20,7 @@ IT_PROG_INTLTOOL([0.40.0])
+
+ AM_PATH_PYTHON_VERSION(2.7, 2.7.0, 2.6, 2.6.0, 2.5, 2.5.0, 2.4, 2.4.0)
+
+-PKG_CHECK_MODULES(ALACARTE, libgnome-menu-3.0 >= 3.2.0.1)
+-
+-dnl Check for correctly installed pygobject
+-AC_MSG_CHECKING(for pygobject required_pygobject_version installed for python required_python_abi)
+-prog="
+-import pygtk; pygtk.require('2.0')
+-import gobject
+-assert gobject.pygobject_version >= tuple(map(int, 'required_pygobject_version'.split('.')))
+-"
+-
+-if $PYTHON -c "$prog" 1>&AC_FD_CC 2>&AC_FD_CC; then
+- AC_MSG_RESULT(found)
+-else
+- AC_MSG_RESULT(not found)
+- AC_MSG_ERROR(required pygobject version not found)
+-fi
+-
+-dnl Check for correctly installed pygtk
+-AC_MSG_CHECKING(for pygtk required_pygtk_version installed for python ${PYTHON_VERSION})
+-prog="
+-import pygtk; pygtk.require('2.0')
+-import gobject
+-assert gobject.pygtk_version >= tuple(map(int, 'required_pygtk_version'.split('.')))
+-"
+-
+-if $PYTHON -c "$prog" 1>&AC_FD_CC 2>&AC_FD_CC; then
+- AC_MSG_RESULT(found)
+-else
+- AC_MSG_RESULT(not found)
+- AC_MSG_ERROR(required pygtk version not found)
+-fi
+-
+-dnl Check for correctly installed python-glade
+-dnl AC_MSG_CHECKING(for pyglade required_pygtk_version installed for python ${PYTHON_VERSION})
+-dnl prog="
+-dnl import pygtk; pygtk.require('2.0')
+-dnl import gtk.glade
+-dnl "
+-dnl if $PYTHON -c "$prog" 1>&AC_FD_CC 2>&AC_FD_CC; then
+-dnl AC_MSG_RESULT(found)
+-dnl else
+-dnl AC_MSG_RESULT(not found)
+-dnl AC_MSG_ERROR(required pyglade version not found)
+-dnl fi
++PKG_CHECK_MODULES(ALACARTE, libgnome-menu-3.0 >= 3.2.0.1 pygobject-3.0)
+
+ AC_CONFIG_FILES([
+ Makefile
+--
+1.7.8.6
+