summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-23 15:01:20 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-23 15:01:20 +0000
commite7d13a7588cc89f58ad72fc063ee9df231d29df5 (patch)
tree5c3ae147a41cbd67de4438e7344b370e77e683a6 /x11-libs
parentDelete deprecation warning (bug #324175). (diff)
downloadgentoo-2-e7d13a7588cc89f58ad72fc063ee9df231d29df5.tar.gz
gentoo-2-e7d13a7588cc89f58ad72fc063ee9df231d29df5.tar.bz2
gentoo-2-e7d13a7588cc89f58ad72fc063ee9df231d29df5.zip
Version bump and try to handle bugs 324631 and 323443 in a way most people are happy.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/ChangeLog14
-rw-r--r--x11-libs/vte/files/vte-0.24.2-invisible-cursor.patch39
-rw-r--r--x11-libs/vte/files/vte-0.24.2-invisible-cursor2.patch34
-rw-r--r--x11-libs/vte/vte-0.24.2.ebuild (renamed from x11-libs/vte/vte-0.24.1-r1.ebuild)16
4 files changed, 98 insertions, 5 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index e858ea77af7a..74dc11d3655e 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for x11-libs/vte
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.250 2010/06/17 19:33:21 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.251 2010/06/23 15:01:20 pacho Exp $
+
+*vte-0.24.2 (23 Jun 2010)
+
+ 23 Jun 2010; Pacho Ramos <pacho@gentoo.org> -vte-0.24.1-r1.ebuild,
+ +vte-0.24.2.ebuild, +files/vte-0.24.2-invisible-cursor.patch,
+ +files/vte-0.24.2-invisible-cursor2.patch:
+ Version bump with translations updates. This also provides patches to fix
+ upstream bug #602596 as demanded by some people, but they are not being
+ applied yet since they cause other problems (bug #323443). Finally, this
+ no longer applies second patch to solve ugly artifacts bug with
+ gnome-terminal since it also causes problems with x11-terms/terminal (bug
+ #324631) and the other patches seem to be enough for now.
*vte-0.24.1-r1 (17 Jun 2010)
diff --git a/x11-libs/vte/files/vte-0.24.2-invisible-cursor.patch b/x11-libs/vte/files/vte-0.24.2-invisible-cursor.patch
new file mode 100644
index 000000000000..59380f9561fe
--- /dev/null
+++ b/x11-libs/vte/files/vte-0.24.2-invisible-cursor.patch
@@ -0,0 +1,39 @@
+From b58bc5359085d2c9233ac6d6a265645bfa217e82 Mon Sep 17 00:00:00 2001
+From: Behdad Esfahbod <behdad@behdad.org>
+Date: Wed, 31 Mar 2010 18:05:10 +0000
+Subject: Bug 602596 - Cursor can become invisible
+
+Always compute the full fore/back color first, then reverse.
+That's what xterm does also.
+---
+diff --git a/src/vte.c b/src/vte.c
+index 178010b..c6844e9 100644
+--- a/src/vte.c
++++ b/src/vte.c
+@@ -8760,10 +8760,6 @@ vte_terminal_determine_colors(VteTerminal *terminal,
+ if (highlight && !cursor && terminal->pvt->highlight_color_set) {
+ *fore = cell ? cell->attr.fore : VTE_DEF_FG;
+ *back = VTE_DEF_HL;
+- } else
+- if (reverse ^ ((cell != NULL) && (cell->attr.reverse))) {
+- *fore = cell ? cell->attr.back : VTE_DEF_BG;
+- *back = cell ? cell->attr.fore : VTE_DEF_FG;
+ } else {
+ *fore = cell ? cell->attr.fore : VTE_DEF_FG;
+ *back = cell ? cell->attr.back : VTE_DEF_BG;
+@@ -8796,6 +8792,13 @@ vte_terminal_determine_colors(VteTerminal *terminal,
+ }
+ }
+ }
++
++ if (reverse ^ ((cell != NULL) && (cell->attr.reverse))) {
++ int tmp;
++ tmp = *fore;
++ *fore = *back;
++ *back = tmp;
++ }
+ }
+
+ /* Check if a unicode character is actually a graphic character we draw
+--
+cgit v0.8.3.1
diff --git a/x11-libs/vte/files/vte-0.24.2-invisible-cursor2.patch b/x11-libs/vte/files/vte-0.24.2-invisible-cursor2.patch
new file mode 100644
index 000000000000..633e9c3baa0d
--- /dev/null
+++ b/x11-libs/vte/files/vte-0.24.2-invisible-cursor2.patch
@@ -0,0 +1,34 @@
+From f412a6f73a7b3a432bb88830b63ee25ea648619d Mon Sep 17 00:00:00 2001
+From: Behdad Esfahbod <behdad@behdad.org>
+Date: Thu, 01 Apr 2010 05:34:18 +0000
+Subject: Followup on Bug 602596 - Cursor can become invisible
+
+Fix invisible attribute.
+---
+diff --git a/src/vte.c b/src/vte.c
+index c6844e9..eddf06b 100644
+--- a/src/vte.c
++++ b/src/vte.c
+@@ -8767,9 +8767,6 @@ vte_terminal_determine_colors(VteTerminal *terminal,
+
+ /* Handle invisible, bold, and standout text by adjusting colors. */
+ if (cell) {
+- if (cell->attr.invisible) {
+- *fore = *back;
+- }
+ if (cell->attr.bold) {
+ if (*fore == VTE_DEF_FG) {
+ *fore = VTE_BOLD_FG;
+@@ -8799,6 +8796,10 @@ vte_terminal_determine_colors(VteTerminal *terminal,
+ *fore = *back;
+ *back = tmp;
+ }
++
++ if (cell && cell->attr.invisible) {
++ *fore = *back;
++ }
+ }
+
+ /* Check if a unicode character is actually a graphic character we draw
+--
+cgit v0.8.3.1
diff --git a/x11-libs/vte/vte-0.24.1-r1.ebuild b/x11-libs/vte/vte-0.24.2.ebuild
index 2d93f8f6f5a4..b20fe9d324ce 100644
--- a/x11-libs/vte/vte-0.24.1-r1.ebuild
+++ b/x11-libs/vte/vte-0.24.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.24.1-r1.ebuild,v 1.1 2010/06/17 19:33:21 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.24.2.ebuild,v 1.1 2010/06/23 15:01:20 pacho Exp $
EAPI="2"
@@ -44,7 +44,15 @@ src_prepare() {
gnome2_src_prepare
# Fix ugly artifacts with upstream patches from bgo#618749
- epatch "${FILESDIR}/${P}-background-color.patch"
- epatch "${FILESDIR}/${P}-background-color2.patch"
- epatch "${FILESDIR}/${P}-cleanup-background.patch"
+ # FIXME: Second patch needs to be skipped since it causes problems with
+ # x11-terms/terminal, see bug #324631. If this is not solved by upstream,
+ # the problem could reappear with >=x11-libs/vte-0.25.2
+ epatch "${FILESDIR}/${PN}-0.24.1-background-color.patch"
+# epatch "${FILESDIR}/${PN}-0.24.1-background-color2.patch"
+ epatch "${FILESDIR}/${PN}-0.24.1-cleanup-background.patch"
+
+ # Prevent cursor from become invisible, bgo#602596
+ # FIXME: The following patches cannot be applied until bug #323443 is solved.
+# epatch "${FILESDIR}/${PN}-0.24.2-invisible-cursor.patch"
+# epatch "${FILESDIR}/${PN}-0.24.2-invisible-cursor2.patch"
}