summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2011-09-09 13:22:54 +0000
committerVadim Kuznetsov <vadimk@gentoo.org>2011-09-09 13:22:54 +0000
commitc33cdd417c66bd808680f438b64a02c3bdf407fa (patch)
tree0e3456e8145a2e00c88e6bb949bb32a6c06085ae /x11-libs
parentapp-admin/hddtemp-0.3_beta15-r4: Bumped EAPI to 4. Fixed bug #374163. (diff)
downloadgentoo-2-c33cdd417c66bd808680f438b64a02c3bdf407fa.tar.gz
gentoo-2-c33cdd417c66bd808680f438b64a02c3bdf407fa.tar.bz2
gentoo-2-c33cdd417c66bd808680f438b64a02c3bdf407fa.zip
static libs via USE flag; removing la files; fixed debug use flag.
(Portage version: 2.1.10.14/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libview/ChangeLog8
-rw-r--r--x11-libs/libview/libview-0.6.6-r1.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/x11-libs/libview/ChangeLog b/x11-libs/libview/ChangeLog
index efc036136105..d7a469f6d434 100644
--- a/x11-libs/libview/ChangeLog
+++ b/x11-libs/libview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libview
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libview/ChangeLog,v 1.13 2011/09/08 16:12:55 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libview/ChangeLog,v 1.14 2011/09/09 13:22:54 vadimk Exp $
+
+*libview-0.6.6-r1 (09 Sep 2011)
+
+ 09 Sep 2011; Vadim Kuznetsov <vadimk@gentoo.org> +libview-0.6.6-r1.ebuild:
+ static libs via USE flag; removing la files; fixed debug use flag.
+ Bugs 382279, 382277
08 Sep 2011; Vadim Kuznetsov <vadimk@gentoo.org> -libview-0.5.6-r1.ebuild,
-libview-0.6.1.ebuild:
diff --git a/x11-libs/libview/libview-0.6.6-r1.ebuild b/x11-libs/libview/libview-0.6.6-r1.ebuild
new file mode 100644
index 000000000000..8bdde00011c6
--- /dev/null
+++ b/x11-libs/libview/libview-0.6.6-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libview/libview-0.6.6-r1.ebuild,v 1.1 2011/09/09 13:22:54 vadimk Exp $
+
+EAPI=3
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="VMware's Incredibly Exciting Widgets"
+HOMEPAGE="http://view.sourceforge.net"
+SRC_URI="mirror://sourceforge/view/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=x11-libs/gtk+-2.4.0:2
+ dev-cpp/gtkmm:2.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+G2CONF="--enable-deprecated"
+
+src_unpack() {
+ gnome2_src_unpack
+}
+
+src_prepare() {
+ # Fix the pkgconfig file
+ epatch "${FILESDIR}"/${PN}-0.5.6-pcfix.patch
+ eautoreconf -i
+}
+src_configure() {
+ econf \
+ --enable-deprecated \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS
+
+ find "${ED}" -name '*.la' -delete
+}