summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-08-06 10:49:07 +0000
committerRémi Cardona <remi@gentoo.org>2009-08-06 10:49:07 +0000
commit9f51ed4e588f4b11cfe3c10072054ffd3199023c (patch)
tree999a3ba4b9338139e383956506261a481a4a455a /x11-libs
parentVersion bump. db2bin.py now uses new hashlib for SHA1. (diff)
downloadgentoo-2-9f51ed4e588f4b11cfe3c10072054ffd3199023c.tar.gz
gentoo-2-9f51ed4e588f4b11cfe3c10072054ffd3199023c.tar.bz2
gentoo-2-9f51ed4e588f4b11cfe3c10072054ffd3199023c.zip
x11-libs/libXt: bump to 1.0.6
(Portage version: 2.2_rc36/cvs/Linux i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libXt/ChangeLog8
-rw-r--r--x11-libs/libXt/files/libXt-1.0.6-cross.patch48
-rw-r--r--x11-libs/libXt/libXt-1.0.6.ebuild30
3 files changed, 85 insertions, 1 deletions
diff --git a/x11-libs/libXt/ChangeLog b/x11-libs/libXt/ChangeLog
index 6bd6807f6f5b..0fc139005dfc 100644
--- a/x11-libs/libXt/ChangeLog
+++ b/x11-libs/libXt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libXt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXt/ChangeLog,v 1.52 2009/05/18 11:26:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXt/ChangeLog,v 1.53 2009/08/06 10:49:07 remi Exp $
+
+*libXt-1.0.6 (06 Aug 2009)
+
+ 06 Aug 2009; Rémi Cardona <remi@gentoo.org> +libXt-1.0.6.ebuild,
+ +files/libXt-1.0.6-cross.patch:
+ bump to 1.0.6
18 May 2009; Diego E. Pettenò <flameeyes@gentoo.org> libXt-1.0.5.ebuild:
Remove WANT_AUTOMAKE which is not needed any longer since bug #270010 was
diff --git a/x11-libs/libXt/files/libXt-1.0.6-cross.patch b/x11-libs/libXt/files/libXt-1.0.6-cross.patch
new file mode 100644
index 000000000000..b5448ccbbd82
--- /dev/null
+++ b/x11-libs/libXt/files/libXt-1.0.6-cross.patch
@@ -0,0 +1,48 @@
+From f77482f0618f954de1d080599ada058e9a3c24ff Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Tue, 28 Jul 2009 09:59:41 +0000
+Subject: Fix compilation of host tools in cross-compilation case
+
+At 36e9f0d351afbf7fd2595990b2d39e7c551f6420, a fix was added to use
+the host gcc instead of the target gcc when cross-compiling
+libXt. This fix works, but is not solve the whole problem: the CFLAGS
+and LDFLAGS used with the host compilers are the one defined for the
+target compiler (and the flags for both compilers might be very
+different).
+
+This new fix let libXt obey to CFLAGS_FOR_BUILD and LDFLAGS_FOR_BUILD
+environment variables, and use them to compile the host tools in
+util/.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+diff --git a/configure.ac b/configure.ac
+index 043ab5f..cb00a41 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -48,6 +48,10 @@ if test x"$CC_FOR_BUILD" = x; then
+ fi
+ fi
+ AC_SUBST([CC_FOR_BUILD])
++CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
++AC_SUBST(CFLAGS_FOR_BUILD)
++LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
++AC_SUBST(LDFLAGS_FOR_BUILD)
+
+ PKG_CHECK_MODULES(XT, sm x11 xproto kbproto)
+
+diff --git a/util/Makefile.am b/util/Makefile.am
+index 0d3ff01..37b78d2 100644
+--- a/util/Makefile.am
++++ b/util/Makefile.am
+@@ -5,6 +5,8 @@ noinst_PROGRAMS = makestrs
+ endif
+
+ CC = @CC_FOR_BUILD@
++CFLAGS = @CFLAGS_FOR_BUILD@
++LDFLAGS = @LDFLAGS_FOR_BUILD@
+
+ EXTRA_DIST = \
+ Shell.ht \
+--
+cgit v0.8.2
diff --git a/x11-libs/libXt/libXt-1.0.6.ebuild b/x11-libs/libXt/libXt-1.0.6.ebuild
new file mode 100644
index 000000000000..0edbe22f1226
--- /dev/null
+++ b/x11-libs/libXt/libXt-1.0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXt/libXt-1.0.6.ebuild,v 1.1 2009/08/06 10:49:07 remi Exp $
+
+# Must be before x-modular eclass is inherited
+SNAPSHOT="yes"
+
+inherit x-modular flag-o-matic
+
+DESCRIPTION="X.Org Xt library"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libSM
+ x11-proto/xproto
+ x11-proto/kbproto"
+DEPEND="${RDEPEND}"
+
+PATCHES=("${FILESDIR}/libXt-1.0.6-cross.patch")
+
+pkg_setup() {
+ # No such function yet
+ # x-modular_pkg_setup
+
+ # (#125465) Broken with Bdirect support
+ filter-flags -Wl,-Bdirect
+ filter-ldflags -Bdirect
+ filter-ldflags -Wl,-Bdirect
+}