summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-11-05 11:41:08 +0000
committerRémi Cardona <remi@gentoo.org>2009-11-05 11:41:08 +0000
commit4604355aee440c8755c5c750b5c4c727e7c95514 (patch)
treedbcf8930a7236c539e65597f555d2b42b65c5b30 /x11-libs
parentx86 stable, bug #290922 (diff)
downloadgentoo-2-4604355aee440c8755c5c750b5c4c727e7c95514.tar.gz
gentoo-2-4604355aee440c8755c5c750b5c4c727e7c95514.tar.bz2
gentoo-2-4604355aee440c8755c5c750b5c4c727e7c95514.zip
x11-libs/libXt: fix cross-compile yet again, should fix bug #290307
(Portage version: 2.2_rc48/cvs/Linux i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libXt/ChangeLog8
-rw-r--r--x11-libs/libXt/files/libXt-1.0.7-fix-cross-compile-again.patch96
-rw-r--r--x11-libs/libXt/libXt-1.0.7-r1.ebuild34
3 files changed, 137 insertions, 1 deletions
diff --git a/x11-libs/libXt/ChangeLog b/x11-libs/libXt/ChangeLog
index d74772e40636..15f91fe8a365 100644
--- a/x11-libs/libXt/ChangeLog
+++ b/x11-libs/libXt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libXt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXt/ChangeLog,v 1.60 2009/10/26 21:02:59 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXt/ChangeLog,v 1.61 2009/11/05 11:41:08 remi Exp $
+
+*libXt-1.0.7-r1 (05 Nov 2009)
+
+ 05 Nov 2009; Rémi Cardona <remi@gentoo.org> +libXt-1.0.7-r1.ebuild,
+ +files/libXt-1.0.7-fix-cross-compile-again.patch:
+ fix cross-compile yet again, should fix bug #290307
26 Oct 2009; Jeroen Roovers <jer@gentoo.org> libXt-1.0.6.ebuild:
Stable for HPPA (bug #282290).
diff --git a/x11-libs/libXt/files/libXt-1.0.7-fix-cross-compile-again.patch b/x11-libs/libXt/files/libXt-1.0.7-fix-cross-compile-again.patch
new file mode 100644
index 000000000000..fc5ea7d75789
--- /dev/null
+++ b/x11-libs/libXt/files/libXt-1.0.7-fix-cross-compile-again.patch
@@ -0,0 +1,96 @@
+From da5ba611fbff6f939a7cec9ca41fa7df0f76a197 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?R=C3=A9mi=20Cardona?= <remi@gentoo.org>
+Date: Thu, 5 Nov 2009 11:55:22 +0100
+Subject: [PATCH] fix cross-compile again
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+makestrs should always be built for the target arch. When cross-compiling,
+create a native version "xmakestrs" which will always be noinst, and use it
+to generate the other sources.
+
+This avoids installing a makestrs built for the wrong arch.
+
+Based on this patch :
+http://overlays.gentoo.org/proj/embedded/browser/openmoko/trunk/openmoko-target/x11-libs/libXt/files/libXt-1.0.7-crosscompile-makestr.patch
+
+Signed-off-by: Rémi Cardona <remi@gentoo.org>
+---
+ configure.ac | 2 ++
+ src/Makefile.am | 8 +++++++-
+ util/Makefile.am | 15 ++++++++++-----
+ 3 files changed, 19 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6a66d45..73bfbc0 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -40,6 +40,8 @@ AC_PROG_LIBTOOL
+ AM_PROG_CC_C_O
+ XORG_DEFAULT_OPTIONS
+
++AM_CONDITIONAL(CROSS_COMPILING, [ test $cross_compiling = yes ])
++
+ if test x"$CC_FOR_BUILD" = x; then
+ if test x"$cross_compiling" = xyes; then
+ AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc)
+diff --git a/src/Makefile.am b/src/Makefile.am
+index a43fb22..6b767a7 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -92,12 +92,18 @@ BUILT_FILES = $(BUILT_SOURCE) $(BUILT_HEADER)
+
+ STRING_LIST = $(top_srcdir)/util/string.list
+
++if CROSS_COMPILING
++MAKESTRS=$(top_builddir)/util/xmakestrs
++else
++MAKESTRS=$(top_builddir)/util/makestrs
++endif
++
+ all-local: $(BUILT_FILES)
+
+ $(BUILT_HEADER): $(BUILT_SOURCE)
+
+ $(BUILT_SOURCE):
+- $(top_builddir)/util/makestrs -i $(top_srcdir) $(STRINGSABIOPTIONS) < $(STRING_LIST) > StringDefs.c
++ $(MAKESTRS) -i $(top_srcdir) $(STRINGSABIOPTIONS) < $(STRING_LIST) > StringDefs.c
+ mkdir -p $(top_builddir)/src
+ mkdir -p $(top_builddir)/include/X11
+ cp StringDefs.h $(top_builddir)/include/X11
+diff --git a/util/Makefile.am b/util/Makefile.am
+index d51365e..6853d89 100644
+--- a/util/Makefile.am
++++ b/util/Makefile.am
+@@ -1,13 +1,10 @@
+ if INSTALL_MAKESTRS
+ bin_PROGRAMS = makestrs
++noinst_PROGRAMS = $(MAKESTRS_PROG)
+ else
+-noinst_PROGRAMS = makestrs
++noinst_PROGRAMS = makestrs $(MAKESTRS_PROG)
+ endif
+
+-CC = @CC_FOR_BUILD@
+-CFLAGS = @CFLAGS_FOR_BUILD@
+-LDFLAGS = @LDFLAGS_FOR_BUILD@
+-
+ EXTRA_DIST = \
+ Shell.ht \
+ StrDefs.ct \
+@@ -45,3 +42,11 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
+
+ .man.$(APP_MAN_SUFFIX):
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
++
++if CROSS_COMPILING
++MAKESTRS_PROG=xmakestrs$(EXEEXT)
++
++xmakestrs$(EXEEXT): makestrs.c
++ $(AM_V_GEN)$(CC_FOR_BUILD) $(X11_CFLAGS) $(CPPFLAGS_FOR_BUILD) \
++ $(CFLAGS_FOR_BUILD) $(LDFLAGS_FOR_BUILD) -o $@ makestrs.c
++endif
+--
+1.6.5.2
+
diff --git a/x11-libs/libXt/libXt-1.0.7-r1.ebuild b/x11-libs/libXt/libXt-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..30200a5b1f9d
--- /dev/null
+++ b/x11-libs/libXt/libXt-1.0.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXt/libXt-1.0.7-r1.ebuild,v 1.1 2009/11/05 11:41:08 remi Exp $
+
+SNAPSHOT="yes"
+
+inherit x-modular flag-o-matic toolchain-funcs
+
+DESCRIPTION="X.Org Xt library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libSM
+ x11-proto/xproto
+ x11-proto/kbproto"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-cross-compile-again.patch" )
+
+pkg_setup() {
+ # No such function yet
+ # x-modular_pkg_setup
+
+ # (#125465) Broken with Bdirect support
+ filter-flags -Wl,-Bdirect
+ filter-ldflags -Bdirect
+ filter-ldflags -Wl,-Bdirect
+
+ if tc-is-cross-compiler; then
+ CFLAGS_FOR_BUILD="${BUILD_CFLAGS}"
+ fi
+}