summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando Serboncini <fserb@gentoo.org>2006-04-26 19:21:21 +0000
committerFernando Serboncini <fserb@gentoo.org>2006-04-26 19:21:21 +0000
commit553dbc735957403061f730d02b6c76f5d4b0f6cf (patch)
tree1e742e15d1fc2aef8eb46ff5fee4c1931158c27b /x11-libs/wxmozilla
parentStable on amd64 wrt security Bug #131341. (diff)
downloadgentoo-2-553dbc735957403061f730d02b6c76f5d4b0f6cf.tar.gz
gentoo-2-553dbc735957403061f730d02b6c76f5d4b0f6cf.tar.bz2
gentoo-2-553dbc735957403061f730d02b6c76f5d4b0f6cf.zip
Version bump 0.5.6
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'x11-libs/wxmozilla')
-rw-r--r--x11-libs/wxmozilla/ChangeLog10
-rw-r--r--x11-libs/wxmozilla/files/digest-wxmozilla-0.5.63
-rw-r--r--x11-libs/wxmozilla/wxmozilla-0.5.6.ebuild48
3 files changed, 59 insertions, 2 deletions
diff --git a/x11-libs/wxmozilla/ChangeLog b/x11-libs/wxmozilla/ChangeLog
index a90e8da5075a..5010b10df671 100644
--- a/x11-libs/wxmozilla/ChangeLog
+++ b/x11-libs/wxmozilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/wxmozilla
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxmozilla/ChangeLog,v 1.5 2005/06/04 13:43:22 fserb Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxmozilla/ChangeLog,v 1.6 2006/04/26 19:21:21 fserb Exp $
+
+*wxmozilla-0.5.6 (26 Apr 2006)
+
+ 26 Apr 2006; Fernando Serboncini <fserb@gentoo.org>
+ +wxmozilla-0.5.6.ebuild:
+ Version bump.
*wxmozilla-0.5.4 (04 Jun 2005)
diff --git a/x11-libs/wxmozilla/files/digest-wxmozilla-0.5.6 b/x11-libs/wxmozilla/files/digest-wxmozilla-0.5.6
new file mode 100644
index 000000000000..55691a3ccbad
--- /dev/null
+++ b/x11-libs/wxmozilla/files/digest-wxmozilla-0.5.6
@@ -0,0 +1,3 @@
+MD5 f67edaaa17ed33a360c7c636b98b78fd wxmozilla-0.5.6.tar.gz 539622
+RMD160 0a5a0043a494ccb01bb5207a44377c5ec04ed196 wxmozilla-0.5.6.tar.gz 539622
+SHA256 35d877fb53fe06be89412479c47c8fe3108019149a23f4c7e8478b42d7dac863 wxmozilla-0.5.6.tar.gz 539622
diff --git a/x11-libs/wxmozilla/wxmozilla-0.5.6.ebuild b/x11-libs/wxmozilla/wxmozilla-0.5.6.ebuild
new file mode 100644
index 000000000000..dbedd748816e
--- /dev/null
+++ b/x11-libs/wxmozilla/wxmozilla-0.5.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxmozilla/wxmozilla-0.5.6.ebuild,v 1.1 2006/04/26 19:21:21 fserb Exp $
+
+inherit eutils libtool flag-o-matic
+
+# firefox support is disabled until it compiles.
+IUSE="python doc"
+
+DESCRIPTION="Mozilla widget for wxWindows"
+SRC_URI="mirror://sourceforge/wxmozilla/${P}.tar.gz"
+HOMEPAGE="http://wxmozilla.sourceforge.net/"
+
+# !firefox? ( >=www-client/mozilla-1.3 )
+# firefox? ( >=www-client/mozilla-firefox-1.0.2-r1 )
+DEPEND=">=www-client/mozilla-1.3
+ python? ( dev-lang/python >=dev-python/wxpython-2.6.3 )
+ >=x11-libs/wxGTK-2.4"
+
+SLOT="0"
+LICENSE="wxWinLL-3"
+KEYWORDS="~x86"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/wxmozilla-wxpy-2.4.patch
+}
+
+src_compile() {
+ elibtoolize
+ #append-flags "-DMOZILLA_INTERNAL_API"
+ # `use_enable firefox`
+ econf `use_enable python` || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "install failed"
+
+ if use doc; then
+ dodoc README
+ newdoc demo/main.cpp example.cpp
+ if use python; then
+ dodoc wxPython/demo/*.py
+ fi
+ fi
+}