summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-09-30 20:49:07 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-09-30 20:49:07 +0000
commit4d94804b20258f60d3439e1824e7f2cf62064cc2 (patch)
treee7fa7fc9cedf29730a40caea9d27c440c8f1499a /x11-libs/pango
parentadd ~amd64 kw based on Chad's testing. bug #239162 (diff)
downloadgentoo-2-4d94804b20258f60d3439e1824e7f2cf62064cc2.tar.gz
gentoo-2-4d94804b20258f60d3439e1824e7f2cf62064cc2.tar.bz2
gentoo-2-4d94804b20258f60d3439e1824e7f2cf62064cc2.zip
Add pango 1.22.0 to go with cario 1.8.0
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/ChangeLog7
-rw-r--r--x11-libs/pango/pango-1.22.0.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index 1872c298a7ce..78685e311a35 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/pango
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.228 2008/09/25 14:00:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.229 2008/09/30 20:49:07 dang Exp $
+
+*pango-1.22.0 (30 Sep 2008)
+
+ 30 Sep 2008; Daniel Gryniewicz <dang@gentoo.org> +pango-1.22.0.ebuild:
+ Add pango 1.22.0 to go with cario 1.8.0
25 Sep 2008; Jeroen Roovers <jer@gentoo.org> pango-1.20.5.ebuild:
Stable for HPPA (bug #236971).
diff --git a/x11-libs/pango/pango-1.22.0.ebuild b/x11-libs/pango/pango-1.22.0.ebuild
new file mode 100644
index 000000000000..6fd6eb39c9b3
--- /dev/null
+++ b/x11-libs/pango/pango-1.22.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.22.0.ebuild,v 1.1 2008/09/30 20:49:07 dang Exp $
+
+inherit eutils gnome2 multilib
+
+DESCRIPTION="Text rendering and layout library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="X debug doc"
+
+# glib-2.16.3 dependency instead of 2.14 ensures Unicode 5.1 support on the system
+RDEPEND=">=dev-libs/glib-2.16.3
+ >=media-libs/fontconfig-1.0.1
+ >=media-libs/freetype-2
+ >=x11-libs/cairo-1.7.6
+ X? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft
+ )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? (
+ >=dev-util/gtk-doc-1
+ ~app-text/docbook-xml-dtd-4.1.2
+ )
+ X? ( x11-proto/xproto )"
+
+DOCS="AUTHORS ChangeLog* NEWS README TODO*"
+
+function multilib_enabled() {
+ has_multilib_profile || ( use x86 && [ "$(get_libdir)" == "lib32" ] )
+}
+
+pkg_setup() {
+ # Do NOT build with --disable-debug/--enable-debug=no
+ if use debug ; then
+ G2CONF="${G2CONF} --enable-debug=yes"
+ fi
+
+ G2CONF="${G2CONF} $(use_with X x)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # make config file location host specific so that a 32bit and 64bit pango
+ # wont fight with each other on a multilib system. Fix building for
+ # emul-linux-x86-gtklibs
+ if multilib_enabled ; then
+ epatch "${FILESDIR}/${PN}-1.2.5-lib64.patch"
+ fi
+
+ epunt_cxx
+}
+
+src_install() {
+ gnome2_src_install
+ rm "${D}/etc/pango/pango.modules"
+}
+
+pkg_postinst() {
+ if [[ "${ROOT}" == "/" ]] ; then
+ einfo "Generating modules listing..."
+
+ local PANGO_CONFDIR=
+
+ if multilib_enabled ; then
+ PANGO_CONFDIR="/etc/pango/${CHOST}"
+ else
+ PANGO_CONFDIR="/etc/pango"
+ fi
+
+ mkdir -p ${PANGO_CONFDIR}
+
+ pango-querymodules > ${PANGO_CONFDIR}/pango.modules
+ fi
+}