summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-06-24 20:39:39 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-06-24 20:39:39 +0000
commit83eb06a1d351b611e89b177750974e268f5ec97d (patch)
tree7b585dd51b87b74630d923324f1a2a07f55943f9 /x11-libs/libnotify
parentStable on ppc64; bug #137875 (diff)
downloadgentoo-2-83eb06a1d351b611e89b177750974e268f5ec97d.tar.gz
gentoo-2-83eb06a1d351b611e89b177750974e268f5ec97d.tar.bz2
gentoo-2-83eb06a1d351b611e89b177750974e268f5ec97d.zip
version bump from upstream, patch from bug #137792
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'x11-libs/libnotify')
-rw-r--r--x11-libs/libnotify/ChangeLog8
-rw-r--r--x11-libs/libnotify/files/digest-libnotify-0.4.23
-rw-r--r--x11-libs/libnotify/files/libnotify-0.4.2-send-uchar-array.patch20
-rw-r--r--x11-libs/libnotify/libnotify-0.4.2.ebuild38
4 files changed, 68 insertions, 1 deletions
diff --git a/x11-libs/libnotify/ChangeLog b/x11-libs/libnotify/ChangeLog
index d08174951f9b..115464e29d77 100644
--- a/x11-libs/libnotify/ChangeLog
+++ b/x11-libs/libnotify/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libnotify
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/ChangeLog,v 1.7 2006/04/28 00:02:15 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/ChangeLog,v 1.8 2006/06/24 20:39:39 compnerd Exp $
+
+*libnotify-0.4.2 (24 Jun 2006)
+
+ 24 Jun 2006; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/libnotify-0.4.2-send-uchar-array.patch, +libnotify-0.4.2.ebuild:
+ Version bump from upstream, patch from bug #137792
27 Apr 2006; Alec Warner <antarus@gentoo.org> Manifest:
Fixing SHA256 digest, pass four
diff --git a/x11-libs/libnotify/files/digest-libnotify-0.4.2 b/x11-libs/libnotify/files/digest-libnotify-0.4.2
new file mode 100644
index 000000000000..1cf2b1611eea
--- /dev/null
+++ b/x11-libs/libnotify/files/digest-libnotify-0.4.2
@@ -0,0 +1,3 @@
+MD5 25585318503079a513af7064bb59c04d libnotify-0.4.2.tar.gz 388355
+RMD160 6a2bc403a927571480683b5ffa3d40ecb482e24f libnotify-0.4.2.tar.gz 388355
+SHA256 9e95499badd1b0da67b1422caa4198dbe61c961300b7001173eace18b8b2c38e libnotify-0.4.2.tar.gz 388355
diff --git a/x11-libs/libnotify/files/libnotify-0.4.2-send-uchar-array.patch b/x11-libs/libnotify/files/libnotify-0.4.2-send-uchar-array.patch
new file mode 100644
index 000000000000..e23d7d1af15a
--- /dev/null
+++ b/x11-libs/libnotify/files/libnotify-0.4.2-send-uchar-array.patch
@@ -0,0 +1,20 @@
+--- libnotify/notification.c 2006-06-24 15:12:58.000000000 -0500
++++ libnotify/notification.c 2006-06-24 15:14:01.000000000 -0500
+@@ -901,7 +901,7 @@
+ return FALSE;
+ }
+
+- g_value_init(value, dbus_g_type_get_collection("GArray", G_TYPE_CHAR));
++ g_value_init(value, DBUS_TYPE_G_UCHAR_ARRAY);
+ g_value_set_boxed_take_ownership(value, byte_array);
+ g_value_array_append(array, value);
+
+@@ -961,7 +961,7 @@
+
+ value = g_new0(GValue, 1);
+ g_value_init(value, G_TYPE_VALUE_ARRAY);
+- g_value_set_boxed(value, image_struct);
++ g_value_set_boxed_take_ownership(value, image_struct);
+
+ g_hash_table_insert(notification->priv->hints,
+ g_strdup("icon_data"), value);
diff --git a/x11-libs/libnotify/libnotify-0.4.2.ebuild b/x11-libs/libnotify/libnotify-0.4.2.ebuild
new file mode 100644
index 000000000000..0e1dba73b75b
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/libnotify-0.4.2.ebuild,v 1.1 2006/06/24 20:39:39 compnerd Exp $
+
+inherit eutils
+
+DESCRIPTION="Notifications library"
+HOMEPAGE="http://www.galago-project.org/"
+SRC_URI="http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2.2.2
+ >=dev-libs/glib-2.6
+ >=sys-apps/dbus-0.60
+ x11-misc/notification-daemon"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-0.4.2-send-uchar-array.patch
+}
+
+src_compile() {
+ econf $(use_enable doc gtk-doc) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS
+}