summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-05-10 10:09:28 +0000
committerUlrich Müller <ulm@gentoo.org>2008-05-10 10:09:28 +0000
commit010e4c993f49aa4bef1efbc2d067463bf7e9d353 (patch)
treef8517128d018b4691313334abc2960066c5a79c0 /x11-libs/lesstif
parentforgotten commit (diff)
downloadgentoo-2-010e4c993f49aa4bef1efbc2d067463bf7e9d353.tar.gz
gentoo-2-010e4c993f49aa4bef1efbc2d067463bf7e9d353.tar.bz2
gentoo-2-010e4c993f49aa4bef1efbc2d067463bf7e9d353.zip
Ebuild completely rewritten: SLOTting is finally gone.
(Portage version: 2.1.5_rc9)
Diffstat (limited to 'x11-libs/lesstif')
-rw-r--r--x11-libs/lesstif/ChangeLog16
-rw-r--r--x11-libs/lesstif/files/lesstif-0.95.0-vendorsp-cxx.patch17
-rw-r--r--x11-libs/lesstif/lesstif-0.95.0-r1.ebuild64
3 files changed, 96 insertions, 1 deletions
diff --git a/x11-libs/lesstif/ChangeLog b/x11-libs/lesstif/ChangeLog
index befc12f1dd0b..c23031c234de 100644
--- a/x11-libs/lesstif/ChangeLog
+++ b/x11-libs/lesstif/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for x11-libs/lesstif
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/lesstif/ChangeLog,v 1.86 2008/04/21 18:26:02 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/lesstif/ChangeLog,v 1.87 2008/05/10 10:09:27 ulm Exp $
+
+*lesstif-0.95.0-r1 (10 May 2008)
+
+ 10 May 2008; Ulrich Mueller <ulm@gentoo.org>
+ +files/lesstif-0.95.0-vendorsp-cxx.patch, +lesstif-0.95.0-r1.ebuild:
+ Ebuild completely rewritten: SLOTting is finally gone. Install libraries,
+ include files, and man pages in their standard locations. No more need for
+ motif-config and profile manipulation. Libtool tweaks to fix linkage against
+ already installed version are no longer needed. Fix issue with inclusion
+ of VendorSP.h in C++ code, original issue of bug 193505, patch extracted
+ from upstream CVS. Update LICENSE: add libXpm; add GPL-2 and FVWM for mwm.
+ Dependencies scrutinised and fixed: libXft/freetype is needed also at run
+ time, remove unnecessary libXaw and perl, remove redundant printproto.
+ Block against openmotif and motif-config.
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/x11-libs/lesstif/files/lesstif-0.95.0-vendorsp-cxx.patch b/x11-libs/lesstif/files/lesstif-0.95.0-vendorsp-cxx.patch
new file mode 100644
index 000000000000..21706f81023b
--- /dev/null
+++ b/x11-libs/lesstif/files/lesstif-0.95.0-vendorsp-cxx.patch
@@ -0,0 +1,17 @@
+--- lesstif-0.95.0-orig/include/Motif-2.1/Xm/VendorSP.h 2004/08/28 19:23:27 1.1
++++ lesstif-0.95.0/include/Motif-2.1/Xm/VendorSP.h 2007/09/12 20:34:52 1.2
+@@ -28,12 +28,13 @@
+
+ #include <Xm/XmP.h>
+ #include <Xm/VendorS.h>
+-#include <X11/ShellP.h>
+
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+
++#include <X11/ShellP.h>
++
+ XMLIBEXPORT extern Cardinal _XmFilterResources(XtResource *resources,
+ Cardinal numResources,
+ WidgetClass filterClass,
diff --git a/x11-libs/lesstif/lesstif-0.95.0-r1.ebuild b/x11-libs/lesstif/lesstif-0.95.0-r1.ebuild
new file mode 100644
index 000000000000..64b814a544ce
--- /dev/null
+++ b/x11-libs/lesstif/lesstif-0.95.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/lesstif/lesstif-0.95.0-r1.ebuild,v 1.1 2008/05/10 10:09:27 ulm Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="An OSF/Motif(R) clone"
+HOMEPAGE="http://www.lesstif.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2 GPL-2 libXpm FVWM"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="static"
+
+RDEPEND="!x11-libs/motif-config
+ !x11-libs/openmotif
+ !<=x11-libs/lesstif-0.95.0
+ x11-libs/libXp
+ x11-libs/libXt
+ x11-libs/libXft"
+
+DEPEND="${RDEPEND}"
+
+PROVIDE="virtual/motif"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/CAN-2005-0605.patch"
+ epatch "${FILESDIR}/${P}-vendorsp-cxx.patch"
+}
+
+src_compile() {
+ econf \
+ $(use_enable static) \
+ --enable-production \
+ --enable-verbose=no \
+ --with-x || die "econf failed"
+
+ emake CFLAGS="${CFLAGS}" \
+ mwmddir=/etc/X11/mwm \
+ || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF}/html \
+ appdir=/usr/share/X11/app-defaults \
+ mwmddir=/etc/X11/mwm \
+ install || die "emake install failed"
+
+ dodoc AUTHORS BUG-REPORTING ChangeLog CREDITS FAQ NEWS README \
+ ReleaseNotes.txt
+ newdoc "${D}"/etc/X11/mwm/README README.mwm
+
+ # cleanup
+ rm -f "${D}"/etc/X11/mwm/README
+ rm -f "${D}"/usr/bin/motif-config
+ rm -f "${D}"/usr/bin/mxmkmf
+ rm -fR "${D}"/usr/LessTif
+ rm -fR "${D}"/usr/$(get_libdir)/LessTif
+ rm -fR "${D}"/usr/share/aclocal/
+}