summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-19 03:48:07 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-19 03:48:07 +0000
commit8bc33b49a125fa6a310ac37d4ca45643ffef786e (patch)
tree005e7fcd93925f44dfbb27f64da33bea190f0ad2 /x11-libs/gtk+
parentUnmask USE="packagekit" for x11-libs/gtk+. (diff)
downloadgentoo-2-8bc33b49a125fa6a310ac37d4ca45643ffef786e.tar.gz
gentoo-2-8bc33b49a125fa6a310ac37d4ca45643ffef786e.tar.bz2
gentoo-2-8bc33b49a125fa6a310ac37d4ca45643ffef786e.zip
Add gtk+-3.2.1 from the gnome overlay. Fix a failing test and skip ones which cannot be fixed (e.g. for bug #384855).
(Portage version: 2.2.0_alpha69/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog20
-rw-r--r--x11-libs/gtk+/files/gtk+-3.2.1-failing-tests.patch25
-rw-r--r--x11-libs/gtk+/files/gtk+-3.2.1-selector.errors1
-rw-r--r--x11-libs/gtk+/gtk+-3.2.1.ebuild197
-rw-r--r--x11-libs/gtk+/metadata.xml4
5 files changed, 246 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 18694d267edc..d8639c5149fc 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,24 @@
# ChangeLog for x11-libs/gtk+
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.536 2011/10/18 18:43:56 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.537 2011/10/19 03:48:07 tetromino Exp $
+
+*gtk+-3.2.1 (19 Oct 2011)
+
+ 19 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org> +gtk+-3.2.1.ebuild,
+ +files/gtk+-3.2.1-failing-tests.patch, +files/gtk+-3.2.1-selector.errors,
+ metadata.xml:
+ Add gtk+-3.2.1 from the gnome overlay. Disable failing treeview scrolling
+ tests (see bug #384855 and https://bugzilla.gnome.org/show_bug.cgi?id=660931),
+ add missing selectors.errors file (needed for the css parser test),
+ completely skip reftests (many of them fail when building from portage, but
+ strangely enough succeed when building from my home directory; need to
+ investigate why), and disable a11y picker test (GtkFileChooserButton look
+ depends on list of mounted filesystems).
+
+ Notable changes: *lots* (better theming, including a new CSS parser, and dark
+ theme variants; better XInput2 support; gail is no longer a module; tree
+ model improvements; more widgets support height-for-width;
+ GtkFontChooserDialog, GtkLockButton, GtkOverlay).
*gtk+-2.24.7 (18 Oct 2011)
diff --git a/x11-libs/gtk+/files/gtk+-3.2.1-failing-tests.patch b/x11-libs/gtk+/files/gtk+-3.2.1-failing-tests.patch
new file mode 100644
index 000000000000..ca7c896c11c2
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-3.2.1-failing-tests.patch
@@ -0,0 +1,25 @@
+Skip failing tests. See bug #384855 and https://bugzilla.gnome.org/show_bug.cgi?id=660931
+
+diff --git a/gtk/tests/treeview-scrolling.c b/gtk/tests/treeview-scrolling.c
+index 63bf429..0f8bafd 100644
+--- a/gtk/tests/treeview-scrolling.c
++++ b/gtk/tests/treeview-scrolling.c
+@@ -1300,7 +1300,6 @@ add_tests (gboolean mixed,
+ add_test ("750", mixed, test_type, use_align, row_align, setup, scroll_func);
+ add_test ("990", mixed, test_type, use_align, row_align, setup, scroll_func);
+ add_test ("991", mixed, test_type, use_align, row_align, setup, scroll_func);
+- add_test ("995", mixed, test_type, use_align, row_align, setup, scroll_func);
+ add_test ("997", mixed, test_type, use_align, row_align, setup, scroll_func);
+ add_test ("999", mixed, test_type, use_align, row_align, setup, scroll_func);
+ }
+@@ -1491,10 +1490,6 @@ main (int argc, char **argv)
+ ScrollFixture, NULL,
+ scroll_fixture_tree_setup, test_bug93584,
+ scroll_fixture_teardown);
+- g_test_add ("/TreeView/scrolling/specific/bug-111500",
+- ScrollFixture, NULL,
+- scroll_fixture_tree_setup, test_bug111500,
+- scroll_fixture_teardown);
+ g_test_add ("/TreeView/scrolling/specific/bug-111500-mixed",
+ ScrollFixture, NULL,
+ scroll_fixture_mixed_tree_setup, test_bug111500_mixed,
diff --git a/x11-libs/gtk+/files/gtk+-3.2.1-selector.errors b/x11-libs/gtk+/files/gtk+-3.2.1-selector.errors
new file mode 100644
index 000000000000..42cc16e1d308
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-3.2.1-selector.errors
@@ -0,0 +1 @@
+selector.css:201: error: GTK_CSS_PROVIDER_ERROR_SYNTAX
diff --git a/x11-libs/gtk+/gtk+-3.2.1.ebuild b/x11-libs/gtk+/gtk+-3.2.1.ebuild
new file mode 100644
index 000000000000..984fe7e425b5
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-3.2.1.ebuild
@@ -0,0 +1,197 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-3.2.1.ebuild,v 1.1 2011/10/19 03:48:07 tetromino Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic gnome.org gnome2-utils libtool virtualx
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="3"
+# NOTE: This gtk+ has multi-gdk-backend support, see:
+# * http://blogs.gnome.org/kris/2010/12/29/gdk-3-0-on-mac-os-x/
+# * http://mail.gnome.org/archives/gtk-devel-list/2010-November/msg00099.html
+# I tried this and got it all compiling, but the end result is unusable as it
+# horribly mixes up the backends -- grobian
+IUSE="aqua colord cups debug doc examples +introspection packagekit test vim-syntax xinerama"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# FIXME: introspection data is built against system installation of gtk+:3
+# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
+# Use gtk+:2 for gtk-update-icon-cache and gtk-builder-convert
+# >=x11-libs/gtk+-2.24:2 is needed for bug 359555
+COMMON_DEPEND="!aqua? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXt
+ x11-libs/libXext
+ >=x11-libs/libXrandr-1.3
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ >=x11-libs/cairo-1.10.0[X,glib,svg]
+ >=x11-libs/gdk-pixbuf-2.23.5:2[X,introspection?]
+ )
+ aqua? (
+ >=x11-libs/cairo-1.10.0[aqua,glib,svg]
+ >=x11-libs/gdk-pixbuf-2.23.5:2[introspection?]
+ )
+ xinerama? ( x11-libs/libXinerama )
+ >=dev-libs/glib-2.29.14
+ >=x11-libs/pango-1.29.0[introspection?]
+ >=dev-libs/atk-2.1.5[introspection?]
+ >=x11-libs/gtk+-2.24:2
+ media-libs/fontconfig
+ x11-misc/shared-mime-info
+ colord? ( >=x11-misc/colord-0.1.9 )
+ cups? ( net-print/cups )
+ introspection? ( >=dev-libs/gobject-introspection-0.10.1 )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/pkgconfig-0.9
+ !aqua? (
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/damageproto
+ )
+ xinerama? ( x11-proto/xineramaproto )
+ >=dev-util/gtk-doc-am-1.11
+ doc? (
+ >=dev-util/gtk-doc-1.11
+ ~app-text/docbook-xml-dtd-4.1.2 )
+ test? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc )"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gail-1000
+ packagekit? ( app-admin/packagekit-base )"
+PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
+
+strip_builddir() {
+ local rule=$1
+ shift
+ local directory=$1
+ shift
+ sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
+ || die "Could not strip director ${directory} from build."
+}
+
+src_prepare() {
+ # -O3 and company cause random crashes in applications. Bug #133469
+ replace-flags -O3 -O2
+ strip-flags
+
+ # Non-working test in gentoo's env
+ sed 's:\(g_test_add_func ("/ui-tests/keys-events.*\):/*\1*/:g' \
+ -i gtk/tests/testing.c || die "sed 1 failed"
+ sed '\%/recent-manager/add%,/recent_manager_purge/ d' \
+ -i gtk/tests/recentmanager.c || die "sed 2 failed"
+
+ # Missing file, required for tests; https://bugzilla.gnome.org/show_bug.cgi?id=662024
+ cp "${FILESDIR}/${PN}-3.2.1-selector.errors" \
+ tests/css/parser/selector.errors || die "cp failed"
+
+ # FIXME: multiple reftests fail when run from portage (but succeed when
+ # run from a manual compile in a temp directory)
+ sed -e 's:\(SUBDIRS.*\)reftests:\1:' \
+ -i tests/Makefile.* || die "sed 3 failed"
+
+ # Test results depend on the list of mounted filesystems!
+ rm tests/a11y/pickers.{ui,txt} || die "rm failed"
+
+ # Failing treeview scrolling tests; bug #384855,
+ # https://bugzilla.gnome.org/show_bug.cgi?id=660931
+ epatch "${FILESDIR}/${PN}-3.2.1-failing-tests.patch"
+
+ if ! use test; then
+ # don't waste time building tests
+ strip_builddir SRC_SUBDIRS tests Makefile.am
+ strip_builddir SRC_SUBDIRS tests Makefile.in
+ fi
+
+ if ! use examples; then
+ # don't waste time building demos
+ strip_builddir SRC_SUBDIRS demos Makefile.am
+ strip_builddir SRC_SUBDIRS demos Makefile.in
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # png always on to display icons (foser)
+ local myconf="$(use_enable doc gtk-doc)
+ $(use_enable xinerama)
+ $(use_enable packagekit)
+ $(use_enable cups cups auto)
+ $(use_enable colord)
+ $(use_enable introspection)
+ --disable-papi
+ --enable-gtk2-dependency"
+
+ # XXX: Maybe with multi-backend we should enable x11 all the time?
+ if use aqua; then
+ myconf="${myconf} --enable-quartz-backend --disable-xinput"
+ else
+ myconf="${myconf} --enable-x11-backend --enable-xinput"
+ fi
+
+ # Passing --disable-debug is not recommended for production use
+ use debug && myconf="${myconf} --enable-debug=yes"
+
+ # need libdir here to avoid a double slash in a path that libtool doesn't
+ # grok so well during install (// between $EPREFIX and usr ...)
+ econf --libdir="${EPREFIX}/usr/$(get_libdir)" ${myconf}
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ # Exporting HOME fixes tests using XDG directories spec since all defaults
+ # are based on $HOME. It is also backward compatible with functions not
+ # yet ported to this spec.
+ XDG_DATA_HOME="${T}" HOME="${T}" Xemake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/gtk-3.0
+ doins "${FILESDIR}"/settings.ini
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README*
+
+ # Remove unneeded *.la files
+ find "${ED}" -name "*.la" -delete
+
+ # add -framework Carbon to the .pc files
+ use aqua && for i in gtk+-3.0.pc gtk+-quartz-3.0.pc gtk+-unix-print-3.0.pc; do
+ sed -i -e "s:Libs\: :Libs\: -framework Carbon :" "${ED}"usr/$(get_libdir)/pkgconfig/$i || die "sed failed"
+ done
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+
+ local GTK3_MODDIR="${EROOT}usr/$(get_libdir)/gtk-3.0/3.0.0"
+ gtk-query-immodules-3.0 > "${GTK3_MODDIR}/immodules.cache" \
+ || ewarn "Failed to run gtk-query-immodules-3.0"
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your settings.ini file."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_schemas_update --uninstall
+}
diff --git a/x11-libs/gtk+/metadata.xml b/x11-libs/gtk+/metadata.xml
index 028313934c81..3ae90e713edc 100644
--- a/x11-libs/gtk+/metadata.xml
+++ b/x11-libs/gtk+/metadata.xml
@@ -9,7 +9,11 @@
application suites.
</longdescription>
<use>
+ <flag name="colord">Use <pkg>x11-misc/colord</pkg> for color management
+ in printing</flag>
<flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
for introspection</flag>
+ <flag name="packagekit">Enable support for the distro-neutral package
+ manager GUI <pkg>app-admin/packagekit</pkg> in application chooser</flag>
</use>
</pkgmetadata>