summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2004-02-18 15:34:30 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2004-02-18 15:34:30 +0000
commite634c5ef453d8bd91a02d03366f69c447bd895cd (patch)
tree13b5e3637fc99fcd7f5efd2ce74e8983efa3c0c1 /x11-libs/gai
parentmarked 0.4.5 stable on x86; added dep for sys-apps/chpax in 0.4.4 Bug 39542 (... (diff)
downloadgentoo-2-e634c5ef453d8bd91a02d03366f69c447bd895cd.tar.gz
gentoo-2-e634c5ef453d8bd91a02d03366f69c447bd895cd.tar.bz2
gentoo-2-e634c5ef453d8bd91a02d03366f69c447bd895cd.zip
version bump
Diffstat (limited to 'x11-libs/gai')
-rw-r--r--x11-libs/gai/ChangeLog7
-rw-r--r--x11-libs/gai/Manifest4
-rw-r--r--x11-libs/gai/files/digest-gai-0.5.21
-rw-r--r--x11-libs/gai/gai-0.5.2.ebuild53
4 files changed, 64 insertions, 1 deletions
diff --git a/x11-libs/gai/ChangeLog b/x11-libs/gai/ChangeLog
index f14ffd6db333..c16a3266ec4c 100644
--- a/x11-libs/gai/ChangeLog
+++ b/x11-libs/gai/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gai
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gai/ChangeLog,v 1.3 2004/01/11 01:18:50 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gai/ChangeLog,v 1.4 2004/02/18 15:34:30 lordvan Exp $
+
+*gai-0.5.2 (18 Feb 2004)
+
+ 18 Feb 2004; Thomas Raschbacher <lordvan@gentoo.org> gai-0.5.2.ebuild:
+ version bump (Bug #39046)
10 Jan 2004; Seemant Kulleen <seemant@gentoo.org> gai-0.5.0_pre6.ebuild:
Upstream needs to learn the definition of consistency -- use_enable and
diff --git a/x11-libs/gai/Manifest b/x11-libs/gai/Manifest
index e4f34355f364..3a898df67757 100644
--- a/x11-libs/gai/Manifest
+++ b/x11-libs/gai/Manifest
@@ -1,4 +1,8 @@
MD5 41d0a3243e5ad6a4fec48c12c31b21d4 gai-0.5.0_pre6.ebuild 1462
+MD5 41d0a3243e5ad6a4fec48c12c31b21d4 gai-0.5.2.ebuild 1462
+MD5 41d0a3243e5ad6a4fec48c12c31b21d4 gai-0.5.1.ebuild 1462
MD5 1eda3d80bdd13ad6437e74e159224de9 ChangeLog 901
MD5 4de810beafe6af976494dfe29abd5c60 metadata.xml 405
MD5 2cc1df4e270e1be3a526f9609c89accc files/digest-gai-0.5.0_pre6 66
+MD5 8883ea189899edb5e2e110b8e2ab86c1 files/digest-gai-0.5.1 62
+MD5 72db507aad739b6917552b17dac52b3c files/digest-gai-0.5.2 62
diff --git a/x11-libs/gai/files/digest-gai-0.5.2 b/x11-libs/gai/files/digest-gai-0.5.2
new file mode 100644
index 000000000000..3a8d4fdb3e19
--- /dev/null
+++ b/x11-libs/gai/files/digest-gai-0.5.2
@@ -0,0 +1 @@
+MD5 a9d53513b002cedabf2a1ee29ad2d712 gai-0.5.2.tar.bz2 185549
diff --git a/x11-libs/gai/gai-0.5.2.ebuild b/x11-libs/gai/gai-0.5.2.ebuild
new file mode 100644
index 000000000000..1902c2cc4603
--- /dev/null
+++ b/x11-libs/gai/gai-0.5.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gai/gai-0.5.2.ebuild,v 1.1 2004/02/18 15:34:30 lordvan Exp $
+
+IUSE="opengl gnome"
+
+MY_P=${P/_/}
+DESCRIPTION="GAI, The General Applet Interface library is a library that will help applet programmers alot."
+HOMEPAGE="http://gai.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gai/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=x11-libs/gtk+-2.0.0
+ opengl? ( >=x11-libs/gtkglext-1.0.5 )
+ gnome? ( >=gnome-base/gnome-panel-2.0.0 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # works with just set prefix (doesn't hardcode the prefix anywhere)!
+ local myconf
+
+ # Someone please tell upstream that the way to enable/disable things in
+ # configure scripts should be bloody well consistent -- it's in poor taste
+ # and downright incompetent to have to use --with if you want something
+ # and --disable if you don't
+
+ use opengl \
+ && myconf="${myconf} --with-gl" \
+ || myconf="${myconf} --disable-gl"
+
+ use gnome \
+ && myconf="${myconf} --with-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ econf \
+ --prefix=${D}/usr \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS BUGS COPYING.LIB ChangeLog INSTALL README \
+ README.gai THANKS TODO WINDOWMANAGERS
+ dohtml ${S}/docs/*
+ # install examples
+ cp -r ${S}/examples ${D}/usr/share/doc/${P}
+}