summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-01-25 07:45:49 +0000
committerTod Neidt <tod@gentoo.org>2002-01-25 07:45:49 +0000
commit58fb265d7945a68fb000cbf322e71032c85baa27 (patch)
tree59c303530d0ce23943824e806e9814f0791a497c /x11-libs/fltk
parentupdated (diff)
downloadgentoo-2-58fb265d7945a68fb000cbf322e71032c85baa27.tar.gz
gentoo-2-58fb265d7945a68fb000cbf322e71032c85baa27.tar.bz2
gentoo-2-58fb265d7945a68fb000cbf322e71032c85baa27.zip
updated syntax and install directory
Diffstat (limited to 'x11-libs/fltk')
-rw-r--r--x11-libs/fltk/files/digest-fltk-1.0.11-r11
-rw-r--r--x11-libs/fltk/fltk-1.0.11-r1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-libs/fltk/files/digest-fltk-1.0.11-r1 b/x11-libs/fltk/files/digest-fltk-1.0.11-r1
new file mode 100644
index 000000000000..49d88f4dca4c
--- /dev/null
+++ b/x11-libs/fltk/files/digest-fltk-1.0.11-r1
@@ -0,0 +1 @@
+MD5 e917767d012bcd8953a5d811e68134ff fltk-1.0.11-source.tar.bz2 999424
diff --git a/x11-libs/fltk/fltk-1.0.11-r1.ebuild b/x11-libs/fltk/fltk-1.0.11-r1.ebuild
new file mode 100644
index 000000000000..38fe21d1be5a
--- /dev/null
+++ b/x11-libs/fltk/fltk-1.0.11-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# /space/gentoo/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.0.11.ebuild,v 1.2 2001/06/04 00:16:12 achim Exp
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="C++ user interface toolkit for X and OpenGL."
+
+SRC_URI="ftp://ftp.fltk.org/pub/fltk/${MYVER}/${P}-source.tar.bz2"
+
+HOMEPAGE="http://www.fltk.org"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ opengl? ( virtual/opengl )"
+
+
+src_compile() {
+
+ local myconf
+ #shared libraries diabled by default
+ myconf="--enable-shared"
+
+ use opengl || myconf="$myconf --disable-gl" #default enabled
+
+#Learned '${prefix}' trick from studying python ebuild
+#There are no info files
+ ./configure \
+ --prefix=/usr \
+ --mandir='${prefix}'/share/man \
+ --host=${CHOST} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr/ \
+ install || die "Installation Failed"
+
+ dodoc CHANGES COPYING README
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/fltk/* ${D}/usr/share/doc/${PF}/html
+ rmdir ${D}/usr/share/doc/fltk
+
+}
+