summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-07-08 11:34:48 +0000
committerBen de Groot <yngwin@gentoo.org>2009-07-08 11:34:48 +0000
commit161f8e9f8af09555faa7d2de5adf6e52291d3625 (patch)
tree9434f3e678f61fab5780d71cc463e97d0a312921 /x11-libs/fltk
parentAdd same mask to hardened/linux to work around this design fail of not having... (diff)
downloadgentoo-2-161f8e9f8af09555faa7d2de5adf6e52291d3625.tar.gz
gentoo-2-161f8e9f8af09555faa7d2de5adf6e52291d3625.tar.bz2
gentoo-2-161f8e9f8af09555faa7d2de5adf6e52291d3625.zip
Remove glibc-2.10 patches from 1.1.9 and 2.0_pre6786, so they can be stabled. Reapplied those patches to the -r1 ebuilds, so it works for ~arch users.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/fltk')
-rw-r--r--x11-libs/fltk/ChangeLog12
-rw-r--r--x11-libs/fltk/fltk-1.1.9-r1.ebuild133
-rw-r--r--x11-libs/fltk/fltk-1.1.9.ebuild9
-rw-r--r--x11-libs/fltk/fltk-2.0_pre6786-r1.ebuild84
-rw-r--r--x11-libs/fltk/fltk-2.0_pre6786.ebuild6
5 files changed, 234 insertions, 10 deletions
diff --git a/x11-libs/fltk/ChangeLog b/x11-libs/fltk/ChangeLog
index 999e2ef90b04..00d23f2fa016 100644
--- a/x11-libs/fltk/ChangeLog
+++ b/x11-libs/fltk/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-libs/fltk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.116 2009/07/05 08:37:00 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.117 2009/07/08 11:34:48 yngwin Exp $
+
+*fltk-2.0_pre6786-r1 (08 Jul 2009)
+*fltk-1.1.9-r1 (08 Jul 2009)
+
+ 08 Jul 2009; Ben de Groot <yngwin@gentoo.org> fltk-1.1.9.ebuild,
+ +fltk-1.1.9-r1.ebuild, fltk-2.0_pre6786.ebuild,
+ +fltk-2.0_pre6786-r1.ebuild:
+ Remove glibc-2.10 patches from 1.1.9 and 2.0_pre6786, so they can be
+ stabled. Reapplied those patches to the -r1 ebuilds, so it works for ~arch
+ users.
05 Jul 2009; Ben de Groot <yngwin@gentoo.org> fltk-1.1.9.ebuild,
+files/fltk-1.1.9-consts.patch, +files/fltk-1.1.9-glibc2.10-scandir.patch:
diff --git a/x11-libs/fltk/fltk-1.1.9-r1.ebuild b/x11-libs/fltk/fltk-1.1.9-r1.ebuild
new file mode 100644
index 000000000000..44debc14dcbd
--- /dev/null
+++ b/x11-libs/fltk/fltk-1.1.9-r1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.9-r1.ebuild,v 1.1 2009/07/08 11:34:48 yngwin Exp $
+
+EAPI=2
+inherit eutils autotools versionator fdo-mime
+
+DESCRIPTION="C++ user interface toolkit for X and OpenGL."
+HOMEPAGE="http://www.fltk.org"
+SRC_URI="mirror://easysw/${PN}/${PV}/${P}-source.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="FLTK LGPL-2"
+
+SLOT="$(get_version_component_range 1-2)"
+
+IUSE="doc examples games opengl threads xft xinerama"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXt
+ media-libs/jpeg
+ media-libs/libpng
+ sys-libs/zlib
+ opengl? ( virtual/opengl virtual/glu )
+ xinerama? ( x11-libs/libXinerama )
+ xft? ( x11-libs/libXft )
+ >=sys-libs/glibc-2.10" # glibc-2.10 patch breaks with 2.9, bug 276695
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ doc? ( app-text/htmldoc )
+ xinerama? ( x11-proto/xineramaproto )"
+
+INCDIR=/usr/include/fltk-${SLOT}
+LIBDIR=/usr/$(get_libdir)/fltk-${SLOT}
+
+src_prepare() {
+ #epatch "${FILESDIR}"/${P}-fromdebian.patch
+ epatch "${FILESDIR}"/${P}-desktop.patch
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ # prevent to run twice configure (needs eautoconf), to compile tests,
+ # remove forced -Os compile
+ epatch "${FILESDIR}"/${P}-conf-tests.patch
+ # fix stricter c++ handling in glibc-2.10/gcc-4.4 (bug 270487)
+ epatch "${FILESDIR}"/${P}-glibc2.10-scandir.patch
+ epatch "${FILESDIR}"/${P}-consts.patch
+ # remove forced flags from fltk-config
+ sed -i \
+ -e '/C\(XX\)\?FLAGS=/s:@C\(XX\)\?FLAGS@::' \
+ -e '/^LDFLAGS=/d' \
+ "${S}/fltk-config.in" || die
+ # some fixes introduced because slotting
+ sed -i \
+ -e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \
+ src/Makefile || die
+ # docs in proper docdir
+ sed -i \
+ -e "/^docdir/s:fltk:${PF}/html:" \
+ makeinclude.in || die
+ sed -e "s/7/$(get_version_component_range 3)/" \
+ "${FILESDIR}"/FLTKConfig.cmake > CMake/FLTKConfig.cmake
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --includedir=${INCDIR}\
+ --libdir=${LIBDIR} \
+ --docdir=/usr/share/doc/${PF}/html \
+ --enable-largefile \
+ --enable-shared \
+ --enable-xdbe \
+ $(use_enable opengl gl) \
+ $(use_enable threads) \
+ $(use_enable xft) \
+ $(use_enable xinerama)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ cd "${S}"/documentation
+ emake alldocs || die "emake doc failed"
+ fi
+ if use games; then
+ cd "${S}"/test
+ emake blocks checkers sudoku || die "emake games failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ emake -C fluid \
+ DESTDIR="${D}" install-linux || die "emake install fluid failed"
+ if use doc; then
+ emake -C documentation \
+ DESTDIR="${D}" install || die "emake install doc failed"
+ fi
+ local apps="fluid"
+ if use games; then
+ emake -C test \
+ DESTDIR="${D}" install-linux || die "emake install games failed"
+ emake -C documentation \
+ DESTDIR="${D}" install-linux || die "emake install doc games failed"
+ apps="${apps} sudoku blocks checkers"
+ fi
+ for app in ${apps}; do
+ dosym /usr/share/icons/hicolor/32x32/apps/${app}.png \
+ /usr/share/pixmaps/${app}.png
+ done
+ dodoc CHANGES README CREDITS ANNOUNCEMENT
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins test/*.{h,cxx,fl} test/demo.menu
+ fi
+
+ insinto /usr/share/cmake/Modules
+ doins CMake/FLTK*.cmake
+
+ echo "LDPATH=${LIBDIR}" > 99fltk-${SLOT}
+ echo "FLTK_DOCDIR=/usr/share/doc/${PF}/html" >> 99fltk-${SLOT}
+ doenvd 99fltk-${SLOT}
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/x11-libs/fltk/fltk-1.1.9.ebuild b/x11-libs/fltk/fltk-1.1.9.ebuild
index b062d68f08b1..e3f3eb23f7e4 100644
--- a/x11-libs/fltk/fltk-1.1.9.ebuild
+++ b/x11-libs/fltk/fltk-1.1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.9.ebuild,v 1.6 2009/07/05 08:37:00 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.9.ebuild,v 1.7 2009/07/08 11:34:48 yngwin Exp $
EAPI=2
inherit eutils autotools versionator fdo-mime
@@ -25,8 +25,8 @@ RDEPEND="x11-libs/libXext
sys-libs/zlib
opengl? ( virtual/opengl virtual/glu )
xinerama? ( x11-libs/libXinerama )
- xft? ( x11-libs/libXft )"
-
+ xft? ( x11-libs/libXft )
+ <sys-libs/glibc-2.10" # glibc-2.10 patch breaks with 2.9, bug 276695
DEPEND="${RDEPEND}
x11-proto/xextproto
doc? ( app-text/htmldoc )
@@ -42,9 +42,6 @@ src_prepare() {
# prevent to run twice configure (needs eautoconf), to compile tests,
# remove forced -Os compile
epatch "${FILESDIR}"/${P}-conf-tests.patch
- # fix stricter c++ handling in glibc-2.10/gcc-4.4 (bug 270487)
- epatch "${FILESDIR}"/${P}-glibc2.10-scandir.patch
- epatch "${FILESDIR}"/${P}-consts.patch
# remove forced flags from fltk-config
sed -i \
-e '/C\(XX\)\?FLAGS=/s:@C\(XX\)\?FLAGS@::' \
diff --git a/x11-libs/fltk/fltk-2.0_pre6786-r1.ebuild b/x11-libs/fltk/fltk-2.0_pre6786-r1.ebuild
new file mode 100644
index 000000000000..805519095b0f
--- /dev/null
+++ b/x11-libs/fltk/fltk-2.0_pre6786-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-2.0_pre6786-r1.ebuild,v 1.1 2009/07/08 11:34:48 yngwin Exp $
+
+EAPI="2"
+inherit multilib autotools flag-o-matic
+
+MY_P=${P/_pre/.x-r}
+DESCRIPTION="C++ user interface toolkit for X and OpenGL"
+HOMEPAGE="http://www.fltk.org/"
+SRC_URI="mirror://easysw/fltk/snapshots/${MY_P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="FLTK LGPL-2"
+SLOT="2"
+IUSE="cairo debug doc +jpeg +png opengl +xft xinerama zlib"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXt
+ xft? ( x11-libs/libXft )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ opengl? ( virtual/opengl )
+ cairo? ( x11-libs/cairo )
+ xinerama? ( x11-libs/libXinerama )
+ zlib? ( sys-libs/zlib )
+ >=sys-libs/glibc-2.10" # glibc-2.10 patch breaks with 2.9, bug 276695
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )
+ cairo? ( dev-util/pkgconfig )
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fltk2-asneeded.patch # bug 255494
+ epatch "${FILESDIR}"/fltk2-gcc43.patch
+ epatch "${FILESDIR}"/fltk2-glibc2.10-scandir.patch # bug 270487
+ epatch "${FILESDIR}"/fltk2-ldflags.patch # bug 251233
+ sed -i "/STRIP/d" fluid/Makefile # don't pre-strip, bug 246694
+ use opengl || epatch "${FILESDIR}"/fltk2-nogl.patch
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ CPPFLAGS="${CPPFLAGS} -DFLTK_DOCDIR=\"/usr/share/doc/${PF}\"" \
+ econf --enable-shared --enable-threads \
+ $(use_enable debug) \
+ $(use_enable xft) \
+ $(use_enable opengl gl) \
+ $(use_enable cairo) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable xinerama) \
+ $(use_enable zlib)
+}
+
+src_compile() {
+ emake || die "make failed"
+
+ if use doc; then
+ make -C documentation || die "make documentation failed"
+ fi
+}
+
+src_install() {
+ einstall includedir="${D}/usr/include" libdir="${D}/usr/$(get_libdir)/fltk"
+
+ if use doc; then
+ emake -C documentation install || die "install documentation failed"
+ dohtml -r documentation/html/* || die "install html documentation failed"
+ fi
+ dodoc CHANGES CREDITS README* TODO
+
+ echo "LDPATH=/usr/$(get_libdir)/fltk" > 99fltk-${SLOT}
+ echo "FLTK_DOCDIR=/usr/share/doc/${PF}/html" >> 99fltk-${SLOT}
+
+ doenvd 99fltk-${SLOT} || die "installing env.d file failed"
+}
diff --git a/x11-libs/fltk/fltk-2.0_pre6786.ebuild b/x11-libs/fltk/fltk-2.0_pre6786.ebuild
index b93acdfcfc82..0eed5532d567 100644
--- a/x11-libs/fltk/fltk-2.0_pre6786.ebuild
+++ b/x11-libs/fltk/fltk-2.0_pre6786.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-2.0_pre6786.ebuild,v 1.2 2009/07/04 18:38:30 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-2.0_pre6786.ebuild,v 1.3 2009/07/08 11:34:48 yngwin Exp $
EAPI="2"
inherit multilib autotools flag-o-matic
@@ -25,7 +25,8 @@ RDEPEND="x11-libs/libXext
opengl? ( virtual/opengl )
cairo? ( x11-libs/cairo )
xinerama? ( x11-libs/libXinerama )
- zlib? ( sys-libs/zlib )"
+ zlib? ( sys-libs/zlib )
+ <sys-libs/glibc-2.10" # glibc-2.10 patch breaks with 2.9, bug 276695
DEPEND="${RDEPEND}
x11-proto/xextproto
xinerama? ( x11-proto/xineramaproto )
@@ -37,7 +38,6 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
epatch "${FILESDIR}"/fltk2-asneeded.patch # bug 255494
epatch "${FILESDIR}"/fltk2-gcc43.patch
- epatch "${FILESDIR}"/fltk2-glibc2.10-scandir.patch # bug 270487
epatch "${FILESDIR}"/fltk2-ldflags.patch # bug 251233
sed -i "/STRIP/d" fluid/Makefile # don't pre-strip, bug 246694
use opengl || epatch "${FILESDIR}"/fltk2-nogl.patch