summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-08-03 15:33:08 +0000
committerRémi Cardona <remi@gentoo.org>2009-08-03 15:33:08 +0000
commitacbb646833d40627158909f0b53ac5796c2b688c (patch)
treecabfdaa42505c50c5cd7bb8bf5151ad80524400b /x11-drivers/xf86-video-sis/xf86-video-sis-0.10.2.ebuild
parentInstall manpage and ucat wrt #280067, Comment #2. (diff)
downloadgentoo-2-acbb646833d40627158909f0b53ac5796c2b688c.tar.gz
gentoo-2-acbb646833d40627158909f0b53ac5796c2b688c.tar.bz2
gentoo-2-acbb646833d40627158909f0b53ac5796c2b688c.zip
x11-drivers/xf86-video-sis: bump to 0.10.2
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'x11-drivers/xf86-video-sis/xf86-video-sis-0.10.2.ebuild')
-rw-r--r--x11-drivers/xf86-video-sis/xf86-video-sis-0.10.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-sis/xf86-video-sis-0.10.2.ebuild b/x11-drivers/xf86-video-sis/xf86-video-sis-0.10.2.ebuild
new file mode 100644
index 000000000000..517d7cd5f197
--- /dev/null
+++ b/x11-drivers/xf86-video-sis/xf86-video-sis-0.10.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-sis/xf86-video-sis-0.10.2.ebuild,v 1.1 2009/08/03 15:33:08 remi Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="SiS and XGI video driver"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~x86-fbsd"
+IUSE="dri"
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86miscproto
+ x11-proto/xineramaproto
+ x11-proto/xproto
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable dri)"
+}