summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-03-12 16:44:51 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-03-12 16:44:51 +0000
commit885a96cc66a1f6143361c8650dc9ea21afc2d40b (patch)
treeddaa1334b4f95100160c3db57caf36f4f7380ea0 /x11-drivers/xf86-video-nv
parentNew revision for EAPI change, enable rebuilding of the xorg module. (diff)
downloadgentoo-2-885a96cc66a1f6143361c8650dc9ea21afc2d40b.tar.gz
gentoo-2-885a96cc66a1f6143361c8650dc9ea21afc2d40b.tar.bz2
gentoo-2-885a96cc66a1f6143361c8650dc9ea21afc2d40b.zip
Fix building against xorg-server-1.14, bug #461414.
(Portage version: 2.1.11.52/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-drivers/xf86-video-nv')
-rw-r--r--x11-drivers/xf86-video-nv/ChangeLog11
-rw-r--r--x11-drivers/xf86-video-nv/files/xf86-video-nv-2.1.20-remove-mibstore_h.patch81
-rw-r--r--x11-drivers/xf86-video-nv/xf86-video-nv-2.1.20-r1.ebuild19
-rw-r--r--x11-drivers/xf86-video-nv/xf86-video-nv-2.1.20.ebuild4
4 files changed, 111 insertions, 4 deletions
diff --git a/x11-drivers/xf86-video-nv/ChangeLog b/x11-drivers/xf86-video-nv/ChangeLog
index 91fc2ae9d99d..0c5eac22a3c8 100644
--- a/x11-drivers/xf86-video-nv/ChangeLog
+++ b/x11-drivers/xf86-video-nv/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-video-nv
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-nv/ChangeLog,v 1.119 2012/12/30 14:49:05 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-nv/ChangeLog,v 1.120 2013/03/12 16:44:51 chithanh Exp $
+
+*xf86-video-nv-2.1.20-r1 (12 Mar 2013)
+
+ 12 Mar 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/xf86-video-nv-2.1.20-remove-mibstore_h.patch,
+ +xf86-video-nv-2.1.20-r1.ebuild, xf86-video-nv-2.1.20.ebuild:
+ Fix building against xorg-server-1.14, bug #461414.
30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> xf86-video-nv-2.1.20.ebuild:
Stable for alpha, wrt bug #440872
diff --git a/x11-drivers/xf86-video-nv/files/xf86-video-nv-2.1.20-remove-mibstore_h.patch b/x11-drivers/xf86-video-nv/files/xf86-video-nv-2.1.20-remove-mibstore_h.patch
new file mode 100644
index 000000000000..ef5a4f2d9d6b
--- /dev/null
+++ b/x11-drivers/xf86-video-nv/files/xf86-video-nv-2.1.20-remove-mibstore_h.patch
@@ -0,0 +1,81 @@
+From fc78fe98222b0204b8a2872a529763d6fe5048da Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 25 Sep 2012 12:54:49 +0000
+Subject: Remove mibstore.h
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+---
+diff --git a/src/g80_driver.c b/src/g80_driver.c
+index cc4e197..719b96c 100644
+--- a/src/g80_driver.c
++++ b/src/g80_driver.c
+@@ -34,7 +34,6 @@
+ #include <xf86Resources.h>
+ #endif
+ #include <mipointer.h>
+-#include <mibstore.h>
+ #include <micmap.h>
+ #include <xf86cmap.h>
+ #include <fb.h>
+@@ -833,7 +832,6 @@ G80ScreenInit(SCREEN_INIT_ARGS_DECL)
+ }
+ }
+
+- miInitializeBackingStore(pScreen);
+ xf86SetBackingStore(pScreen);
+ xf86SetSilkenMouse(pScreen);
+
+diff --git a/src/nv_driver.c b/src/nv_driver.c
+index 6dad6e5..8f35334 100644
+--- a/src/nv_driver.c
++++ b/src/nv_driver.c
+@@ -2550,7 +2550,6 @@ NVScreenInit(SCREEN_INIT_ARGS_DECL)
+ if (!pNv->NoAccel)
+ NVAccelInit(pScreen);
+
+- miInitializeBackingStore(pScreen);
+ xf86SetBackingStore(pScreen);
+ xf86SetSilkenMouse(pScreen);
+
+diff --git a/src/nv_include.h b/src/nv_include.h
+index fb190bf..f174eef 100644
+--- a/src/nv_include.h
++++ b/src/nv_include.h
+@@ -24,9 +24,6 @@
+ /* All drivers initialising the SW cursor need this */
+ #include "mipointer.h"
+
+-/* All drivers implementing backing store need this */
+-#include "mibstore.h"
+-
+ #include "micmap.h"
+
+ #include "xf86DDC.h"
+diff --git a/src/riva_driver.c b/src/riva_driver.c
+index e0667ef..759501e 100644
+--- a/src/riva_driver.c
++++ b/src/riva_driver.c
+@@ -1168,7 +1168,6 @@ RivaScreenInit(SCREEN_INIT_ARGS_DECL)
+ if (!pRiva->NoAccel)
+ RivaAccelInit(pScreen);
+
+- miInitializeBackingStore(pScreen);
+ xf86SetBackingStore(pScreen);
+ xf86SetSilkenMouse(pScreen);
+
+diff --git a/src/riva_include.h b/src/riva_include.h
+index f2c5302..c7aeef7 100644
+--- a/src/riva_include.h
++++ b/src/riva_include.h
+@@ -22,9 +22,6 @@
+ /* All drivers initialising the SW cursor need this */
+ #include "mipointer.h"
+
+-/* All drivers implementing backing store need this */
+-#include "mibstore.h"
+-
+ #include "micmap.h"
+
+ #include "xf86DDC.h"
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-drivers/xf86-video-nv/xf86-video-nv-2.1.20-r1.ebuild b/x11-drivers/xf86-video-nv/xf86-video-nv-2.1.20-r1.ebuild
new file mode 100644
index 000000000000..ae74f5238954
--- /dev/null
+++ b/x11-drivers/xf86-video-nv/xf86-video-nv-2.1.20-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-nv/xf86-video-nv-2.1.20-r1.ebuild,v 1.1 2013/03/12 16:44:51 chithanh Exp $
+
+EAPI=5
+inherit xorg-2
+
+DESCRIPTION="Nvidia 2D only video driver"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-base/xorg-server
+ >=x11-libs/libpciaccess-0.10.7"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-mibstore_h.patch
+)
diff --git a/x11-drivers/xf86-video-nv/xf86-video-nv-2.1.20.ebuild b/x11-drivers/xf86-video-nv/xf86-video-nv-2.1.20.ebuild
index 76fa6482fc29..153130b8c19f 100644
--- a/x11-drivers/xf86-video-nv/xf86-video-nv-2.1.20.ebuild
+++ b/x11-drivers/xf86-video-nv/xf86-video-nv-2.1.20.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-nv/xf86-video-nv-2.1.20.ebuild,v 1.8 2012/12/30 14:49:05 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-nv/xf86-video-nv-2.1.20.ebuild,v 1.9 2013/03/12 16:44:51 chithanh Exp $
EAPI=4
inherit xorg-2