summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-04-08 21:04:56 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-04-08 21:04:56 +0000
commit7286d89ebfa3aa0d8f20278387fc6242e62f23b1 (patch)
treee54401f040565b88d2245ed138e14dc43836c119 /x11-drivers/radeon-ucode
parentMissing dev-util/pkgconfig DEPEND wrt #233068 by Evil Compile Person. (diff)
downloadgentoo-2-7286d89ebfa3aa0d8f20278387fc6242e62f23b1.tar.gz
gentoo-2-7286d89ebfa3aa0d8f20278387fc6242e62f23b1.tar.bz2
gentoo-2-7286d89ebfa3aa0d8f20278387fc6242e62f23b1.zip
x11-drivers/radeon-ucode: add new Evergreen microcode
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/radeon-ucode')
-rw-r--r--x11-drivers/radeon-ucode/ChangeLog8
-rw-r--r--x11-drivers/radeon-ucode/radeon-ucode-20100408.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/x11-drivers/radeon-ucode/ChangeLog b/x11-drivers/radeon-ucode/ChangeLog
index 43d638724318..d7a6f28f5d12 100644
--- a/x11-drivers/radeon-ucode/ChangeLog
+++ b/x11-drivers/radeon-ucode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/radeon-ucode
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/ChangeLog,v 1.1 2010/02/15 17:10:17 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/ChangeLog,v 1.2 2010/04/08 21:04:56 chithanh Exp $
+
+*radeon-ucode-20100408 (08 Apr 2010)
+
+ 08 Apr 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +radeon-ucode-20100408.ebuild:
+ add new Evergreen microcode
*radeon-ucode-20091209 (15 Feb 2010)
diff --git a/x11-drivers/radeon-ucode/radeon-ucode-20100408.ebuild b/x11-drivers/radeon-ucode/radeon-ucode-20100408.ebuild
new file mode 100644
index 000000000000..789dbc503ffc
--- /dev/null
+++ b/x11-drivers/radeon-ucode/radeon-ucode-20100408.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/radeon-ucode-20100408.ebuild,v 1.1 2010/04/08 21:04:56 chithanh Exp $
+
+inherit linux-info
+
+UCODE_BASE_URI="http://people.freedesktop.org/~agd5f/${PN/-/_}"
+UCODE_FILES=(
+ "CEDAR_me.bin"
+ "CEDAR_pfp.bin"
+ "CEDAR_rlc.bin"
+ "CYPRESS_me.bin"
+ "CYPRESS_pfp.bin"
+ "CYPRESS_rlc.bin"
+ "JUNIPER_me.bin"
+ "JUNIPER_pfp.bin"
+ "JUNIPER_rlc.bin"
+ "R600_rlc.bin"
+ "R700_rlc.bin"
+ "REDWOOD_me.bin"
+ "REDWOOD_pfp.bin"
+ "REDWOOD_rlc.bin"
+)
+
+DESCRIPTION="IRQ microcode for r6xx/r7xx/Evergreen Radeon GPUs"
+HOMEPAGE="http://people.freedesktop.org/~agd5f/radeon_ucode/"
+SRC_URI="${UCODE_FILES[@]/#/${UCODE_BASE_URI}/}"
+
+LICENSE="radeon-ucode"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack() { :; }
+
+src_install() {
+ insinto /lib/firmware/radeon || die "insinto failed"
+ doins "${UCODE_FILES[@]/#/${DISTDIR}/}" || die "doins failed"
+}
+
+pkg_postinst() {
+ if linux_config_exists && linux_chkconfig_builtin DRM_RADEON; then
+ if ! linux_chkconfig_present FIRMWARE_IN_KERNEL || \
+ ! [[ "$(linux_chkconfig_string EXTRA_FIRMWARE)" == *_rlc.bin* ]]; then
+ ewarn "Your kernel has radeon DRM built-in but not the IRQ microcode."
+ ewarn "For kernel modesetting to work, please set in kernel config"
+ ewarn "CONFIG_FIRMWARE_IN_KERNEL=y"
+ ewarn "CONFIG_EXTRA_FIRMWARE_DIR=\"/lib/firmware\""
+ ewarn "CONFIG_EXTRA_FIRMWARE=\"${UCODE_FILES[@]/#/radeon/}\""
+ ewarn "You may skip microcode files for which no hardware is installed."
+ ewarn "More information at http://wiki.x.org/wiki/radeonBuildHowTo"
+ fi
+ fi
+}