summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-10-11 08:29:39 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-10-11 08:29:39 +0000
commitf467196161279fafa678a28da7ebbf938b280783 (patch)
treed47500cfbdeff795cf2e54f939a3f1e8aec8d4fd /x11-base
parentAdd uclibc support by making build a little more minimal with USE=uclibc, tha... (diff)
downloadgentoo-2-f467196161279fafa678a28da7ebbf938b280783.tar.gz
gentoo-2-f467196161279fafa678a28da7ebbf938b280783.tar.bz2
gentoo-2-f467196161279fafa678a28da7ebbf938b280783.zip
Allow FEATURES=nostrip to prevent stripping, and add ${CHOST}-strip support from solar (#66531).
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-x11/ChangeLog7
-rw-r--r--x11-base/xorg-x11/xorg-x11-6.8.0-r2.ebuild14
2 files changed, 16 insertions, 5 deletions
diff --git a/x11-base/xorg-x11/ChangeLog b/x11-base/xorg-x11/ChangeLog
index 85d8bfecc1b4..49bdbab5d4a9 100644
--- a/x11-base/xorg-x11/ChangeLog
+++ b/x11-base/xorg-x11/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-base/xorg-x11
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/ChangeLog,v 1.143 2004/10/11 08:27:13 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/ChangeLog,v 1.144 2004/10/11 08:29:39 spyderous Exp $
+
+ 11 Oct 2004; Donnie Berkholz <spyderous@gentoo.org>;
+ xorg-x11-6.8.0-r2.ebuild:
+ Allow FEATURES=nostrip to prevent stripping, and add ${CHOST}-strip support
+ from solar (#66531).
11 Oct 2004; Donnie Berkholz <spyderous@gentoo.org>;
xorg-x11-6.8.0-r2.ebuild:
diff --git a/x11-base/xorg-x11/xorg-x11-6.8.0-r2.ebuild b/x11-base/xorg-x11/xorg-x11-6.8.0-r2.ebuild
index 0c711d57c553..53eab8f48945 100644
--- a/x11-base/xorg-x11/xorg-x11-6.8.0-r2.ebuild
+++ b/x11-base/xorg-x11/xorg-x11-6.8.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.8.0-r2.ebuild,v 1.5 2004/10/11 08:27:13 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.8.0-r2.ebuild,v 1.6 2004/10/11 08:29:39 spyderous Exp $
# Set TDFX_RISKY to "yes" to get 16-bit, 1024x768 or higher on low-memory
# voodoo3 cards.
@@ -818,11 +818,17 @@ setup_dynamic_libgl() {
}
strip_execs() {
- if use debug
+ if use debug || has nostrip ${FEATURES}
then
ewarn "Debug build turned on by USE=debug"
ewarn "NOT stripping binaries and libraries"
else
+ local STRIP
+ if [ ! -z "${CBUILD}" ] && [ "${CBUILD}" != "${CHOST}" ]; then
+ STRIP=${CHOST}-strip
+ else
+ STRIP=strip
+ fi
einfo "Stripping binaries and libraries..."
# This bit I got from Redhat ... strip binaries and drivers ..
# NOTE: We do NOT want to strip the drivers, modules or DRI modules!
@@ -836,7 +842,7 @@ strip_execs() {
if [ "${x/\/usr\/X11R6\/$(get_libdir)\/modules}" = "${x}" ]
then
echo "`echo ${x} | sed -e "s|${D}||"`"
- strip ${x} || :
+ ${STRIP} ${x} || :
fi
fi
done
@@ -847,7 +853,7 @@ strip_execs() {
if [ -f ${x} ]
then
echo "`echo ${x} | sed -e "s|${D}||"`"
- strip --strip-debug ${x} || :
+ ${STRIP} --strip-debug ${x} || :
fi
done
fi