summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-04-19 03:46:40 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-04-19 03:46:40 +0000
commitcef9b03453de5ecd1fc7cc80be5f56122334b820 (patch)
tree4fdb2d0fa72348634a6b9ade29850d89eee6c5e3 /x11-base
parentstable (diff)
downloadgentoo-2-cef9b03453de5ecd1fc7cc80be5f56122334b820.tar.gz
gentoo-2-cef9b03453de5ecd1fc7cc80be5f56122334b820.tar.bz2
gentoo-2-cef9b03453de5ecd1fc7cc80be5f56122334b820.zip
Add more backwards compatibility things -- symlinks for all former font, doc and man dirs as well as autogeneration of new config files. Fix generation of xrender.pc.
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-x11/ChangeLog7
-rw-r--r--x11-base/xorg-x11/xorg-x11-6.7.0.ebuild126
2 files changed, 89 insertions, 44 deletions
diff --git a/x11-base/xorg-x11/ChangeLog b/x11-base/xorg-x11/ChangeLog
index 992bc4a8821a..eacf403e86ab 100644
--- a/x11-base/xorg-x11/ChangeLog
+++ b/x11-base/xorg-x11/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-base/xorg-x11
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/ChangeLog,v 1.28 2004/04/19 00:36:16 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/ChangeLog,v 1.29 2004/04/19 03:46:40 spyderous Exp $
+
+ 18 Apr 2004; Donnie Berkholz <spyderous@gentoo.org>; xorg-x11-6.7.0.ebuild:
+ Add more backwards compatibility things -- symlinks for all former font, doc
+ and man dirs as well as autogeneration of new config files. Fix generation of
+ xrender.pc.
18 Apr 2004; Donnie Berkholz <spyderous@gentoo.org>; xorg-x11-6.7.0.ebuild:
Add explicit xfree to blockers.
diff --git a/x11-base/xorg-x11/xorg-x11-6.7.0.ebuild b/x11-base/xorg-x11/xorg-x11-6.7.0.ebuild
index 8f99c29379e8..92c6fdbaa8e0 100644
--- a/x11-base/xorg-x11/xorg-x11-6.7.0.ebuild
+++ b/x11-base/xorg-x11/xorg-x11-6.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.7.0.ebuild,v 1.29 2004/04/19 00:36:16 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.7.0.ebuild,v 1.30 2004/04/19 03:46:40 spyderous Exp $
# This is a snapshot of the XORG-RELEASE-1 branch.
@@ -68,7 +68,8 @@ IUSE="3dfx cjk debug doc hardened ipv6 nls pam sdk static pie"
FILES_VER="0.2"
PATCH_VER="0.5"
#RENDER_VER="0.8"
-#XRENDER_VER="0.8.4"
+# Needed for xrender.pc in addition to external libs
+XRENDER_VER="0.8.4"
#XFT_VER="2.1.5"
XCUR_VER="0.3.1"
#SISDRV_VER="021203-1"
@@ -676,34 +677,37 @@ src_install() {
ln -snf libXrender.so.1.2.2 libXrender.so.1
cd ${S}
- # Generate xrender.pc using 'EOF' style here document with no expansion
- # (adapted from Red Hat)
- cat <<-'EOF' > ${D}/usr/X11R6/lib/pkgconfig/xrender.pc
- prefix=/usr/X11R6
- exec_prefix=${prefix}
- libdir=${exec_prefix}/lib
- includedir=${prefix}/include
-
- Name: Xrender
- Description: X Render Library
- Version: 0.8.3
- Cflags: -I${includedir} -I/usr/X11R6/include
- Libs: -L${libdir} -lXrender -L/usr/X11R6/lib -lX11
- EOF
-
- fperms 0644 /usr/X11R6/lib/pkgconfig/xrender.pc
-
# Fix problem in xft.pc with version not being defined
sed -i "s:@VERSION@:${XFT_VER}:g" ${D}/usr/X11R6/lib/pkgconfig/xft.pc
fi
+ # upstream still doesn't generate this -- move back into external stuff
+ # once they do
+ # Generate xrender.pc using 'EOF' style here document with no expansion
+ # (adapted from Red Hat)
+ cat <<-'EOF' > ${D}/usr/X11R6/lib/pkgconfig/xrender.pc
+prefix=/usr/X11R6
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: Xrender
+Description: X Render Library
+Version: ${XRENDER_VER}
+Cflags: -I${includedir} -I/usr/X11R6/include
+Libs: -L${libdir} -lXrender -L/usr/X11R6/lib -lX11
+EOF
+
+ fperms 0644 /usr/X11R6/lib/pkgconfig/xrender.pc
+
# This one needs to be in /usr/lib
insinto /usr/lib/pkgconfig
doins ${D}/usr/X11R6/lib/pkgconfig/{xcursor,xft}.pc
- if [ "${EXT_XFT_XRENDER}" = "yes" ]
- then
+# pending upstream fix
+# if [ "${EXT_XFT_XRENDER}" = "yes" ]
+# then
doins ${D}/usr/X11R6/lib/pkgconfig/xrender.pc
- fi
+# fi
# Now remove the invalid xft.pc, and co ...
rm -rf ${D}/usr/X11R6/lib/pkgconfig
@@ -718,18 +722,17 @@ src_install() {
make DESTDIR=${D} install || die
fi
- # Backwards compatibility so X server will still start
- # after installing fonts to /usr/share/fonts
- # if xorg.conf is not edited
- # This provides the 'fixed' font
+ # Backwards compatibility for /usr/share move
+ G_FONTDIRS="100dpi 75dpi Speedo TTF Type1 encodings local misc util"
+
dodir /usr/X11R6/lib/X11/fonts/
- dosym ${ROOT}/usr/share/fonts/misc /usr/X11R6/lib/X11/fonts/misc
+ for G_FONTDIR in ${G_FONTDIRS}
+ do
+ dosym ${ROOT}/usr/share/fonts/${G_FONTDIR} /usr/X11R6/lib/X11/fonts/${G_FONTDIR}
+ done
- # Fix default config files after installing fonts to /usr/share/fonts
- sed -i "s:/usr/X116/lib/X11/fonts:/usr/share/fonts:g" \
- ${D}/etc/X11/xorg.conf.example
- sed -i "s:/usr/X116/lib/X11/fonts:/usr/share/fonts:g" \
- ${D}/etc/X11/fs/config
+ dosym ${ROOT}/usr/share/man /usr/X11R6/man
+ dosym ${ROOT}/usr/share/doc/${PF} /usr/X11R6/lib/X11/doc
# Fix permissions on locale/common/*.so
for x in ${D}/usr/X11R6/lib/X11/locale/lib/common/*.so*
@@ -972,15 +975,55 @@ src_install() {
insinto /usr/share/cursors/${PN}/gentoo-silver/cursors
doins ${WORKDIR}/cursors/gentoo-silver/cursors/*
+ # Remove xterm app-defaults, since we don't install xterm
+ rm ${D}/etc/X11/app-defaults/{UXTerm,XTerm,XTerm-color}
+
+ # Fix default config files after installing fonts to /usr/share/fonts
+ sed -i "s:/usr/X116/lib/X11/fonts:/usr/share/fonts:g" \
+ ${D}/etc/X11/xorg.conf.example
+ sed -i "s:/usr/X116/lib/X11/fonts:/usr/share/fonts:g" \
+ ${D}/etc/X11/fs/config
+
+ # Fix any installed config files for installing fonts to /usr/share/fonts
+ # This *needs* to be after all other installation so files aren't
+ # overwritten.
+ einfo "Preparing any installed configuration files for font move..."
+ FILES="/etc/X11/xorg.conf
+ /etc/X11/XF86Config
+ /etc/fonts/fonts.conf
+ /etc/fonts/local.conf
+ /etc/X11/fs/config"
+
+ for FILE in ${FILES}
+ do
+ if [ -e ${ROOT}${FILE} ]
+ then
+ DIR="$(dirname ${ROOT}${FILE})"
+ if [ ! -d ${T}${DIR} ]
+ then
+ mkdir -p ${T}${DIR}
+ fi
+ cp ${ROOT}${FILE} ${T}${DIR}
+ sed -i "s,/usr/X11R6/lib/X11/fonts,/usr/share/fonts,g" ${T}${FILE}
+ dodir ${DIR}
+ insinto ${DIR}
+ doins ${T}${FILE}
+ fi
+ done
}
pkg_preinst() {
- # More stuff for emergency symlink
- if [ -d ${ROOT}/usr/X11R6/lib/X11/fonts/misc ]
- then
- rm -rf ${ROOT}/usr/X11R6/lib/X11/fonts/misc
- fi
+ # Get rid of deprecated directories so our symlinks in the same location
+ # work -- users shouldn't be placing fonts here so that should be fine,
+ # they should be using ~/.fonts or /usr/share/fonts. <spyderous>
+ for G_FONTDIR in ${G_FONTDIRS}
+ do
+ if [ -d ${ROOT}/usr/X11R6/lib/X11/fonts/${G_FONTDIR} ]
+ then
+ rm -rf ${ROOT}/usr/X11R6/lib/X11/fonts/${G_FONTDIR}
+ fi
+ done
if [ -L ${ROOT}/etc/X11/app-defaults ]
then
@@ -1205,12 +1248,9 @@ pkg_postinst() {
ewarn "BEWARE:"
ewarn "Font installation location has MOVED to:"
ewarn "/usr/share/fonts"
- ewarn "Edit /etc/X11/xorg.conf, /etc/fonts/fonts.conf,"
- ewarn "/etc/fonts/local.conf and /etc/X11/fs/config"
- ewarn "to reflect this change."
- einfo "One compatibility symlink to the misc fonts,"
- einfo "including the 'fixed' font, has been provided"
- einfo "so an emergency X server will start."
+ ewarn "Run etc-update to update your config files."
+ ewarn "Old locations for fonts, docs and man pages"
+ ewarn "are deprecated."
echo
ewarn "The configuration file has changed from that in XFree86."
ewarn "It is xorg.conf instead of XF86Config."