summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-04-12 02:00:19 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-04-12 02:00:19 +0000
commit195b2c83f960776e9de062db01b406b7701fd0d0 (patch)
tree1160da9d8ce8e56036d622b9df0c9b0920840532 /x11-base/xorg-x11/xorg-x11-6.7.0.ebuild
parentRemove kde-i18n virtuals as they are no longer packages in portage (diff)
downloadgentoo-2-195b2c83f960776e9de062db01b406b7701fd0d0.tar.gz
gentoo-2-195b2c83f960776e9de062db01b406b7701fd0d0.tar.bz2
gentoo-2-195b2c83f960776e9de062db01b406b7701fd0d0.zip
Add some arch-specific CFLAGS mangling.
Diffstat (limited to 'x11-base/xorg-x11/xorg-x11-6.7.0.ebuild')
-rw-r--r--x11-base/xorg-x11/xorg-x11-6.7.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/x11-base/xorg-x11/xorg-x11-6.7.0.ebuild b/x11-base/xorg-x11/xorg-x11-6.7.0.ebuild
index 52d22b0d13c6..faf902b2b7e6 100644
--- a/x11-base/xorg-x11/xorg-x11-6.7.0.ebuild
+++ b/x11-base/xorg-x11/xorg-x11-6.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.7.0.ebuild,v 1.20 2004/04/12 00:34:02 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.7.0.ebuild,v 1.21 2004/04/12 02:00:19 spyderous Exp $
# This is a snapshot of the XORG-RELEASE-1 branch.
@@ -176,9 +176,17 @@ pkg_setup() {
PATCHDIR="${WORKDIR}/patch"
EXCLUDED="${PATCHDIR}/excluded"
+ # Set up CFLAGS
filter-flags "-funroll-loops"
ALLOWED_FLAGS="-fstack-protector -march -mcpu -O -O1 -O2 -O3 -pipe -fomit-frame-pointer -g"
+ # arch-specific section added by popular demand
+ case "${ARCH}" in
+ mips) ALLOWED_FLAGS="${ALLOWED_FLAGS} -mips1 -mips2 -mips3 -mips4 -mabi" ;;
+ # -fomit-frame-pointer known to break things and is pointless
+ # according to ciaranm
+ sparc) filter-flags "-fomit-frame-pointer"
+ esac
# Recently there has been a lot of stability problem in Gentoo-land. Many
# things can be the cause to this, but I believe that it is due to gcc3