summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-09-14 16:19:03 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-09-14 16:19:03 +0000
commitcc7ae9ff3483f4bedf9b1c6e34ddb5889014c133 (patch)
treeab60ec29a894d53bccdad763d1760ae51ced2acb /x11-apps
parentVersion bump (diff)
downloadgentoo-2-cc7ae9ff3483f4bedf9b1c6e34ddb5889014c133.tar.gz
gentoo-2-cc7ae9ff3483f4bedf9b1c6e34ddb5889014c133.tar.bz2
gentoo-2-cc7ae9ff3483f4bedf9b1c6e34ddb5889014c133.zip
rev bump for bug #156570.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/ChangeLog12
-rw-r--r--x11-apps/xinit/files/x-setup.initd-110
-rwxr-xr-xx11-apps/xinit/files/xdm.initd-3202
-rw-r--r--x11-apps/xinit/xinit-1.0.8-r5.ebuild69
4 files changed, 292 insertions, 1 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index 190b3833c22d..7a98187e427c 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.132 2009/08/31 09:09:18 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.133 2009/09/14 16:19:02 williamh Exp $
+
+*xinit-1.0.8-r5 (14 Sep 2009)
+
+ 14 Sep 2009; William Hubbs <williamh@gentoo.org> +files/x-setup.initd-1,
+ +xinit-1.0.8-r5.ebuild, +files/xdm.initd-3:
+ rev bump for bug #156570.
+ The x-setup script now checks the kernel command line for gentoo=nox,
+ and creates /etc/init.d/.noxdm if this option is passed.
+ The xdm script now looks only for the file /etc/init.d/.noxdm
+ to know when to skip starting X.
31 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org> files/xdm.initd-2:
Adjust xdm init script to die bit sane way. Per bug #207075.
diff --git a/x11-apps/xinit/files/x-setup.initd-1 b/x11-apps/xinit/files/x-setup.initd-1
new file mode 100644
index 000000000000..8fe5fdcd2ff9
--- /dev/null
+++ b/x11-apps/xinit/files/x-setup.initd-1
@@ -0,0 +1,10 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/x-setup.initd-1,v 1.1 2009/09/14 16:19:03 williamh Exp $
+
+start() {
+ if check_bootparam "nox" ; then
+ touch /etc/init.d/.noxdm
+ fi
+}
diff --git a/x11-apps/xinit/files/xdm.initd-3 b/x11-apps/xinit/files/xdm.initd-3
new file mode 100755
index 000000000000..79c0f695b4c4
--- /dev/null
+++ b/x11-apps/xinit/files/xdm.initd-3
@@ -0,0 +1,202 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/xdm.initd-3,v 1.1 2009/09/14 16:19:03 williamh Exp $
+
+# This is here to serve as a note to myself, and future developers.
+#
+# Any Display manager (gdm,kdm,xdm) has the following problem: if
+# it is started before any getty, and no vt is specified, it will
+# usually run on vt2. When the getty on vt2 then starts, and the
+# DM is already started, the getty will take control of the keyboard,
+# leaving us with a "dead" keyboard.
+#
+# Resolution: add the following line to /etc/inittab
+#
+# x:a:once:/etc/X11/startDM.sh
+#
+# and have /etc/X11/startDM.sh start the DM in daemon mode if
+# a lock is present (with the info of what DM should be started),
+# else just fall through.
+#
+# How this basically works, is the "a" runlevel is a additional
+# runlevel that you can use to fork processes with init, but the
+# runlevel never gets changed to this runlevel. Along with the "a"
+# runlevel, the "once" key word means that startDM.sh will only be
+# run when we specify it to run, thus eliminating respawning
+# startDM.sh when "xdm" is not added to the default runlevel, as was
+# done previously.
+#
+# This script then just calls "telinit a", and init will run
+# /etc/X11/startDM.sh after the current runlevel completes (this
+# script should only be added to the actual runlevel the user is
+# using).
+#
+# Martin Schlemmer
+# aka Azarah
+# 04 March 2002
+
+
+# Start X Font Server before X
+depend() {
+ need localmount x-setup
+
+ # this should start as early as possible
+ # we can't do 'before *' as that breaks it
+ # (#139824) Start after ypbind and autofs for network authentication
+ # (#145219 #180163) Could use lirc mouse as input device
+ # (#70689 comment #92) Start after consolefont to avoid display corruption
+ after bootmisc consolefont modules netmount
+ after readahead-list ypbind autofs openvpn gpm lircmd
+ before alsasound
+
+ # Start before X
+ use acpid consolekit hald xfs
+}
+
+setup_dm() {
+ local MY_XDM="$(echo "${DISPLAYMANAGER}" | tr '[:upper:]' '[:lower:]')"
+
+ # Load our root path from profile.env
+ # Needed for kdm
+ PATH="${PATH}:$(. /etc/profile.env; echo "${ROOTPATH}")"
+
+ case "${MY_XDM}" in
+ kdm|kde|kde2|kde3)
+ EXE="$(which kdm)"
+ # kdm takes too long to create a pidfile for baselayout-2
+ #PIDFILE=/var/run/kdm.pid
+ PIDFILE=
+ ;;
+ kdm-*)
+ EXE="/usr/kde/${MY_XDM#kdm-}/bin/kdm"
+ PIDFILE=
+ ;;
+ entrance*)
+ EXE=/usr/sbin/entranced
+ PIDFILE=/var/lib/entranced.pid
+ ;;
+ gdm|gnome)
+ EXE=/usr/bin/gdm
+ [ "${RC_UNAME}" != "Linux" ] && NAME=gdm-binary
+ PIDFILE=/var/run/gdm.pid
+ ;;
+ wdm)
+ EXE=/usr/bin/wdm
+ PIDFILE=
+ ;;
+ gpe)
+ EXE=/usr/bin/gpe-dm
+ PIDFILE=/var/run/gpe-dm.pid
+ ;;
+ *)
+ EXE=
+ # Fix #65586, where MY_XDM is empty so EXE=somedir
+ [ -x "/usr/bin/${MY_XDM}" ] && [ -f "/usr/bin/${MY_XDM}" ] \
+ && EXE="/usr/bin/${MY_XDM}"
+ if [ -z "${EXE}" ] ; then
+ EXE=/usr/bin/xdm
+ PIDFILE=/var/run/xdm.pid
+ fi
+ ;;
+ esac
+
+ if ! [ -x "${EXE}" ] ; then
+ EXE=/usr/bin/xdm
+ PIDFILE=/var/run/xdm.pid
+ if ! [ -x "/usr/bin/xdm" ] ; then
+ echo "ERROR: Please set your DISPLAYMANAGER variable in /etc/conf.d/xdm,"
+ echo " or install x11-apps/xdm package"
+ eend 255
+ fi
+ fi
+}
+
+# Check to see if something is defined on our VT
+vtstatic() {
+ if [ -e /etc/inittab ] ; then
+ grep -Eq "^[^#]+.*\<tty$1\>" /etc/inittab
+ elif [ -e /etc/ttys ] ; then
+ grep -q "^ttyv$(($1 - 1))" /etc/ttys
+ else
+ return 1
+ fi
+}
+
+start() {
+ local EXE= NAME= PIDFILE=
+ setup_dm
+
+ if [ -f /etc/init.d/.noxdm ] ; then
+ einfo "Skipping ${EXE}, /etc/init.d/.noxdm found"
+ rm /etc/init.d/.noxdm
+ return 1
+ fi
+
+ ebegin "Setting up ${EXE##*/}"
+ #save the prefered DM
+ save_options "service" "${EXE}"
+ save_options "name" "${NAME}"
+ save_options "pidfile" "${PIDFILE}"
+
+ if [ -n "${CHECKVT-y}" ] ; then
+ if vtstatic "${CHECKVT:-7}" ; then
+ if [ -x /sbin/telinit ] && [ "${SOFTLEVEL}" != "BOOT" ] && [ "${RC_SOFTLEVEL}" != "BOOT" ] ; then
+ ewarn "Something is already defined on VT ${CHECKVT:-7}, will start X later"
+ telinit a >/dev/null 2>/dev/null
+ return 0
+ else
+ eerror "Something is already defined on VT ${CHECKVT:-7}, not starting"
+ return 1
+ fi
+ fi
+ fi
+
+ /etc/X11/startDM.sh
+ eend 0
+}
+
+stop() {
+ local retval=0
+ local curvt=
+ if [ -t 0 ] ; then
+ if type fgconsole >/dev/null 2>/dev/null ; then
+ curvt="$(fgconsole 2>/dev/null)"
+ else
+ curvt="$(tty)"
+ case "${curvt}" in
+ /dev/ttyv[0-9]*) curvt="${curvt#/dev/ttyv*}" ;;
+ *) curvt= ;;
+ esac
+ fi
+ fi
+ local myexe="$(get_options "service")"
+ local myname="$(get_options "name")"
+ local mypidfile="$(get_options "pidfile")"
+ local myservice=${myexe##*/}
+
+ [ -z "${myexe}" ] && return 0
+
+ ebegin "Stopping ${myservice}"
+
+ if start-stop-daemon --quiet --test --stop --exec "${myexe}" ; then
+ start-stop-daemon --stop --exec "${myexe}" --retry TERM/5/TERM/5 \
+ ${mypidfile:+--pidfile} ${mypidfile} \
+ ${myname:+--name} ${myname}
+ retval=$?
+ fi
+
+ # switch back to original vt
+ if [ -n "${curvt}" ] ; then
+ if type chvt >/dev/null 2>/dev/null ; then
+ chvt "${curvt}"
+ else
+ vidcontrol -s "$((${curvt} + 1))"
+ fi
+ fi
+ eend ${retval} "Error stopping ${myservice}"
+
+ return ${retval}
+}
+
+# vim: set ts=4 :
diff --git a/x11-apps/xinit/xinit-1.0.8-r5.ebuild b/x11-apps/xinit/xinit-1.0.8-r5.ebuild
new file mode 100644
index 000000000000..60aa1d695c53
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.0.8-r5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.0.8-r5.ebuild,v 1.1 2009/09/14 16:19:02 williamh Exp $
+
+EAPI="2"
+
+# Must be before x-modular eclass is inherited
+# This is enabled due to modified Makefile.am from the patches
+SNAPSHOT="yes"
+
+inherit x-modular pam
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="hal minimal pam"
+
+RDEPEND="x11-apps/xauth
+ x11-libs/libX11
+ hal? ( sys-auth/consolekit sys-apps/dbus[X] )"
+DEPEND="${RDEPEND}"
+PDEPEND="!minimal? ( x11-wm/twm
+ x11-apps/xclock
+ x11-apps/xrdb
+ x11-apps/xsm
+ x11-terms/xterm )"
+
+PATCHES=( "${FILESDIR}"/nolisten-tcp-and-black-background.patch
+ "${FILESDIR}"/gentoo-startx-customization-1.0.8.patch
+ "${FILESDIR}"/xinit-1.0.4-console-kit.patch )
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_with hal consolekit)"
+}
+
+src_prepare() {
+ x-modular_patch_source
+
+ sed -i -e "s:^XINITDIR.*:XINITDIR = \$(sysconfdir)/X11/xinit:g" "${S}/Makefile.am"
+
+ x-modular_reconf_source
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh || die
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession || die
+ exeinto /etc/X11/xinit
+ doexe "${FILESDIR}"/xinitrc || die
+ newinitd "${FILESDIR}"/xdm.initd-3 xdm
+ newinitd "${FILESDIR}"/x-setup.initd-1 x-setup
+ newconfd "${FILESDIR}"/xdm.confd-1 xdm
+ newpamd "${FILESDIR}"/xserver.pamd xserver
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+}