summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-25 19:03:24 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-25 19:03:24 +0000
commit908fc5e5eece2f6374950519f68de8d39edf7430 (patch)
tree1b6a077976dba01d1ff0a7e5ad2beebc945cf651 /www-servers
parentDon't depend on enum34 for python3.4. (diff)
downloadgentoo-2-908fc5e5eece2f6374950519f68de8d39edf7430.tar.gz
gentoo-2-908fc5e5eece2f6374950519f68de8d39edf7430.tar.bz2
gentoo-2-908fc5e5eece2f6374950519f68de8d39edf7430.zip
Version bump. Adds SSL/TLS support. Fixes handling of empty files and filenames with special characters.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pshs/ChangeLog8
-rw-r--r--www-servers/pshs/pshs-0.2.5.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/www-servers/pshs/ChangeLog b/www-servers/pshs/ChangeLog
index c7813388811d..073381aafae3 100644
--- a/www-servers/pshs/ChangeLog
+++ b/www-servers/pshs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/pshs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/ChangeLog,v 1.12 2014/12/23 18:16:45 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/ChangeLog,v 1.13 2014/12/25 19:03:24 mgorny Exp $
+
+*pshs-0.2.5 (25 Dec 2014)
+
+ 25 Dec 2014; Michał Górny <mgorny@gentoo.org> +pshs-0.2.5.ebuild:
+ Version bump. Adds SSL/TLS support. Fixes handling of empty files and
+ filenames with special characters.
23 Dec 2014; Michał Górny <mgorny@gentoo.org> pshs-9999.ebuild:
Add USE=ssl to control newly-added SSL support.
diff --git a/www-servers/pshs/pshs-0.2.5.ebuild b/www-servers/pshs/pshs-0.2.5.ebuild
new file mode 100644
index 000000000000..c077fe21f0d6
--- /dev/null
+++ b/www-servers/pshs/pshs-0.2.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/pshs-0.2.5.ebuild,v 1.1 2014/12/25 19:03:24 mgorny Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Pretty small HTTP server - a command-line tool to share files"
+HOMEPAGE="https://bitbucket.org/mgorny/pshs/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+magic +netlink qrcode ssl upnp"
+
+RDEPEND=">=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ ssl? ( >=dev-libs/libevent-2.1:0=[ssl]
+ dev-libs/openssl:0= )
+ upnp? ( net-libs/miniupnpc:0= )"
+DEPEND="${RDEPEND}
+ netlink? ( sys-apps/iproute2
+ >=sys-kernel/linux-headers-2.6.27 )"
+# libnetlink is static only ATM
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable magic libmagic)
+ $(use_enable netlink)
+ $(use_enable qrcode qrencode)
+ $(use_enable ssl)
+ $(use_enable upnp)
+ )
+
+ autotools-utils_src_configure
+}