summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-08-18 14:52:07 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-08-18 14:52:07 +0000
commit84c3a5fa083ef8c07be9a55ce134f205fc50a4bc (patch)
tree41d8c7b748a019a3514ed6c216f83a89b8fb9572 /www-servers
parentmedia-sound/alsaplayer masked by treecleaners for bug(s) 143402 (diff)
downloadgentoo-2-84c3a5fa083ef8c07be9a55ce134f205fc50a4bc.tar.gz
gentoo-2-84c3a5fa083ef8c07be9a55ce134f205fc50a4bc.tar.bz2
gentoo-2-84c3a5fa083ef8c07be9a55ce134f205fc50a4bc.zip
* bump
(Portage version: 2.1.1_pre5-r2)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.603
-rw-r--r--www-servers/nginx/nginx-0.3.60.ebuild79
3 files changed, 89 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index a01fabf7c6f6..5debfba7ad9b 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.106 2006/08/16 14:54:37 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.107 2006/08/18 14:52:07 voxus Exp $
+
+*nginx-0.3.60 (18 Aug 2006)
+
+ 18 Aug 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.60.ebuild,
+ -nginx-0.3.59.ebuild:
+ Bump.
*nginx-0.3.59 (16 Aug 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.3.60 b/www-servers/nginx/files/digest-nginx-0.3.60
new file mode 100644
index 000000000000..bdad32056685
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.60
@@ -0,0 +1,3 @@
+MD5 72cbceab5b42adc09af1dac037347cb0 nginx-0.3.60.tar.gz 416307
+RMD160 c6af53274fb0972eb8b2eaa16c9135be10d3f0cd nginx-0.3.60.tar.gz 416307
+SHA256 d28ea75f38ec571432a31390404dfc74720904ea8943af0c579a040b8bbb9859 nginx-0.3.60.tar.gz 416307
diff --git a/www-servers/nginx/nginx-0.3.60.ebuild b/www-servers/nginx/nginx-0.3.60.ebuild
new file mode 100644
index 000000000000..40d4e481e5c9
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.60.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.60.ebuild,v 1.1 2006/08/18 14:52:07 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}