summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2007-01-11 08:41:02 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2007-01-11 08:41:02 +0000
commit41587e7264922c662563c02ae16faba5272bee00 (patch)
treea581535187d7421019fbd5321d1dc3cbbdbd7532 /www-servers
parentadd some new versions; cleanup (diff)
downloadgentoo-2-41587e7264922c662563c02ae16faba5272bee00.tar.gz
gentoo-2-41587e7264922c662563c02ae16faba5272bee00.tar.bz2
gentoo-2-41587e7264922c662563c02ae16faba5272bee00.zip
* bump
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog10
-rw-r--r--www-servers/nginx/files/digest-nginx-0.5.63
-rw-r--r--www-servers/nginx/nginx-0.5.6.ebuild86
3 files changed, 97 insertions, 2 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 75b7eac41c08..f75dea0a3e06 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.127 2006/12/25 12:57:55 voxus Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.128 2007/01/11 08:41:02 voxus Exp $
+
+*nginx-0.5.6 (11 Jan 2007)
+
+ 11 Jan 2007; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +nginx-0.5.6.ebuild:
+ Version bump.
*nginx-0.5.5 (25 Dec 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.5.6 b/www-servers/nginx/files/digest-nginx-0.5.6
new file mode 100644
index 000000000000..7d18a3c31d49
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.5.6
@@ -0,0 +1,3 @@
+MD5 9515a2ac4d43501ff5d916147a5d6aa7 nginx-0.5.6.tar.gz 451523
+RMD160 3fb820408a5e50e3a1cc982e8146ccb63323e36e nginx-0.5.6.tar.gz 451523
+SHA256 3ede24e73a63b400c62c6d25ba8bceb95c1de764d3f73e2dd628d619c5ccde92 nginx-0.5.6.tar.gz 451523
diff --git a/www-servers/nginx/nginx-0.5.6.ebuild b/www-servers/nginx/nginx-0.5.6.ebuild
new file mode 100644
index 000000000000..f8f16db6ec46
--- /dev/null
+++ b/www-servers/nginx/nginx-0.5.6.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.6.ebuild,v 1.1 2007/01/11 08:41:02 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl status zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+pkg_setup() {
+ ebegin "Creating nginx user and group"
+ enewgroup nginx
+ enewuser nginx -1 -1 /dev/null nginx
+ eend ${?}
+}
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+ use status && myconf="${myconf} --with-http_stub_status_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ cp ${FILESDIR}/nginx.conf-r3 conf/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/*
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}