summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2012-12-04 10:04:18 +0000
committerZac Medico <zmedico@gentoo.org>2012-12-04 10:04:18 +0000
commit3679f53e764ed04e953127687e63a491cb686d1e (patch)
tree6e390dad2a26ec237e96222006027b9696051c9c /www-servers
parentsci-libs/gdal: Correct USE-dep for sci-libs/armadillo, #445546 (diff)
downloadgentoo-2-3679f53e764ed04e953127687e63a491cb686d1e.tar.gz
gentoo-2-3679f53e764ed04e953127687e63a491cb686d1e.tar.bz2
gentoo-2-3679f53e764ed04e953127687e63a491cb686d1e.zip
Fix for prefix and add ~x86-linux keyword.
(Portage version: 2.2.0_alpha144/cvs/Linux i686, signed Manifest commit with key 0xFDE8EF85AE5719A3)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/webfs/ChangeLog5
-rw-r--r--www-servers/webfs/webfs-1.21-r2.ebuild17
2 files changed, 12 insertions, 10 deletions
diff --git a/www-servers/webfs/ChangeLog b/www-servers/webfs/ChangeLog
index 695982dccf55..346c0ce00758 100644
--- a/www-servers/webfs/ChangeLog
+++ b/www-servers/webfs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-servers/webfs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/webfs/ChangeLog,v 1.29 2012/07/31 13:55:06 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/webfs/ChangeLog,v 1.30 2012/12/04 10:04:18 zmedico Exp $
+
+ 04 Dec 2012; Zac Medico <zmedico@gentoo.org> webfs-1.21-r2.ebuild:
+ Fix for prefix and add ~x86-linux keyword.
31 Jul 2012; Michael Palimaka <kensington@gentoo.org> -files/webfs.initd,
-webfs-1.21-r1.ebuild:
diff --git a/www-servers/webfs/webfs-1.21-r2.ebuild b/www-servers/webfs/webfs-1.21-r2.ebuild
index 15e6747456ed..8002d2c9170a 100644
--- a/www-servers/webfs/webfs-1.21-r2.ebuild
+++ b/www-servers/webfs/webfs-1.21-r2.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/webfs/webfs-1.21-r2.ebuild,v 1.5 2012/07/29 18:15:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/webfs/webfs-1.21-r2.ebuild,v 1.6 2012/12/04 10:04:18 zmedico Exp $
+EAPI=4
inherit eutils
DESCRIPTION="Lightweight HTTP server for static content"
@@ -10,7 +11,7 @@ HOMEPAGE="http://linux.bytesex.org/misc/webfs.html"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="amd64 ppc x86 ~x86-linux"
IUSE="ssl threads"
DEPEND="ssl? ( dev-libs/openssl )"
@@ -18,9 +19,7 @@ DEPEND="ssl? ( dev-libs/openssl )"
RDEPEND="${DEPEND}
app-misc/mime-types"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/webfs-1.21-Variables.mk-dont-strip-binaries-on-install.patch"
}
@@ -29,15 +28,15 @@ src_compile() {
use ssl || myconf="${myconf} USE_SSL=no"
use threads && myconf="${myconf} USE_THREADS=yes"
- emake prefix=/usr ${myconf} || die "emake failed"
+ emake prefix="${EPREFIX}/usr" ${myconf}
}
src_install() {
local myconf
use ssl || myconf="${myconf} USE_SSL=no"
use threads && myconf="${myconf} USE_THREADS=yes"
- einstall ${myconf} mandir="${D}/usr/share/man" || die "make install failed"
- newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN} || die "newinitd failed"
- newconfd "${FILESDIR}"/${PN}.confd ${PN} || die "newconfd failed"
+ einstall ${myconf} mandir="${ED}/usr/share/man"
+ newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
dodoc README
}