summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-09-09 17:27:36 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-09-09 17:27:36 +0000
commit1840284b22da51e2ff3d980a5c013ace583dd2e8 (patch)
treea9eaed84796708433168e84ee6bdddfb036f217f /www-servers
parentStable on ppc wrt bug 146886 (diff)
downloadgentoo-2-1840284b22da51e2ff3d980a5c013ace583dd2e8.tar.gz
gentoo-2-1840284b22da51e2ff3d980a5c013ace583dd2e8.tar.bz2
gentoo-2-1840284b22da51e2ff3d980a5c013ace583dd2e8.zip
* double bump
(Portage version: 2.1.1)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog9
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.613
-rw-r--r--www-servers/nginx/files/digest-nginx-0.4.03
-rw-r--r--www-servers/nginx/nginx-0.3.61.ebuild79
-rw-r--r--www-servers/nginx/nginx-0.4.0.ebuild79
5 files changed, 172 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 5debfba7ad9b..d39ea032b5c1 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.107 2006/08/18 14:52:07 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.108 2006/09/09 17:27:36 voxus Exp $
+
+*nginx-0.4.0 (09 Sep 2006)
+*nginx-0.3.61 (09 Sep 2006)
+
+ 09 Sep 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.61.ebuild,
+ +nginx-0.4.0.ebuild:
+ Double bump.
*nginx-0.3.60 (18 Aug 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.3.61 b/www-servers/nginx/files/digest-nginx-0.3.61
new file mode 100644
index 000000000000..acc1ae819d7d
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.61
@@ -0,0 +1,3 @@
+MD5 ab9372a0c88b7cbd71d397798dab3c7e nginx-0.3.61.tar.gz 416967
+RMD160 bf4d84d3cdfb6d8f767e75aa9ef69a2bca6c08a0 nginx-0.3.61.tar.gz 416967
+SHA256 19dbfb86c42e38c8ced641b6b8f808951a60003ff711c5f7cc68448a159df6b4 nginx-0.3.61.tar.gz 416967
diff --git a/www-servers/nginx/files/digest-nginx-0.4.0 b/www-servers/nginx/files/digest-nginx-0.4.0
new file mode 100644
index 000000000000..2c4c37dea21b
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.4.0
@@ -0,0 +1,3 @@
+MD5 59db2b315f65cbe9f9452bc882d77999 nginx-0.4.0.tar.gz 421031
+RMD160 e168570b249e522d3a33a0a428ad3b3544374bf5 nginx-0.4.0.tar.gz 421031
+SHA256 4bd30b1ae75f64553d03ce5f2657cb4f8685a272d02c1390e47a92c9d11d9b62 nginx-0.4.0.tar.gz 421031
diff --git a/www-servers/nginx/nginx-0.3.61.ebuild b/www-servers/nginx/nginx-0.3.61.ebuild
new file mode 100644
index 000000000000..1d3d46757225
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.61.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.61.ebuild,v 1.1 2006/09/09 17:27:36 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}
diff --git a/www-servers/nginx/nginx-0.4.0.ebuild b/www-servers/nginx/nginx-0.4.0.ebuild
new file mode 100644
index 000000000000..d7d113a361fa
--- /dev/null
+++ b/www-servers/nginx/nginx-0.4.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.4.0.ebuild,v 1.1 2006/09/09 17:27:36 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}