summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2010-12-21 09:13:39 +0000
committerAlistair Bush <ali_bush@gentoo.org>2010-12-21 09:13:39 +0000
commit4fff7f0fee4a27502ff3c6664528edfc1e855c0a (patch)
tree46ea7068dccb6f603099d2abed6c3fa62695b6a5 /www-servers/tomcat
parentfixed missing php-fpm.conf (bug #349179), removed unused configure option, si... (diff)
downloadgentoo-2-4fff7f0fee4a27502ff3c6664528edfc1e855c0a.tar.gz
gentoo-2-4fff7f0fee4a27502ff3c6664528edfc1e855c0a.tar.bz2
gentoo-2-4fff7f0fee4a27502ff3c6664528edfc1e855c0a.zip
Version Bump. Thanks again to wltjr. Come back wltjr.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/tomcat')
-rw-r--r--www-servers/tomcat/ChangeLog9
-rw-r--r--www-servers/tomcat/files/7/build-xml.patch149
-rw-r--r--www-servers/tomcat/files/7/examples-cal.patch11
-rw-r--r--www-servers/tomcat/files/7/tomcat.conf79
-rw-r--r--www-servers/tomcat/files/7/tomcat.init108
-rw-r--r--www-servers/tomcat/tomcat-7.0.5.ebuild226
6 files changed, 581 insertions, 1 deletions
diff --git a/www-servers/tomcat/ChangeLog b/www-servers/tomcat/ChangeLog
index a53709a42e86..722b189b7b9c 100644
--- a/www-servers/tomcat/ChangeLog
+++ b/www-servers/tomcat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/tomcat
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.233 2010/08/31 15:19:58 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.234 2010/12/21 09:13:39 ali_bush Exp $
+
+*tomcat-7.0.5 (21 Dec 2010)
+
+ 21 Dec 2010; Alistair Bush <ali_bush@gentoo.org> +files/7/build-xml.patch,
+ +files/7/examples-cal.patch, +files/7/tomcat.init, +tomcat-7.0.5.ebuild,
+ +files/7/tomcat.conf:
+ Version Bump. Thanks to wltjr for all the work.
*tomcat-6.0.29 (31 Aug 2010)
diff --git a/www-servers/tomcat/files/7/build-xml.patch b/www-servers/tomcat/files/7/build-xml.patch
new file mode 100644
index 000000000000..637f08ae8a0b
--- /dev/null
+++ b/www-servers/tomcat/files/7/build-xml.patch
@@ -0,0 +1,149 @@
+diff -Naur apache-tomcat-7.0.5-src_orig/build.xml apache-tomcat-7.0.5-src/build.xml
+--- apache-tomcat-7.0.5-src_orig/build.xml 2010-12-06 17:20:48.777166339 -0500
++++ apache-tomcat-7.0.5-src/build.xml 2010-12-06 17:58:10.529303918 -0500
+@@ -38,9 +38,9 @@
+ <!-- Version numbers -->
+ <property name="version.major" value="7" />
+ <property name="version.minor" value="0" />
+- <property name="version.build" value="0" />
++ <property name="version.build" value="5" />
+ <property name="version.patch" value="0" />
+- <property name="version.suffix" value="-dev" />
++ <property name="version.suffix" value="-gentoo" />
+
+ <property name="version" value="${version.major}.${version.minor}.${version.build}${version.suffix}" />
+ <property name="version.number" value="${version.major}.${version.minor}.${version.build}.${version.patch}" />
+@@ -149,6 +149,7 @@
+
+ <!-- Classpaths -->
+ <path id="compile.classpath">
++ <pathelement location="${ant.jar}"/>
+ <pathelement location="${jdt.jar}"/>
+ </path>
+
+@@ -291,6 +292,7 @@
+ <exclude name="org/apache/catalina/mbeans/JmxRemote*" />
+ <exclude name="org/apache/catalina/tribes/**" />
+ <exclude name="org/apache/naming/factory/webservices/**" />
++ <exclude name="javax/servlet/**" />
+ </patternset>
+
+ <patternset id="files.catalina-tribes">
+@@ -420,7 +422,7 @@
+
+ </target>
+
+- <target name="validate" depends="download-validate" if="${execute.validate}">
++ <target name="validate" if="${execute.validate}">
+ <taskdef resource="checkstyletask.properties"
+ classpath="${checkstyle.jar}" />
+ <checkstyle config="checkstyle.xml">
+@@ -437,7 +439,7 @@
+ </checkstyle>
+ </target>
+
+- <target name="compile" depends="build-prepare,download-compile,validate">
++ <target name="compile" depends="build-prepare,validate">
+
+ <!-- Compile internal server components -->
+ <javac srcdir="java" destdir="${tomcat.classes}"
+@@ -498,7 +500,7 @@
+ filesId="files.annotations-api"
+ manifest="${tomcat.manifests}/annotations-api.jar.manifest" />
+
+- <!-- Servlet 3.0 Implementation JAR File -->
++<!-- Servlet 3.0 Implementation JAR File
+ <jarIt jarfile="${servlet-api.jar}"
+ filesDir="${tomcat.classes}"
+ filesId="files.servlet-api"
+@@ -506,7 +508,7 @@
+ notice="${tomcat.manifests}/servlet-api.jar.notice"
+ license="${tomcat.manifests}/servlet-api.jar.license" />
+
+- <!-- JSP 2.2 Implementation JAR File -->
++ JSP 2.2 Implementation JAR File
+ <jarIt jarfile="${jsp-api.jar}"
+ filesDir="${tomcat.classes}"
+ filesId="files.jsp-api"
+@@ -514,12 +516,12 @@
+ notice="${tomcat.manifests}/jsp-api.jar.notice"
+ license="${tomcat.manifests}/jsp-api.jar.license" />
+
+- <!-- JSP 2.2 EL Implementation JAR File -->
++ JSP 2.2 EL Implementation JAR File
+ <jarIt jarfile="${el-api.jar}"
+ filesDir="${tomcat.classes}"
+ filesId="files.el-api"
+ manifest="${tomcat.manifests}/el-api.jar.manifest" />
+-
++-->
+ <!-- Bootstrap JAR File -->
+ <jarIt jarfile="${bootstrap.jar}"
+ filesDir="${tomcat.classes}"
+@@ -610,7 +612,7 @@
+
+ </target>
+
+- <target name="build-docs" description="Builds all documentation from XML sources">
++ <target name="build-docs" unless="nobuild.docs" description="Builds all documentation from XML sources">
+
+ <copy todir="${tomcat.build}/webapps">
+ <fileset dir="webapps">
+@@ -718,14 +720,14 @@
+
+ <target name="deploy" depends="package,build-docs"
+ description="Default. Builds a working Tomcat instance">
+-
++<!--
+ <copy tofile="${tomcat.build}/bin/tomcat-native.tar.gz"
+ file="${tomcat-native.tar.gz}" />
+ <copy tofile="${tomcat.build}/bin/commons-daemon-native.tar.gz"
+ file="${commons-daemon.native.src.tgz}" />
+
+ <copy tofile="${tomcat.build}/bin/commons-daemon.jar" file="${commons-daemon.jar}" />
+-
++-->
+ <!-- Copy scripts -->
+ <copy todir="${tomcat.build}/bin">
+ <fileset dir="bin">
+@@ -782,7 +784,7 @@
+ source="${compile.source}"
+ target="${compile.target}"
+ optimize="${compile.optimize}"
+- classpath="${tomcat.classes}"
++ classpath="${tomcat.classes}:${jsp-api.jar}"
+ excludes="**/CVS/**,**/.svn/**"
+ encoding="ISO-8859-1"
+ includeantruntime="false">
+@@ -794,7 +796,7 @@
+ source="${compile.source}"
+ target="${compile.target}"
+ optimize="${compile.optimize}"
+- classpath="$tomcat.lcasses}"
++ classpath="${tomcat.classes}:${jsp-api.jar}"
+ excludes="**/CVS/**,**/.svn/**"
+ encoding="ISO-8859-1"
+ includeantruntime="false">
+@@ -802,11 +804,11 @@
+
+ <!-- Add sources for examples -->
+ <antcall target="examples-sources" />
+-
++<!--
+ <copy file="${tomcat-dbcp.jar}" todir="${tomcat.build}/lib"
+ failonerror="false"/>
+ <copy file="${jdt.jar}" todir="${tomcat.build}/lib" />
+-
++-->
+ </target>
+
+ <target name="examples-sources" description="Create examples sources"
+@@ -946,7 +948,7 @@
+ description="Creates the experimental embedded release"
+ depends="embed,embed-sources,embed-extras" />
+
+- <target name="test-compile" depends="compile,download-test-compile" >
++ <target name="test-compile" depends="compile" >
+ <mkdir dir="${test.classes}"/>
+ <!-- Compile -->
+ <javac srcdir="test" destdir="${test.classes}"
diff --git a/www-servers/tomcat/files/7/examples-cal.patch b/www-servers/tomcat/files/7/examples-cal.patch
new file mode 100644
index 000000000000..b8acde4f8791
--- /dev/null
+++ b/www-servers/tomcat/files/7/examples-cal.patch
@@ -0,0 +1,11 @@
+--- webapps/examples/jsp/cal/cal2.jsp 2008-07-21 17:01:28.000000000 -0700
++++ webapps/examples/jsp/cal/cal2-new.jsp 2009-03-06 08:22:39.000000000 -0800
+@@ -35,7 +35,7 @@
+ <FORM METHOD=POST ACTION=cal1.jsp>
+ <BR>
+ <BR> <INPUT NAME="date" TYPE=HIDDEN VALUE="current">
+-<BR> <INPUT NAME="time" TYPE=HIDDEN VALUE=<%= util.HTMLFilter.filter(time) %>
++<BR> <INPUT NAME="time" TYPE=HIDDEN VALUE="<%= util.HTMLFilter.filter(time) %>">
+ <BR> <h2> Description of the event <INPUT NAME="description" TYPE=TEXT SIZE=20> </h2>
+ <BR> <INPUT TYPE=SUBMIT VALUE="submit">
+ </FORM>
diff --git a/www-servers/tomcat/files/7/tomcat.conf b/www-servers/tomcat/files/7/tomcat.conf
new file mode 100644
index 000000000000..ad45eae1e3c5
--- /dev/null
+++ b/www-servers/tomcat/files/7/tomcat.conf
@@ -0,0 +1,79 @@
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/7/tomcat.conf,v 1.1 2010/12/21 09:13:39 ali_bush Exp $
+
+# JVM Runtime
+# Using the default setting, it will determine your JVM from the system-vm
+# set using java-config.
+# See java-config(1) manual page for assistance in determining this value.
+#
+# You can override this value with whatever path you wish.
+# Example: export GENTOO_VM="sun-jdk-1.6"
+
+#export GENTOO_VM="sun-jdk-1.6"
+
+# (Optional) Java runtime options used when the "start", "stop", or "run"
+# commands are executed.
+# Example to set library path for tomcat-native
+# JAVA_OPTS="-Djava.library.path=/usr/lib"
+# JAVA_OPTS=""
+
+# Where your web applications are located
+CATALINA_HOME=/usr/share/tomcat-7/
+CATALINA_BASE=/var/lib/tomcat-7/
+
+# Tomcat's User/Group
+# Change these at your own risk!!! These are not supported so if it
+# breaks something, you are on your own.
+CATALINA_USER=tomcat
+CATALINA_GROUP=tomcat
+
+# Location of the Tomcat JARs and classes
+CATALINA_LIBDIR=/usr/share/tomcat-7/lib/
+
+# The CLASSPATH for Tomcat to use, plus any others you need.
+CLASSPATH=${CATALINA_LIBDIR}
+
+# (Optional) Directory path location of temporary directory the JVM should
+# use (java.io.tmpdir). Defaults to $CATALINA_BASE/temp.
+# Note: This directory must exist and be read/writable by tomcat.
+# See #246362 as an example where /var/tmp was deleted on shutdown.
+CATALINA_TMPDIR="/var/tmp/tomcat-7/"
+
+# TOMCAT STARTUP/SHUTDOWN
+# debug Start Catalina in a debugger
+# -security debug Debug Catalina with a security manager
+# jpda start Start Catalina under JPDA debugger
+# start Start Catalina in a separate window
+# -security start Start in a separate window with security manager
+# stop Stop Catalina"
+#
+# NOTE: -security requires JSSE (see below)
+# NOTE: jpda requires JPDA (see below)
+TOMCAT_START="start"
+TOMCAT_STOP="stop"
+
+# (Optional) Java runtime options used when the "start", "stop", or "run"
+# commands are executed.
+# CATALINA_OPTS=""
+
+# Java Platform Debugger Architecture (JPDA)
+# http://java.sun.com/products/jpda/
+# Included with Java SDK 1.3 and later. No need to specify location.
+#
+# JPDA_TRANSPORT (Optional) JPDA transport used when the "jpda start"
+# command is executed. The default is "dt_socket".
+#
+# JPDA_ADDRESS (Optional) Java runtime options used when the "jpda start"
+# command is executed. The default is 8000.
+#
+# JPDA_TRANSPORT="dt_socket"
+# JPDA_ADDRESS="8000"
+
+# Java Secure Socket Extension (JSSE)
+# http://java.sun.com/products/jsse/
+# Included with Java SDK 1.4 and later.
+#
+# JSSE_HOME (Optional) May point at your Java Secure Sockets Extension
+# (JSSE) installation, whose JAR files will be added to the
+# system class path used to start Tomcat.
+#
+# JSSE_HOME="/opt/sun-jdk-1.5.0.09/jre/lib/"
diff --git a/www-servers/tomcat/files/7/tomcat.init b/www-servers/tomcat/files/7/tomcat.init
new file mode 100644
index 000000000000..9a8f4bba0e00
--- /dev/null
+++ b/www-servers/tomcat/files/7/tomcat.init
@@ -0,0 +1,108 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/7/tomcat.init,v 1.1 2010/12/21 09:13:39 ali_bush Exp $
+
+opts="${opts} forcestop"
+
+init_env_vars() {
+ # Populate JAVA_HOME
+ JAVA_HOME=`java-config --jre-home`
+
+ # Set some sane defaults
+ if [ -z "${CATALINA_TMPDIR}" ] ; then
+ CATALINA_TMPDIR="${CATALINA_BASE}"/temp
+ fi
+ JPDA_TRANSPORT=${JPDA_TRANSPORT:="dt_socket"}
+ JPDA_ADDRESS=${JPDA_ADDRESS:="8000"}
+ JPDA_OPTS=${JPDA_OPTS="-Xdebug -Xrunjdwp:transport=${JPDA_TRANSPORT},address=${JPDA_ADDRESS},server=y,suspend=n"}
+
+ # Activate Logging
+ if [ -r "${CATALINA_HOME}"/bin/tomcat-juli.jar ]; then
+ JAVA_OPTS="${JAVA_OPTS} -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager \
+ -Djava.util.logging.config.file=${CATALINA_BASE}/conf/logging.properties"
+ fi
+
+ # Populate the classpath
+ unset CLASSPATH
+ CLASSPATH="${CATALINA_HOME}/lib:${JAVA_HOME}/lib/tools.jar"
+ if [ -n "${JSSE_HOME}" ]; then
+ CLASSPATH="${CLASSPATH}:${JSSE_HOME}/lib/jcert.jar:${JSSE_HOME}/lib/jnet.jar:${JSSE_HOME}/lib/jsse.jar"
+ fi
+ CLASSPATH="${CLASSPATH}:${CATALINA_HOME}/bin/bootstrap.jar:${CATALINA_HOME}/bin/tomcat-juli.jar"
+
+ OPTS_CP="${JAVA_OPTS} ${CATALINA_OPTS} -classpath ${CLASSPATH}"
+
+ CATALINA_ARGS="-Dcatalina.base=${CATALINA_BASE} \
+ -Dcatalina.home=${CATALINA_HOME} \
+ -Djava.io.tmpdir=${CATALINA_TMPDIR} \
+ org.apache.catalina.startup.Bootstrap "
+}
+
+ssd() {
+ local exec=${1}
+ shift
+ start-stop-daemon --start --quiet --background \
+ --chdir "${CATALINA_TMPDIR}" \
+ --chuid ${CATALINA_USER}:${CATALINA_GROUP} \
+ --make-pidfile --pidfile /var/run/tomcat-7.pid \
+ --exec ${exec} -- ${OPTS_CP} "$@" ${CATALINA_ARGS} ${TOMCAT_START}
+ return $?
+}
+
+depend() {
+ use dns logger net
+}
+
+start() {
+ ebegin "Starting Tomcat"
+ init_env_vars
+
+ if [ ! -e "${CATALINA_TMPDIR}" ]; then
+ eerror "CATALINA_TMPDIR does not exist. Unable to start tomcat."
+ eerror "Please see /etc/conf.d/tomcat-7 for more information."
+ eend 1
+ fi
+
+ # Figure out what args to pass start_helper based on TOMCAT_START
+ if [ "${TOMCAT_START}" = "debug" ] ; then
+ ssd ${JAVA_HOME}/bin/jdb \
+ -sourcepath ${CATALINA_HOME}/../../jakarta-tomcat-catalina/catalina/src/share
+ elif [ "${TOMCAT_START}" = "-security debug" ] ; then
+ ssd ${JAVA_HOME}/bin/jdb \
+ -sourcepath ${CATALINA_HOME}/../../jakarta-tomcat-catalina/catalina/src/share \
+ -Djava.security.manager \
+ -Djava.security.policy=${CATALINA_BASE}/conf/catalina.policy
+ elif [ "${TOMCAT_START}" = "jpda start" ] ; then
+ ssd ${JAVA_HOME}/bin/java ${JPDA_OPTS}
+ elif [ "${TOMCAT_START}" = "start" ] ; then
+ ssd ${JAVA_HOME}/bin/java
+ elif [ "${TOMCAT_START}" = "-security start" ] ; then
+ ssd ${JAVA_HOME}/bin/java \
+ -Djava.security.manager \
+ -Djava.security.policy=${CATALINA_BASE}/conf/catalina.policy
+ else
+ eerror "Invalid TOMCAT_START variable value, or one is not set"
+ eerror "Please see /etc/conf.d/tomcat-7 for more information"
+ eend 1
+ fi
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Tomcat"
+ init_env_vars
+ start-stop-daemon --stop --quiet --retry=60 \
+ --pidfile /var/run/tomcat-7.pid \
+ --exec ${JAVA_HOME}/bin/java -- ${OPTS_CP} ${CATALINA_args} stop ${STD_OUT}
+ eend $?
+}
+forcestop() {
+ ebegin "Forcing Tomcat to Stop"
+ start-stop-daemon --stop --quiet --retry=60 \
+ --pidfile /var/run/tomcat-7.pid --signal=9
+ if service_started "${SVCNAME}"; then
+ mark_service_stopped "${SVCNAME}"
+ fi
+ eend $?
+}
diff --git a/www-servers/tomcat/tomcat-7.0.5.ebuild b/www-servers/tomcat/tomcat-7.0.5.ebuild
new file mode 100644
index 000000000000..55676f2c9e43
--- /dev/null
+++ b/www-servers/tomcat/tomcat-7.0.5.ebuild
@@ -0,0 +1,226 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.5.ebuild,v 1.1 2010/12/21 09:13:39 ali_bush Exp $
+
+EAPI=2
+JAVA_PKG_IUSE="doc examples source test"
+WANT_ANT_TASKS="ant-trax"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Tomcat Servlet-3.0/JSP-2.2 Container"
+
+MY_P="apache-${P/_beta/}-src"
+SLOT="7"
+SRC_URI="mirror://apache/${PN}/${PN}-${SLOT}/v${PV/_/-}-beta/src/${MY_P}.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+LICENSE="Apache-2.0"
+
+IUSE=""
+
+# eclipse ecj version/slot
+ECJV="3.6"
+
+# servlet-api slot
+SAPIS="3.0"
+
+COMMON_DEPEND="dev-java/eclipse-ecj:${ECJV}
+ dev-java/ant-eclipse-ecj:${ECJV}
+ >=dev-java/commons-dbcp-1.4
+ >=dev-java/commons-logging-1.1
+ >=dev-java/commons-pool-1.5.5
+ ~dev-java/tomcat-servlet-api-${PV}
+ examples? ( dev-java/jakarta-jstl )"
+
+RDEPEND="
+ !<dev-java/tomcat-native-1.1.20
+ >=virtual/jre-1.6
+ >=dev-java/commons-daemon-1.0.3
+ dev-java/ant-core
+ ${COMMON_DEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${COMMON_DEPEND}
+ test? ( =dev-java/junit-3.8* )"
+
+S=${WORKDIR}/${MY_P}
+
+TOMCAT_NAME="${PN}-${SLOT}"
+TOMCAT_HOME="/usr/share/${TOMCAT_NAME}"
+WEBAPPS_DIR="/var/lib/${TOMCAT_NAME}/webapps"
+
+# TODO: Fails to find PrettyPrint in with python 2.6 and xml-rewriter-3
+# Find out why so
+JAVA_ANT_CELEMENT_REWRITER="true"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+EANT_NEEDS_TOOLS="true"
+EANT_GENTOO_CLASSPATH="tomcat-servlet-api-${SAPIS},eclipse-ecj-${ECJV}"
+
+EANT_BUILD_TARGET="package"
+EANT_DOC_TARGET="build-docs"
+
+EANT_EXTRA_ARGS="-Dbase.path=${T} -Dversion=${PV}-gentoo -Dversion.number=${PV}
+-Dcompile.debug=false -Del-api.jar=el-api.jar -Djsp-api.jar=jsp-api.jar -Dservlet-api.jar=servlet-api.jar
+-Dant.jar=ant.jar"
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+ enewgroup tomcat 265
+ enewuser tomcat 265 -1 /dev/null tomcat
+}
+
+java_prepare() {
+ epatch "${FILESDIR}/${SLOT}/build-xml.patch"
+
+ rm -v webapps/examples/WEB-INF/lib/*.jar \
+ test/webapp-3.0-fragments/WEB-INF/lib/*.jar || die
+
+ # bug # 178980 and #312293
+ use amd64 && java-pkg_force-compiler eclipse-ecj-${ECJV}
+
+ if ! use doc; then
+ EANT_EXTRA_ARGS+=" -Dnobuild.docs=true"
+ fi
+
+ EANT_EXTRA_ARGS+=" -Djdt.jar=$(java-pkg_getjar eclipse-ecj-${ECJV} ecj.jar)"
+ java-pkg_jarfrom --build-only ant-core ant.jar
+}
+
+src_install() {
+ cd "${S}/bin"
+ rm -f *.bat
+ chmod 755 *.sh
+
+ # register jars per bug #171496
+ cd "${S}/output/build/lib/"
+ for jar in *.jar; do
+ java-pkg_dojar ${jar}
+ done
+
+ local CATALINA_BASE=/var/lib/${TOMCAT_NAME}/
+
+ # init.d, conf.d
+ newinitd "${FILESDIR}"/${SLOT}/tomcat.init ${TOMCAT_NAME}
+ newconfd "${FILESDIR}"/${SLOT}/tomcat.conf ${TOMCAT_NAME}
+
+ # create dir structure
+ dodir /usr/share/${TOMCAT_NAME}
+
+ diropts -m750 -o tomcat -g tomcat
+ dodir /etc/${TOMCAT_NAME}
+ keepdir ${WEBAPPS_DIR}
+
+ diropts -m755 -o tomcat -g tomcat
+ dodir ${CATALINA_BASE}
+
+ diropts -m775 -o tomcat -g tomcat
+ dodir /etc/${TOMCAT_NAME}/Catalina/localhost
+ keepdir /var/log/${TOMCAT_NAME}/
+ keepdir /var/run/${TOMCAT_NAME}/
+ keepdir /var/tmp/${TOMCAT_NAME}/
+
+ cd "${S}"
+ # fix context's so webapps will be deployed
+ sed -i -e 's:Context a:Context docBase="${catalina.home}/webapps/host-manager" a:' "${S}"/webapps/host-manager/META-INF/context.xml
+ sed -i -e 's:Context a:Context docBase="${catalina.home}/webapps/manager" a:' "${S}"/webapps/manager/META-INF/context.xml
+
+ # replace the default pw with a random one, see #92281
+ local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
+ sed -e s:SHUTDOWN:${randpw}: -i conf/server.xml
+
+ # copy over the directories
+ chown -R tomcat:tomcat webapps/* conf/*
+ cp -pR conf/* "${D}"/etc/${TOMCAT_NAME} || die "failed to copy conf"
+ cp -pPR output/build/bin "${D}"/usr/share/${TOMCAT_NAME} \
+ || die "failed to copy"
+ # webapps get stored in /usr/share/${TOMCAT_NAME}/webapps
+ cd "${S}"/webapps || die
+ ebegin "Installing webapps to /usr/share/${TOMCAT_NAME}"
+
+ cp -pR ROOT "${D}"/usr/share/${TOMCAT_NAME}/webapps || die
+ cp -pR host-manager "${D}"/usr/share/${TOMCAT_NAME}/webapps || die
+ cp -pR manager "${D}"/usr/share/${TOMCAT_NAME}/webapps || die
+ if use doc; then
+ cp -pR docs "${D}"/usr/share/${TOMCAT_NAME}/webapps || die
+ fi
+ if use examples; then
+ cd "${S}"/webapps/examples/WEB-INF/lib
+ java-pkg_jar-from jakarta-jstl jstl.jar
+ java-pkg_jar-from jakarta-jstl standard.jar
+ cd "${S}"/webapps
+ cp -pR examples "${D}"/usr/share/${TOMCAT_NAME}/webapps || die
+ fi
+
+ # replace catalina.policy with gentoo specific one bug #176701
+# cp ${FILESDIR}/${SLOT}/catalina.policy "${D}"/etc/${TOMCAT_NAME} \
+# || die "failed to replace catalina.policy"
+
+ cd "${D}/usr/share/${TOMCAT_NAME}/lib" || die
+ java-pkg_jar-from eclipse-ecj-${ECJV}
+ java-pkg_jar-from tomcat-servlet-api-${SAPIS}
+
+ # symlink the directories to make CATALINA_BASE possible
+ dosym /etc/${TOMCAT_NAME} ${CATALINA_BASE}/conf
+ dosym /var/log/${TOMCAT_NAME} ${CATALINA_BASE}/logs
+ dosym /var/tmp/${TOMCAT_NAME} ${CATALINA_BASE}/temp
+ dosym /var/run/${TOMCAT_NAME} ${CATALINA_BASE}/work
+
+ dodoc "${S}"/{RELEASE-NOTES,RUNNING.txt}
+ fperms 640 /etc/${TOMCAT_NAME}/tomcat-users.xml
+
+ #install *.sh scripts bug #278059
+ exeinto /usr/share/${TOMCAT_NAME}/bin
+ doexe "${S}"/bin/*.sh
+}
+
+pkg_postinst() {
+ ewarn "Changing ownership recursively on /etc/${TOMCAT_NAME}"
+ # temp fix for bug #176097
+ chown -fR tomcat:tomcat /etc/${TOMCAT_NAME}
+ ewarn "Owner ship changed to tomcat:tomcat. Temp hack/fix."
+
+ # bug #180519
+ if [[ -e "${ROOT}var/lib/${TOMCAT_NAME}/webapps/manager" ]] ; then
+ elog "The latest webapp has NOT been installed into"
+ elog "${ROOT}var/lib/${TOMCAT_NAME}/webapps/ because directory already exists"
+ elog "and we do not want to overwrite any files you have put there."
+ elog
+ elog "Installing latest webapp into"
+ elog "${ROOT}usr/share/${TOMCAT_NAME}/webapps instead"
+ elog
+ elog "Manager Symbolic Links NOT created."
+
+ else
+ einfo "Installing latest webroot to ${ROOT}/${WEBAPPS_DIR}"
+ cp -pR "${ROOT}"/usr/share/${TOMCAT_NAME}/webapps/* \
+ "${ROOT}""${WEBAPPS_DIR}"
+ # link the manager's context to the right position
+ dosym ${TOMCAT_HOME}/webapps/host-manager/META-INF/context.xml /etc/${TOMCAT_NAME}/Catalina/localhost/host-manager.xml
+ dosym ${TOMCAT_HOME}/webapps/manager/META-INF/context.xml /etc/${TOMCAT_NAME}/Catalina/localhost/manager.xml
+ fi
+
+ elog
+ elog " This ebuild implements a FHS compliant layout for tomcat"
+ elog " Please read http://www.gentoo.org/proj/en/java/tomcat6-guide.xml"
+ elog " for more information."
+ elog
+ ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
+ ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
+ elog
+
+ ewarn "The manager webapps have known exploits, please refer to"
+ ewarn "http://cve.mitre.org/cgi-bin/cvename.cgi?name=2007-2450"
+
+ if use examples ; then
+ ewarn
+ ewarn "The examples webapp has a known exploit, please refer to"
+ ewarn "http://cve.mitre.org/cgi-bin/cvename.cgi?name=2007-2449"
+ ewarn
+ fi
+
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}