summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2006-09-06 06:18:05 +0000
committerThilo Bangert <bangert@gentoo.org>2006-09-06 06:18:05 +0000
commit1157a77b121dcef7eec55b00582bf63fefa38c84 (patch)
treed9df3ac427b601f456524254f9cebb4e58f585ba /www-servers/pound
parentstable x86; gcc-4...about 25 more to go (diff)
downloadgentoo-2-1157a77b121dcef7eec55b00582bf63fefa38c84.tar.gz
gentoo-2-1157a77b121dcef7eec55b00582bf63fefa38c84.tar.bz2
gentoo-2-1157a77b121dcef7eec55b00582bf63fefa38c84.zip
version bump - fixes #146469 - thanks to Pedro Algarvio
(Portage version: 2.1-r2)
Diffstat (limited to 'www-servers/pound')
-rw-r--r--www-servers/pound/ChangeLog7
-rw-r--r--www-servers/pound/files/digest-pound-1.102
-rw-r--r--www-servers/pound/files/digest-pound-2.0.52
-rw-r--r--www-servers/pound/files/digest-pound-2.13
-rw-r--r--www-servers/pound/pound-2.1.ebuild56
5 files changed, 69 insertions, 1 deletions
diff --git a/www-servers/pound/ChangeLog b/www-servers/pound/ChangeLog
index 6c1f82b96d01..c6c8b0072c98 100644
--- a/www-servers/pound/ChangeLog
+++ b/www-servers/pound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/pound
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.22 2006/05/21 09:10:24 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.23 2006/09/06 06:18:05 bangert Exp $
+
+*pound-2.1 (06 Sep 2006)
+
+ 06 Sep 2006; Thilo Bangert <bangert@gentoo.org> +pound-2.1.ebuild:
+ version bump - fixes #146469 - thanks to Pedro Algarvio
21 May 2006; Thilo Bangert <bangert@gentoo.org> -files/pound.init,
-pound-1.9.ebuild, -pound-2.0.3.ebuild:
diff --git a/www-servers/pound/files/digest-pound-1.10 b/www-servers/pound/files/digest-pound-1.10
index 22185fc4caf5..fd9a3b6b1255 100644
--- a/www-servers/pound/files/digest-pound-1.10
+++ b/www-servers/pound/files/digest-pound-1.10
@@ -1 +1,3 @@
MD5 5792fd804907cc617e37607c6783d5f7 Pound-1.10.tgz 145616
+RMD160 1b76d1a7c3893266f24c4f1676cd77cf12bfce28 Pound-1.10.tgz 145616
+SHA256 64be15d72e9bd69d8633c66be5de6cccdd67f8a8fc9328521c304f83935c0b2a Pound-1.10.tgz 145616
diff --git a/www-servers/pound/files/digest-pound-2.0.5 b/www-servers/pound/files/digest-pound-2.0.5
index ee8d908c6b59..3a12366f4cb3 100644
--- a/www-servers/pound/files/digest-pound-2.0.5
+++ b/www-servers/pound/files/digest-pound-2.0.5
@@ -1 +1,3 @@
MD5 4db2c0f8e9694e02eafb3c89d12b296f Pound-2.0.5.tgz 143843
+RMD160 09b4e0fa49182cd3c692909a04be9a91399b729b Pound-2.0.5.tgz 143843
+SHA256 05030bc7522ba4c4a5f609cc5b8fe7880a91b1dd7f034d33a0c5e0c5d643673f Pound-2.0.5.tgz 143843
diff --git a/www-servers/pound/files/digest-pound-2.1 b/www-servers/pound/files/digest-pound-2.1
new file mode 100644
index 000000000000..40ce9a180235
--- /dev/null
+++ b/www-servers/pound/files/digest-pound-2.1
@@ -0,0 +1,3 @@
+MD5 d51fefbaef369c94b87785400e52120f Pound-2.1.tgz 136877
+RMD160 949bcf37c2824f6e713c8d1a36279a66d1a0b5e2 Pound-2.1.tgz 136877
+SHA256 088a5544cdb1133ddcc0fe84b27f2508bbe070ab15f59a986bf42341b1d672d9 Pound-2.1.tgz 136877
diff --git a/www-servers/pound/pound-2.1.ebuild b/www-servers/pound/pound-2.1.ebuild
new file mode 100644
index 000000000000..d954a49f485b
--- /dev/null
+++ b/www-servers/pound/pound-2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-2.1.ebuild,v 1.1 2006/09/06 06:18:05 bangert Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/p/P}"
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+HOMEPAGE="http://www.apsis.ch/pound/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="ssl msdav unsafe static"
+
+DEPEND="virtual/libc
+ ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ use static && append-ldflags -static
+
+ econf \
+ $(use_with ssl) \
+ $(use_enable msdav) \
+ $(use_enable unsafe) \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ dodir /usr/sbin
+ cp ${S}/pound ${D}/usr/sbin/
+
+ doman pound.8
+ dodoc README FAQ
+
+ dodir /etc/init.d
+ newinitd ${FILESDIR}/pound.init-1.9 pound
+
+ insinto /etc
+ newins ${FILESDIR}/pound-2.cfg pound.cfg
+}
+
+pkg_postinst() {
+ einfo "No demo-/sample-configfile is included in the distribution -- read the man-page"
+ einfo "for more info."
+ einfo "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+ echo
+ ewarn "You will have to upgrade you configuration file, if you are"
+ ewarn "upgrading from a version <= 2.0."
+ echo
+}