summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-04-02 12:46:08 +0000
committerRoy Marples <uberlord@gentoo.org>2007-04-02 12:46:08 +0000
commit812c41686f2b763ebb09644c6fb61d1b091aca8a (patch)
tree963c4ecf27ca8df759519323ab359c9e7f3d8930 /www-servers/lighttpd
parentMask app-shells/ash (diff)
downloadgentoo-2-812c41686f2b763ebb09644c6fb61d1b091aca8a.tar.gz
gentoo-2-812c41686f2b763ebb09644c6fb61d1b091aca8a.tar.bz2
gentoo-2-812c41686f2b763ebb09644c6fb61d1b091aca8a.zip
Remove bashisms from spawn-fcgi
(Portage version: 2.1.2.3)
Diffstat (limited to 'www-servers/lighttpd')
-rw-r--r--www-servers/lighttpd/ChangeLog5
-rw-r--r--www-servers/lighttpd/files/spawn-fcgi.initd10
2 files changed, 10 insertions, 5 deletions
diff --git a/www-servers/lighttpd/ChangeLog b/www-servers/lighttpd/ChangeLog
index 8a78fd0673ee..663cec7e6ee0 100644
--- a/www-servers/lighttpd/ChangeLog
+++ b/www-servers/lighttpd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-servers/lighttpd
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/ChangeLog,v 1.106 2007/04/01 23:22:00 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/ChangeLog,v 1.107 2007/04/02 12:46:08 uberlord Exp $
+
+ 02 Apr 2007; Roy Marples <uberlord@gentoo.org> files/spawn-fcgi.initd:
+ Remove bashisms from spawn-fcgi
01 Apr 2007; Robin H. Johnson <robbat2@gentoo.org>
+files/conf/mod_fastcgi.conf-1.4.13-r2, lighttpd-1.4.13-r2.ebuild:
diff --git a/www-servers/lighttpd/files/spawn-fcgi.initd b/www-servers/lighttpd/files/spawn-fcgi.initd
index 2f93285ddb6b..63daa75081f9 100644
--- a/www-servers/lighttpd/files/spawn-fcgi.initd
+++ b/www-servers/lighttpd/files/spawn-fcgi.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/files/spawn-fcgi.initd,v 1.1 2005/02/14 11:39:01 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/files/spawn-fcgi.initd,v 1.2 2007/04/02 12:46:08 uberlord Exp $
SPAWNFCGI_PID="/var/run/spawn-fcgi.pid"
@@ -40,10 +40,12 @@ start() {
stop() {
ebegin "Stopping spawn-fcgi"
- kill `cat ${SPAWNFCGI_PID}`
- [[ $? -ne 0 ]] && eend $?
+ if ! kill `cat ${SPAWNFCGI_PID}` ; then
+ eend $?
+ return 1
+ fi
if [ -w ${SPAWNFCGI_PID} ]; then
- rm ${SPAWNFCGI_PID};
+ rm ${SPAWNFCGI_PID}
fi
eend 0
}