summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-03-15 20:55:57 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-03-15 20:55:57 +0000
commit5ef9621c8520f1ce3b480e803c13080fbe559f27 (patch)
tree4e0ad5fcaaa445cfb781ae9e1ddc81cac5a967c2 /www-plugins
parentFix incompatible implicit declaration of built-in function exit. (diff)
downloadgentoo-2-5ef9621c8520f1ce3b480e803c13080fbe559f27.tar.gz
gentoo-2-5ef9621c8520f1ce3b480e803c13080fbe559f27.tar.bz2
gentoo-2-5ef9621c8520f1ce3b480e803c13080fbe559f27.zip
www-plugins/gnash-0.8.7 version bump
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/gnash/ChangeLog10
-rw-r--r--www-plugins/gnash/files/gnash-0.8.7-klash.patch97
-rw-r--r--www-plugins/gnash/files/gnash-0.8.7-moc-qt4.patch14
-rw-r--r--www-plugins/gnash/files/gnash-0.8.7-xpcom-idldir.patch18
-rw-r--r--www-plugins/gnash/gnash-0.8.7.ebuild263
5 files changed, 401 insertions, 1 deletions
diff --git a/www-plugins/gnash/ChangeLog b/www-plugins/gnash/ChangeLog
index d860875185ba..0fb8c87db88a 100644
--- a/www-plugins/gnash/ChangeLog
+++ b/www-plugins/gnash/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-plugins/gnash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.21 2010/03/15 15:46:33 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.22 2010/03/15 20:55:57 chithanh Exp $
+
+*gnash-0.8.7 (15 Mar 2010)
+
+ 15 Mar 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +gnash-0.8.7.ebuild, +files/gnash-0.8.7-klash.patch,
+ +files/gnash-0.8.7-moc-qt4.patch, +files/gnash-0.8.7-xpcom-idldir.patch:
+ Version bump. Fixes bug #285157, bug #286444, bug #298848, bug #302793,
+ bug #304335 and bug #305311
15 Mar 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
gnash-0.8.6.ebuild:
diff --git a/www-plugins/gnash/files/gnash-0.8.7-klash.patch b/www-plugins/gnash/files/gnash-0.8.7-klash.patch
new file mode 100644
index 000000000000..1d31fb873e00
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.7-klash.patch
@@ -0,0 +1,97 @@
+--- gnash-0.8.5/macros/kde4.m4.alt-kde4 2009-02-28 15:27:53 +0300
++++ gnash-0.8.5/macros/kde4.m4 2009-07-15 16:02:13 +0400
+@@ -24,7 +24,7 @@ AC_DEFUN([GNASH_PATH_KDE4],
+ with_kde4_incl=${withval})
+ dnl make sure the path is a useable one
+ if test x"${with_kde4_incl}" != x ; then
+- if test ! -f ${with_kde4_incl}/kapp.h ; then
++ if test ! -f ${with_kde4_incl}/kapplication.h ; then
+ AC_MSG_ERROR([${with_kde4_incl} directory doesn't contain any KDE 4.x headers])
+ fi
+ fi
+@@ -38,7 +38,7 @@ AC_DEFUN([GNASH_PATH_KDE4],
+ with_kde4_lib=${withval})
+ dnl make sure the path is a useable one
+ if test x"${with_kde4_lib}" != x ; then
+- if test ! -f ${with_kde4_lib}/libkdeui.la; then
++ if test ! -f ${with_kde4_lib}/libkdeui.so; then
+ AC_MSG_ERROR([${with_kde4_lib} directory doesn't contain any KDE 4.x libraries!])
+ fi
+ fi
+@@ -136,7 +136,7 @@ AC_DEFUN([GNASH_PATH_KDE4],
+ dnl Look for the libraries
+ AC_CACHE_VAL(ac_cv_path_kde4_lib, [
+ if test x"${with_kde4_lib}" != x ; then
+- if test -f ${with_kde4_lib}/libkdeui.la; then
++ if test -f ${with_kde4_lib}/libkdeui.so; then
+ ac_cv_path_kde4_lib="-L`(cd ${with_kde4_lib}; pwd)`"
+ else
+ AC_MSG_ERROR([${with_kde4_lib} directory doesn't contain KDE 4.x libraries.])
+@@ -146,7 +146,7 @@ AC_DEFUN([GNASH_PATH_KDE4],
+ AC_MSG_CHECKING([for kdeui library])
+ kde4_topdir=
+ for i in ${kde4_prefix}/lib64 ${kde4_prefix}/lib $libslist ; do
+- if test -f $i/libkdeui.${shlibext} -o -f $i/libkdeui.la; then
++ if test -f $i/libkdeui.${shlibext} -o -f $i/libkdeui.so; then
+ kde4_topdir=$i
+ AC_MSG_RESULT(${kde4_topdir}/libkdeui)
+ if test ! x"$i" = x"/usr/lib" -a ! x"$i" = x"/usr/lib64"; then
+@@ -169,19 +169,6 @@ AC_DEFUN([GNASH_PATH_KDE4],
+ AC_MSG_RESULT(no)
+ fi
+ fi
+- dnl Look for the kdeprint library, which is required
+- AC_MSG_CHECKING([for kdeprint library])
+- if test x"${libkdeprint}" = x; then
+- if test -f ${kde4_topdir}/libkdeprint.la -o -f ${kde4_topdir}/libkdeprint.${shlibext}; then
+- ac_cv_path_kde4_lib="${ac_cv_path_kde4_lib} -lkdeprint"
+- AC_MSG_RESULT(${kde4_topdir}/libkdeprint)
+- else
+- AC_MSG_RESULT(no)
+- fi
+- else
+- AC_MSG_RESULT(${libkdeprint})
+- ac_cv_path_kde4_lib="${ac_cv_path_kde4_lib} ${libkdeprint}"
+- fi
+ ]) dnl end of cache ac_cv_path_kde4_lib
+ fi dnl end of build_kde4
+
+@@ -201,7 +201,7 @@
+ KDE4_PLUGINDIR="${KDE4_PREFIX}/lib/kde4"
+ KDE4_SERVICESDIR="${KDE4_PREFIX}/share/kde4/services"
+ KDE4_CONFIGDIR="${KDE4_PREFIX}/share/kde4/config"
+- KDE4_APPSDATADIR="${KDE4_PREFIX}/share/kde4/apps/klash"
++ KDE4_APPSDATADIR="${KDE4_PREFIX}/share/apps/klash"
+ fi dnl end of build_kparts4
+
+ if test x"${ac_cv_path_kde4_incl}" != x ; then
+@@ -218,7 +205,7 @@ AC_DEFUN([GNASH_PATH_KDE4],
+ fi dnl end of build_kparts4
+
+ if test x"${ac_cv_path_kde4_incl}" != x ; then
+- if test x"${ac_cv_path_kde3_incl}" != x"-I/usr/include"; then
++ if test x"${ac_cv_path_kde4_incl}" != x"-I/usr/include"; then
+ KDE4_CFLAGS="${ac_cv_path_kde4_incl}"
+ else
+ KDE4_CFLAGS=""
+--- gnash-0.8.5/plugin/klash4/Makefile.am.alt-kde4 2009-06-15 11:53:31 +0400
++++ gnash-0.8.5/plugin/klash4/Makefile.am 2009-07-15 16:02:58 +0400
+@@ -42,6 +39,7 @@ libklashpart_la_LDFLAGS = -avoid-version
+ else
+ libklashpart_la_LDFLAGS = -module -avoid-version -L$(plugindir) $(KDE4_LIBS) $(QT4_LIBS)
+ endif
++libklashpart_la_LIBADD = $(KDE4_LIBS) $(QT4_LIBS) $(X11_LIBS) -lkparts
+
+ dist_kde_services_DATA = klash_part.desktop
+ dist_kde_rc_DATA = klashpartui.rc
+--- gnash-0.8.5/plugin/klash4/pluginsinfo.alt-kde4 2008-12-28 13:13:38 +0300
++++ gnash-0.8.5/plugin/klash4/pluginsinfo 2009-07-15 16:02:13 +0400
+@@ -1,7 +1,7 @@
+ number=1
+
+ [0]
+-description=Shockwave Flash 7.0
++description=Shockwave Flash 10.1 r999
+ file=libklashpart.so
+ mime=application/x-shockwave-flash:swf:Shockwave Flash;application/futuresplash:spl:FutureSplash Player
+ name=Shockwave Flash
diff --git a/www-plugins/gnash/files/gnash-0.8.7-moc-qt4.patch b/www-plugins/gnash/files/gnash-0.8.7-moc-qt4.patch
new file mode 100644
index 000000000000..219685ef16fa
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.7-moc-qt4.patch
@@ -0,0 +1,14 @@
+diff -ur a/macros/qt4.m4 b/macros/qt4.m4
+--- a/macros/qt4.m4 2010-02-11 00:20:17.000000000 +0100
++++ b/macros/qt4.m4 2010-03-15 18:26:34.000000000 +0100
+@@ -167,8 +167,8 @@
+ has_qt4="no"
+ fi
+
+- AC_PATH_PROGS(MOC4, [moc-qt4 moc], ,[${QTDIR}/bin /usr/lib/qt4/bin /usr/share/qt4/bin/ ${pathlist}])
+- AC_PATH_PROGS(UIC4, [uic-qt4 uic], ,[${QTDIR}/bin /usr/lib/qt4/bin /usr/share/qt4/bin/ ${pathlist}])
++ AC_PATH_PROGS(MOC4, [moc-qt4 moc], ,[/usr/bin ${QTDIR}/bin /usr/lib/qt4/bin /usr/share/qt4/bin/ ${pathlist}])
++ AC_PATH_PROGS(UIC4, [uic-qt4 uic], ,[/usr/bin ${QTDIR}/bin /usr/lib/qt4/bin /usr/share/qt4/bin/ ${pathlist}])
+
+
+ AC_SUBST([QT4_CFLAGS])
diff --git a/www-plugins/gnash/files/gnash-0.8.7-xpcom-idldir.patch b/www-plugins/gnash/files/gnash-0.8.7-xpcom-idldir.patch
new file mode 100644
index 000000000000..02f990827208
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.7-xpcom-idldir.patch
@@ -0,0 +1,18 @@
+Author: Chi-Thanh Christopher Nguyen <chithanh@cs.tu-berlin.de>
+Subject: Use pkg-config to determine XPCOM_IDL_DIR instead of non-portable construct.
+Bug: #284073
+
+---
+
+diff -ur a/macros/xpcom.m4 b/macros/xpcom.m4
+--- a/macros/xpcom.m4 2009-03-02 16:29:48.000000000 +0100
++++ b/macros/xpcom.m4 2009-09-08 22:02:21.548228034 +0200
+@@ -102,7 +102,7 @@
+
+ if test x"${ac_cv_path_xpcom_incl}" != x; then
+ XPCOM_CFLAGS="${ac_cv_path_xpcom_incl}"
+- XPCOM_IDL_CFLAGS=`echo $XPCOM_CFLAGS | sed -e 's:include:share/idl:'`
++ XPCOM_IDL_CFLAGS="-I`$PKG_CONFIG --variable=idldir libxul`"
+ XPIDL=$(pkg-config libxul --variable=sdkdir)
+ XPIDL="${XPIDL}xpidl"
+ AC_DEFINE([HAVE_XPCOM], [1], [Use XPCOM in the NPAPI plugin])
diff --git a/www-plugins/gnash/gnash-0.8.7.ebuild b/www-plugins/gnash/gnash-0.8.7.ebuild
new file mode 100644
index 000000000000..b4fdedde1a67
--- /dev/null
+++ b/www-plugins/gnash/gnash-0.8.7.ebuild
@@ -0,0 +1,263 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.7.ebuild,v 1.1 2010/03/15 20:55:57 chithanh Exp $
+
+EAPI="2"
+CMAKE_REQUIRED="false"
+KDE_REQUIRED="optional"
+KDE_MINIMAL="4.2"
+AT_M4DIR="cygnal"
+
+inherit autotools eutils kde4-base multilib nsplugins
+
+DESCRIPTION="GNU Flash movie player that supports many SWF v7,8,9 features"
+HOMEPAGE="http://www.gnu.org/software/gnash/"
+SRC_URI="mirror://gnu/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="agg cairo cygnal dbus doc +ffmpeg gnome gstreamer gtk kde lirc mysql +nls nsplugin +opengl python +sdl ssh ssl test video_cards_intel"
+
+RDEPEND=">=dev-libs/boost-1.35.0
+ dev-libs/expat
+ dev-libs/libxml2
+ media-libs/jpeg
+ media-libs/libpng
+ net-misc/curl
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXv
+ media-libs/giflib
+ x11-proto/xproto
+ agg? ( x11-libs/agg )
+ cairo? ( x11-libs/cairo )
+ doc? (
+ >=app-text/docbook2X-0.8.8
+ app-text/docbook-sgml-utils
+ )
+ ffmpeg? (
+ media-libs/libsdl[X]
+ >=media-video/ffmpeg-0.5
+ )
+ gstreamer? (
+ media-plugins/gst-plugins-ffmpeg
+ media-plugins/gst-plugins-mad
+ media-plugins/gst-plugins-meta
+ )
+ gtk? (
+ x11-libs/gtk+:2
+ net-libs/xulrunner:1.9
+ python? ( dev-python/pygtk:2 )
+ )
+ kde? ( >=kde-base/kdebase-startkde-${KDE_MINIMAL} )
+ opengl? (
+ virtual/opengl
+ gtk? ( x11-libs/gtkglext )
+ )
+ sdl? ( media-libs/libsdl[X] )
+ nsplugin? ( net-libs/xulrunner:1.9 )
+ media-libs/speex[ogg]
+ sys-libs/zlib
+ >=sys-devel/libtool-2.2
+ mysql? ( dev-db/mysql )
+ lirc? ( app-misc/lirc )
+ dbus? ( sys-apps/dbus )
+ ssh? ( >=net-libs/libssh-0.4[server] )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+ gnome? ( app-text/rarian )"
+
+pkg_setup() {
+ if ! ( use agg || use cairo || use opengl ); then
+ ewarn "You are trying to build Gnash without choosing a renderer [agg|cairo|opengl]."
+ has_version x11-libs/cairo && ewarn "cairo enabled as default" \
+ || die "Please enable a renderer"
+ elif use agg && use cairo && use opengl; then
+ ewarn "You enabled 3 renderers, agg was chosen as default."
+ fi
+
+ if ! ( use kde || use gtk || use sdl ); then
+ ewarn "You are trying to build Gnash without choosing a gui frontend [gtk,kde,sdl]."
+ has_version media-libs/libsdl[X] && ewarn "sdl enabled as default" \
+ || die "Please enable at least one of these USE flags."
+ fi
+
+ if use nsplugin && use !gtk; then
+ eerror "Building gnash with nsplugin requires the gtk gui."
+ die "Nsplugin requires the gtk gui."
+ fi
+
+ if use sdl; then
+ ewarn "Enable SDL as gui frontend and sound handler"
+ fi
+
+ if use lirc; then
+ ewarn "Enable LIRC daemon support and lirc extension"
+ fi
+
+ kde4-base_pkg_setup
+}
+
+src_prepare() {
+ local mozsdk_incdir=${S}/plugin/mozilla-sdk/include
+
+ # Defines $(XPIDL) correctly using sdkdir variable from libxul.pc
+ epatch "${FILESDIR}"/${PN}-0.8.5-xpidl-sdkdir.patch
+
+ # Use pkgconfig to determine XPCOM_IDL_DIR instead of non-portable construct.
+ # Fixes building against xulrunner-1.9.0, bug #284073.
+ if has_version ">=net-libs/xulrunner-1.9.2"; then
+ epatch "${FILESDIR}"/${PN}-0.8.7-xpcom-idldir.patch
+ else
+ epatch "${FILESDIR}"/${PN}-0.8.5-xpcom-idldir.patch
+ fi
+
+ # Resurect patch from bug #230287
+ epatch "${FILESDIR}"/${PN}-0.8.3-boost-dynamic-link.patch
+
+ # Adapted from Alt Linux to fix klash support properly
+ epatch "${FILESDIR}"/${PN}-0.8.7-klash.patch
+
+ # Make gnash find moc and uic properly, upstream bug #25758,
+ # gentoo bug #283905
+ epatch "${FILESDIR}"/${PN}-0.8.7-moc-qt4.patch
+
+ # Conflict headers with npapi.h from mozilla-sdk embedded stuffs and libxul-unstable header
+ # in case where xpcom (implicitly added with gtk) is enabled, we use the system header
+ if use gtk; then
+ rm -f ${mozsdk_incdir}/npapi.h
+ if has_version ">=net-libs/xulrunner-1.9.2"; then
+ ln -s $(pkg-config libxul --variable=includedir)/npapi.h \
+ ${mozsdk_incdir}/npapi.h || die "symlink failed"
+ else
+ ln -s $(pkg-config libxul-unstable --variable=includedir)/unstable/npapi.h \
+ ${mozsdk_incdir}/npapi.h || die "symlink failed"
+ fi
+ fi
+ eautoreconf
+}
+src_configure() {
+ local myconf myext gui
+
+ # Set nsplugin install directory.
+ use nsplugin && myconf="${myconf} --with-npapi-plugindir=/opt/netscape/plugins"
+ # Set rendering engine.
+ if use agg; then
+ myconf="${myconf} --enable-renderer=agg"
+ elif use cairo; then
+ myconf="${myconf} --enable-renderer=cairo"
+ else
+ myconf="${myconf} --enable-renderer=ogl"
+ fi
+ # Set kde and konqueror plugin directories.
+ if use kde; then
+ myconf="${myconf}
+ --with-plugins-install=system
+ --with-kde4-incl=${KDEDIR}/include
+ --with-kde4-configdir=${KDEDIR}/share/config
+ --with-kde4-prefix=${KDEDIR}
+ --with-kde4-lib=${KDEDIR}/$(get_libdir)
+ --with-kde-appsdatadir=${KDEDIR}/share/apps/klash
+ --with-kde4-servicesdir=${KDEDIR}/share/kde4/services
+ --with-kde4-plugindir=${KDEDIR}/$(get_libdir)/kde4/plugins"
+ fi
+
+ # Set media handler.
+ if use ffmpeg; then
+ myconf="${myconf} --enable-media=ffmpeg"
+ elif use gstreamer; then
+ myconf="${myconf} --enable-media=gst"
+ else
+ myconf="${myconf} --enable-media=none"
+ fi
+ # Set gui.
+ use gtk && gui=",gtk"
+ use kde && gui="${gui},kde4"
+
+ if use sdl; then
+ gui="${gui},sdl"
+ myconf="${myconf} --enable-sound=sdl"
+ fi
+
+ # Set extensions
+ use mysql && myext=",mysql"
+ use gtk && myext="${myext},gtk"
+ use lirc && myext="${myext},lirc"
+ use dbus && myext="${myext},dbus"
+
+ if [ -z "$gui" ]; then
+ gui="sdl"
+ fi
+
+ # Strip extra comma from gui and myext.
+ gui=$( echo $gui | sed -e 's/,//' )
+ myext=$( echo $myext | sed -e 's/,//' )
+
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-dependency-tracking \
+ --disable-kparts3 \
+ --enable-avm2 \
+ $(use_enable cygnal) \
+ $(use_enable cygnal cgibins) \
+ $(use_enable doc docbook) \
+ $(use_enable gnome ghelp) \
+ $(use_enable gtk npapi) \
+ $(use_enable kde kparts4) \
+ $(use_enable lirc) \
+ $(use_enable nls) \
+ $(use_enable nsplugin npapi) \
+ $(use_enable python) \
+ $(use_enable ssh) \
+ $(use_enable ssl) \
+ $(use_enable test testsuite) \
+ $(use_enable video_cards_intel i810-lod-bias) \
+ --enable-gui=${gui} \
+ --enable-extensions=${myext} \
+ ${myconf}
+}
+src_test() {
+ local log=testsuite-results.txt
+ cd testsuite
+ emake check || die "make check failed"
+ ./anaylse-results.sh > $log || die "results analyze failed"
+ cat $log
+}
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # Install nsplugin in directory set by --with-npapi-plugindir.
+ if use nsplugin; then
+ emake DESTDIR="${D}" install-plugin || die "install plugins failed"
+ fi
+
+ # Install kde konqueror plugin.
+ if use kde; then
+ pushd "${S}/plugin/klash4" >& /dev/null
+ emake DESTDIR="${D}" install-plugin || die "install kde plugins failed"
+ popd >& /dev/null
+ fi
+ # Create a symlink in /usr/$(get_libdir)/nsbrowser/plugins to the nsplugin install directory.
+ use nsplugin && inst_plugin /opt/netscape/plugins/libgnashplugin.so \
+ || rm -rf "${D}/opt"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}
+pkg_postinst() {
+ if use !ffmpeg && use !gstreamer || use gstreamer && ( ! use gnome ); then
+ ewarn ""
+ ewarn "Gnash was built without a media handler and or http handler !"
+ ewarn ""
+ ewarn "If you want Gnash to support video then you will need to"
+ ewarn "rebuild Gnash with either the ffmpeg or gstreamer use flags set."
+ ewarn ""
+ fi
+ ewarn "${PN} is still in heavy development"
+ ewarn "Please first report bugs on upstream gnashdevs and deal with them"
+ ewarn "And then report a Gentoo bug to the maintainer"
+ use kde && kde4-base_pkg_postinst
+}