summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-26 21:55:52 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-26 21:55:52 +0000
commit3a51d928c0c85dc283403605aecc05f2861e3b72 (patch)
treeefedb2612978b200832423572b56cb48d74e098c /www-plugins
parentVersion bump (diff)
downloadgentoo-2-3a51d928c0c85dc283403605aecc05f2861e3b72.tar.gz
gentoo-2-3a51d928c0c85dc283403605aecc05f2861e3b72.tar.bz2
gentoo-2-3a51d928c0c85dc283403605aecc05f2861e3b72.zip
Add patch for configuration without gconf. Fixes bug 301932.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/gecko-mediaplayer/ChangeLog7
-rw-r--r--www-plugins/gecko-mediaplayer/files/gecko-mediaplayer-0.9.8_p347-gconf-2.m4.patch71
-rw-r--r--www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8_p347.ebuild5
3 files changed, 80 insertions, 3 deletions
diff --git a/www-plugins/gecko-mediaplayer/ChangeLog b/www-plugins/gecko-mediaplayer/ChangeLog
index 581f7a5430f7..0bd4b94b56ab 100644
--- a/www-plugins/gecko-mediaplayer/ChangeLog
+++ b/www-plugins/gecko-mediaplayer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-plugins/gecko-mediaplayer
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gecko-mediaplayer/ChangeLog,v 1.28 2010/01/22 18:08:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gecko-mediaplayer/ChangeLog,v 1.29 2010/01/26 21:55:52 yngwin Exp $
+
+ 26 Jan 2010; Ben de Groot <yngwin@gentoo.org>
+ gecko-mediaplayer-0.9.8_p347.ebuild,
+ +files/gecko-mediaplayer-0.9.8_p347-gconf-2.m4.patch:
+ Add patch for configuration without gconf. Fixes bug 301932.
22 Jan 2010; Jeroen Roovers <jer@gentoo.org>
files/gecko-mediaplayer-0.9.8_p347-xulrunner-detection.patch:
diff --git a/www-plugins/gecko-mediaplayer/files/gecko-mediaplayer-0.9.8_p347-gconf-2.m4.patch b/www-plugins/gecko-mediaplayer/files/gecko-mediaplayer-0.9.8_p347-gconf-2.m4.patch
new file mode 100644
index 000000000000..95064b96278c
--- /dev/null
+++ b/www-plugins/gecko-mediaplayer/files/gecko-mediaplayer-0.9.8_p347-gconf-2.m4.patch
@@ -0,0 +1,71 @@
+--- gecko-mediaplayer-r347/Makefile.in.orig 2010-01-26 22:14:23.000000000 +0100
++++ gecko-mediaplayer-r347/Makefile.in 2010-01-26 22:15:32.000000000 +0100
+@@ -39,7 +39,8 @@
+ AUTHORS COPYING ChangeLog INSTALL NEWS compile config.guess \
+ config.sub depcomp install-sh ltmain.sh missing mkinstalldirs
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+-am__aclocal_m4_deps = $(top_srcdir)/configure.in
++am__aclocal_m4_deps = $(top_srcdir)/configure.in \
++ $(top_srcdir)/gconf-2.m4
+ am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
+ $(ACLOCAL_M4)
+ am__CONFIG_DISTCLEAN_FILES = config.status config.cache config.log \
+diff -burN gecko-mediaplayer-r347.orig/gconf-2.m4 gecko-mediaplayer-r347/gconf-2.m4
+--- gecko-mediaplayer-r347.orig/gconf-2.m4 1970-01-01 01:00:00.000000000 +0100
++++ gecko-mediaplayer-r347/gconf-2.m4 2010-01-26 21:59:08.000000000 +0100
+@@ -0,0 +1,44 @@
++dnl AM_GCONF_SOURCE_2
++dnl Defines GCONF_SCHEMA_CONFIG_SOURCE which is where you should install schemas
++dnl (i.e. pass to gconftool-2
++dnl Defines GCONF_SCHEMA_FILE_DIR which is a filesystem directory where
++dnl you should install foo.schemas files
++dnl
++
++AC_DEFUN([AM_GCONF_SOURCE_2],
++[
++ if test "x$GCONF_SCHEMA_INSTALL_SOURCE" = "x"; then
++ GCONF_SCHEMA_CONFIG_SOURCE=`gconftool-2 --get-default-source`
++ else
++ GCONF_SCHEMA_CONFIG_SOURCE=$GCONF_SCHEMA_INSTALL_SOURCE
++ fi
++
++ AC_ARG_WITH([gconf-source],
++ AC_HELP_STRING([--with-gconf-source=sourceaddress],
++ [Config database for installing schema files.]),
++ [GCONF_SCHEMA_CONFIG_SOURCE="$withval"],)
++
++ AC_SUBST(GCONF_SCHEMA_CONFIG_SOURCE)
++ AC_MSG_RESULT([Using config source $GCONF_SCHEMA_CONFIG_SOURCE for schema installation])
++
++ if test "x$GCONF_SCHEMA_FILE_DIR" = "x"; then
++ GCONF_SCHEMA_FILE_DIR='$(sysconfdir)/gconf/schemas'
++ fi
++
++ AC_ARG_WITH([gconf-schema-file-dir],
++ AC_HELP_STRING([--with-gconf-schema-file-dir=dir],
++ [Directory for installing schema files.]),
++ [GCONF_SCHEMA_FILE_DIR="$withval"],)
++
++ AC_SUBST(GCONF_SCHEMA_FILE_DIR)
++ AC_MSG_RESULT([Using $GCONF_SCHEMA_FILE_DIR as install directory for schema files])
++
++ AC_ARG_ENABLE(schemas-install,
++ AC_HELP_STRING([--disable-schemas-install],
++ [Disable the schemas installation]),
++ [case ${enableval} in
++ yes|no) ;;
++ *) AC_MSG_ERROR([bad value ${enableval} for --enable-schemas-install]) ;;
++ esac])
++ AM_CONDITIONAL([GCONF_SCHEMAS_INSTALL], [test "$enable_schemas_install" != no])
++])
+--- gecko-mediaplayer-r347/configure.in.orig 2010-01-26 22:43:08.000000000 +0100
++++ gecko-mediaplayer-r347/configure.in 2010-01-26 22:43:41.000000000 +0100
+@@ -6,6 +6,8 @@
+ AM_CONFIG_HEADER(config.h)
+ AM_MAINTAINER_MODE
+
++m4_include([gconf-2.m4])
++
+ AC_ISC_POSIX
+ AC_PROG_CC
+ AM_PROG_CC_STDC
diff --git a/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8_p347.ebuild b/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8_p347.ebuild
index 9f0c6bc265f8..7e99720f4791 100644
--- a/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8_p347.ebuild
+++ b/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8_p347.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8_p347.ebuild,v 1.3 2010/01/22 14:25:11 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8_p347.ebuild,v 1.4 2010/01/26 21:55:52 yngwin Exp $
EAPI=2
GCONF_DEBUG=no
@@ -38,8 +38,9 @@ pkg_setup() {
}
src_prepare() {
- gnome2_src_prepare
+ epatch "${FILESDIR}"/${P}-gconf-2.m4.patch
epatch "${FILESDIR}"/${P}-xulrunner-detection.patch
+ gnome2_src_prepare
eautoreconf
}