summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-08 20:38:26 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-08 20:38:26 +0000
commit1f887f061ad09944835ae009a6677ad591915d50 (patch)
treebecdaa3380b62aa1e76e1e6da722d40b6292c6c9 /www-plugins
parentRemove old versions. (diff)
downloadgentoo-2-1f887f061ad09944835ae009a6677ad591915d50.tar.gz
gentoo-2-1f887f061ad09944835ae009a6677ad591915d50.tar.bz2
gentoo-2-1f887f061ad09944835ae009a6677ad591915d50.zip
Respect CC, LDFLAGS (bug #268493). Change HOMEPAGE.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/libflashsupport/ChangeLog8
-rw-r--r--www-plugins/libflashsupport/files/libflashsupport-1.2-gentoo.patch20
-rw-r--r--www-plugins/libflashsupport/libflashsupport-1.2.ebuild10
3 files changed, 32 insertions, 6 deletions
diff --git a/www-plugins/libflashsupport/ChangeLog b/www-plugins/libflashsupport/ChangeLog
index 4bfe30751cbd..4261f8da51a0 100644
--- a/www-plugins/libflashsupport/ChangeLog
+++ b/www-plugins/libflashsupport/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/libflashsupport
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/libflashsupport/ChangeLog,v 1.3 2009/12/28 15:18:27 lack Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/libflashsupport/ChangeLog,v 1.4 2010/02/08 20:38:25 jer Exp $
+
+ 08 Feb 2010; Jeroen Roovers <jer@gentoo.org> libflashsupport-1.2.ebuild,
+ +files/libflashsupport-1.2-gentoo.patch:
+ Respect CC, LDFLAGS (bug #268493). Change HOMEPAGE.
10 Dec 2009; Jim Ramsay <lack@gentoo.org> libflashsupport-1.2.ebuild:
Block >=www-plugins/adobe-flash-10, this is only needed for flash-9
diff --git a/www-plugins/libflashsupport/files/libflashsupport-1.2-gentoo.patch b/www-plugins/libflashsupport/files/libflashsupport-1.2-gentoo.patch
new file mode 100644
index 000000000000..478220db341d
--- /dev/null
+++ b/www-plugins/libflashsupport/files/libflashsupport-1.2-gentoo.patch
@@ -0,0 +1,20 @@
+--- libflashsupport-1.2/Makefile.org 2010-02-08 21:30:35.000000000 +0100
++++ libflashsupport-1.2/Makefile 2010-02-08 21:34:35.000000000 +0100
+@@ -1,6 +1,6 @@
+ #Default flags
+-CC=gcc
+-CFLAGS=-fPIC -shared -O2 -Wall -Werror
++CC ?= gcc
++CFLAGS += -fPIC -shared -Wall
+ LIBS=-lpthread
+
+ #Define library directory
+@@ -49,7 +49,7 @@
+ all: libflashsupport.so
+
+ libflashsupport.so: flashsupport.c
+- $(CC) $(CFLAGS) $(LIBS) -DLIBDIR=$(LIBDIR) \
++ $(CC) $(CFLAGS) $(LDFLAGS) $(LIBS) -DLIBDIR=$(LIBDIR) \
+ flashsupport.c -o libflashsupport.so \
+ $(ALSA) $(ALSALIBS) $(PULSE) $(LIBPULSEPATH) $(ESD) $(LIBESDPATH) \
+ $(OSS) $(SSL) $(SSLLIBS) $(V4L) $(ICULIBS)
diff --git a/www-plugins/libflashsupport/libflashsupport-1.2.ebuild b/www-plugins/libflashsupport/libflashsupport-1.2.ebuild
index b27587d5b4fd..9c2058b73fd1 100644
--- a/www-plugins/libflashsupport/libflashsupport-1.2.ebuild
+++ b/www-plugins/libflashsupport/libflashsupport-1.2.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/libflashsupport/libflashsupport-1.2.ebuild,v 1.3 2009/12/28 15:18:27 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/libflashsupport/libflashsupport-1.2.ebuild,v 1.4 2010/02/08 20:38:25 jer Exp $
-inherit multilib eutils
+inherit eutils multilib toolchain-funcs
DESCRIPTION="Adds pulseaudio/esd/oss audio output and HTTPS/RTMPS support to
Adobe Flash 9"
-HOMEPAGE="http://pulseaudio.revolutionlinux.com/PulseAudio"
+HOMEPAGE="http://pulseaudio.org/wiki/FlashPlayer9Solution"
SRC_URI="https://svn.revolutionlinux.com/MILLE/XTERM/trunk/libflashsupport/Tarballs/${P}.tar.bz2"
LICENSE="Adobe-SourceCode"
@@ -32,9 +32,11 @@ src_unpack() {
README flashsupport.c || die "sed failed"
epatch "${FILESDIR}"/${P}-asneeded.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch
}
src_compile() {
+ tc-export CC
if use pulseaudio; then
export LIBPULSEPATH="-DLIBPULSEPATH='\"libpulse-simple.so.0\"'"
export PULSE="-DPULSEAUDIO"