summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-22 14:25:11 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-22 14:25:11 +0000
commit0514466be23acb7a021e068c560c20e7a46b3546 (patch)
tree07ec7b069b40b3874fe22687b8e0ad9221db6c2f /www-plugins
parentAdd some elog instructions messages (diff)
downloadgentoo-2-0514466be23acb7a021e068c560c20e7a46b3546.tar.gz
gentoo-2-0514466be23acb7a021e068c560c20e7a46b3546.tar.bz2
gentoo-2-0514466be23acb7a021e068c560c20e7a46b3546.zip
Add xulrunner detection patch to prevent breakage when seamonkey-1 is installed. Thanks to Anarchy and ssuominen.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/gecko-mediaplayer/ChangeLog8
-rw-r--r--www-plugins/gecko-mediaplayer/files/gecko-mediaplayer-0.9.8_p347-xulrunner-detection.patch46
-rw-r--r--www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8_p347.ebuild10
3 files changed, 61 insertions, 3 deletions
diff --git a/www-plugins/gecko-mediaplayer/ChangeLog b/www-plugins/gecko-mediaplayer/ChangeLog
index a2ccba529547..e488da743224 100644
--- a/www-plugins/gecko-mediaplayer/ChangeLog
+++ b/www-plugins/gecko-mediaplayer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/gecko-mediaplayer
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gecko-mediaplayer/ChangeLog,v 1.26 2010/01/22 14:01:39 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gecko-mediaplayer/ChangeLog,v 1.27 2010/01/22 14:25:11 yngwin Exp $
+
+ 22 Jan 2010; Ben de Groot <yngwin@gentoo.org>
+ gecko-mediaplayer-0.9.8_p347.ebuild,
+ +files/gecko-mediaplayer-0.9.8_p347-xulrunner-detection.patch:
+ Add xulrunner detection patch to prevent breakage when seamonkey-1 is
+ installed. Thanks to Anarchy and ssuominen.
22 Jan 2010; Ben de Groot <yngwin@gentoo.org>
gecko-mediaplayer-0.9.8_p347.ebuild:
diff --git a/www-plugins/gecko-mediaplayer/files/gecko-mediaplayer-0.9.8_p347-xulrunner-detection.patch b/www-plugins/gecko-mediaplayer/files/gecko-mediaplayer-0.9.8_p347-xulrunner-detection.patch
new file mode 100644
index 000000000000..96b881e9a67a
--- /dev/null
+++ b/www-plugins/gecko-mediaplayer/files/gecko-mediaplayer-0.9.8_p347-xulrunner-detection.patch
@@ -0,0 +1,46 @@
+--- gecko-mediaplayer-r347/configure.in-orig 2010-01-22 08:08:06.672212390 -0600
++++ gecko-mediaplayer-r347/configure.in 2010-01-22 08:09:11.427185920 -0600
+@@ -40,6 +40,21 @@
+ ],
+ [])
+
++
++if test "$GECKO_CFLAGS" = ""; then
++PKG_CHECK_MODULES(GECKO, [libxul < 1.9.2],[ AC_MSG_NOTICE([libxul < 1.9.2 found])
++ ],[AC_MSG_WARN([libxul < 1.9.2 not found, trying another])])
++fi
++if test "$GECKO_CFLAGS" = ""; then
++PKG_CHECK_MODULES(GECKO, [libxul >= 1.9.2],[ AC_DEFINE([HAVE_NEW_XULRUNNER],[1],[Define to 1 if using libxul 1.9.2 or higher]) AC_MSG_NOTICE([libxul >= 1.9.2 found])
++ ],[AC_MSG_NOTICE([libxul >= 1.9.2 not found, trying another])])
++fi
++
++if test "$GECKO_CFLAGS" = ""; then
++PKG_CHECK_MODULES(GECKO, [libxul-unstable],[
++ ],[AC_MSG_WARN([libxul-unstable not found, trying another])])
++fi
++
+ if test "$GECKO_CFLAGS" = ""; then
+ PKG_CHECK_MODULES(GECKO, [mozilla-plugin mozilla-xpcom],[
+ ],[AC_MSG_WARN([mozilla-plugin not found, trying another])])
+@@ -61,21 +76,6 @@
+ fi
+
+ if test "$GECKO_CFLAGS" = ""; then
+-PKG_CHECK_MODULES(GECKO, [libxul < 1.9.2],[ AC_MSG_NOTICE([libxul < 1.9.2 found])
+- ],[AC_MSG_WARN([libxul < 1.9.2 not found, trying another])])
+-fi
+-if test "$GECKO_CFLAGS" = ""; then
+-PKG_CHECK_MODULES(GECKO, [libxul >= 1.9.2],[ AC_DEFINE([HAVE_NEW_XULRUNNER],[1],[Define to 1 if using libxul 1.9.2 or higher]) AC_MSG_NOTICE([libxul >= 1.9.2 found])
+- ],[AC_MSG_NOTICE([libxul >= 1.9.2 not found, trying another])])
+-fi
+-
+-if test "$GECKO_CFLAGS" = ""; then
+-PKG_CHECK_MODULES(GECKO, [libxul-unstable],[
+- ],[AC_MSG_WARN([libxul-unstable not found, trying another])])
+-fi
+-
+-
+-if test "$GECKO_CFLAGS" = ""; then
+ PKG_CHECK_MODULES(GECKO, [iceape-plugin iceape-xpcom],[
+ ],[AC_MSG_WARN([iceape-plugin not found, trying another])])
+ fi \ No newline at end of file
diff --git a/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8_p347.ebuild b/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8_p347.ebuild
index 2033a04ee1d2..9f0c6bc265f8 100644
--- a/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8_p347.ebuild
+++ b/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8_p347.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8_p347.ebuild,v 1.2 2010/01/22 14:01:39 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8_p347.ebuild,v 1.3 2010/01/22 14:25:11 yngwin Exp $
EAPI=2
GCONF_DEBUG=no
-inherit eutils flag-o-matic gnome2 multilib
+inherit autotools eutils flag-o-matic gnome2 multilib
MY_P=${PN}-r${PV##*p}
@@ -37,6 +37,12 @@ pkg_setup() {
DOCS="ChangeLog DOCS/tech/javascript.txt"
}
+src_prepare() {
+ gnome2_src_prepare
+ epatch "${FILESDIR}"/${P}-xulrunner-detection.patch
+ eautoreconf
+}
+
src_configure() {
gnome2_src_configure
}