summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2007-12-03 08:13:25 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2007-12-03 08:13:25 +0000
commit863ba996b850b401b85fb670390c3ed05f2ab97f (patch)
treebff6c813ce23d7c5103fed4907c33d0989660ef9 /www-misc
parentstable x86, bug 201037 (diff)
downloadgentoo-2-863ba996b850b401b85fb670390c3ed05f2ab97f.tar.gz
gentoo-2-863ba996b850b401b85fb670390c3ed05f2ab97f.tar.bz2
gentoo-2-863ba996b850b401b85fb670390c3ed05f2ab97f.zip
-m htdig-3.2.0_beta6-r3 fixes sec bug #200285.
(Portage version: 2.1.3.14)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/htdig/ChangeLog8
-rw-r--r--www-misc/htdig/files/digest-htdig-3.2.0_beta6-r33
-rw-r--r--www-misc/htdig/files/htdig-3.2.0_beta6-quoting.patch26
-rw-r--r--www-misc/htdig/htdig-3.2.0_beta6-r3.ebuild62
4 files changed, 98 insertions, 1 deletions
diff --git a/www-misc/htdig/ChangeLog b/www-misc/htdig/ChangeLog
index f69a8c57e0fc..2336e7d72043 100644
--- a/www-misc/htdig/ChangeLog
+++ b/www-misc/htdig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-misc/htdig
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/ChangeLog,v 1.34 2007/06/25 14:21:01 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/ChangeLog,v 1.35 2007/12/03 08:13:25 wrobel Exp $
+
+*htdig-3.2.0_beta6-r3 (03 Dec 2007)
+
+ 03 Dec 2007; <wrobel@gentoo.org> +files/htdig-3.2.0_beta6-quoting.patch,
+ +htdig-3.2.0_beta6-r3.ebuild:
+ -m htdig-3.2.0_beta6-r3 fixes sec bug #200285.
25 Jun 2007; Raúl Porcel <armin76@gentoo.org>
htdig-3.2.0_beta6-r2.ebuild:
diff --git a/www-misc/htdig/files/digest-htdig-3.2.0_beta6-r3 b/www-misc/htdig/files/digest-htdig-3.2.0_beta6-r3
new file mode 100644
index 000000000000..71d425d06977
--- /dev/null
+++ b/www-misc/htdig/files/digest-htdig-3.2.0_beta6-r3
@@ -0,0 +1,3 @@
+MD5 8a6952f5b97e305dbb7489045bad220f htdig-3.2.0b6.tar.gz 3104936
+RMD160 621e85920f3452bc1a28a61cf7f8b3e08808bc55 htdig-3.2.0b6.tar.gz 3104936
+SHA256 6da9e0ee8627d5302f5685a1b3e5de5f1e6e8df4c0a92c0ca00796bca9e546c8 htdig-3.2.0b6.tar.gz 3104936
diff --git a/www-misc/htdig/files/htdig-3.2.0_beta6-quoting.patch b/www-misc/htdig/files/htdig-3.2.0_beta6-quoting.patch
new file mode 100644
index 000000000000..57b0e3b78731
--- /dev/null
+++ b/www-misc/htdig/files/htdig-3.2.0_beta6-quoting.patch
@@ -0,0 +1,26 @@
+Index: htdig-3.2.0b6/htsearch/Display.cc
+===================================================================
+--- htdig-3.2.0b6.orig/htsearch/Display.cc
++++ htdig-3.2.0b6/htsearch/Display.cc
+@@ -137,7 +137,7 @@ Display::display(int pageNumber)
+ // Must temporarily stash the message in a String, since
+ // displaySyntaxError will overwrite the static temp used in form.
+
+- String s(form("No such sort method: `%s'", (const char*)config->Find("sort")));
++ String s("invalid sort method");
+
+ displaySyntaxError(s);
+ return;
+Index: htdig-3.2.0b6/libhtdig/ResultFetch.cc
+===================================================================
+--- htdig-3.2.0b6.orig/libhtdig/ResultFetch.cc
++++ htdig-3.2.0b6/libhtdig/ResultFetch.cc
+@@ -142,7 +142,7 @@ ResultFetch::fetch()
+ // Must temporarily stash the message in a String, since
+ // displaySyntaxError will overwrite the static temp used in form.
+
+- String s(form("No such sort method: `%s'", (const char *) config->Find("sort")));
++ String s("invalid sort method");
+
+ displaySyntaxError(s);
+ //return;
diff --git a/www-misc/htdig/htdig-3.2.0_beta6-r3.ebuild b/www-misc/htdig/htdig-3.2.0_beta6-r3.ebuild
new file mode 100644
index 000000000000..00f55f79d554
--- /dev/null
+++ b/www-misc/htdig/htdig-3.2.0_beta6-r3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/htdig-3.2.0_beta6-r3.ebuild,v 1.1 2007/12/03 08:13:25 wrobel Exp $
+
+inherit eutils autotools
+
+MY_PV=${PV/_beta/b}
+S=${WORKDIR}/${PN}-${MY_PV}
+
+DESCRIPTION="HTTP/HTML indexing and searching system"
+SRC_URI="http://www.htdig.org/files/${PN}-${MY_PV}.tar.gz"
+HOMEPAGE="http://www.htdig.org"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+
+DEPEND=">=sys-libs/zlib-1.1.3
+ app-arch/unzip
+ ssl? ( dev-libs/openssl )"
+
+IUSE="ssl"
+SLOT="0"
+
+src_unpack() {
+ unpack "${A}"
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}"-gcc4.patch
+ epatch "${FILESDIR}/${P}"-as-needed.patch
+ epatch "${FILESDIR}/${P}"-quoting.patch
+ eautoreconf
+}
+
+src_compile() {
+ local conf="
+ --with-config-dir=/etc/${PN} \
+ --with-default-config-file=/etc/${PN}/${PN}.conf \
+ --with-database-dir=/var/lib/${PN}/db \
+ --with-cgi-bin-dir=/var/www/localhost/cgi-bin \
+ --with-search-dir=/var/www/localhost/htdocs/${PN} \
+ --with-image-dir=/var/www/localhost/htdocs/${PN}
+ "
+ use ssl && conf="${conf} --with-ssl"
+
+ econf ${conf} || die "configure failed"
+
+# --with-image-url-prefix=file:///var/www/localhost/htdocs/${PN} \
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog COPYING README
+ dohtml -r htdoc
+
+ dosed /etc/${PN}/${PN}.conf
+ dosed /usr/bin/rundig
+
+ # symlink htsearch so it can be easily found. see bug #62087
+ dosym /var/www/localhost/cgi-bin/htsearch /usr/bin/htsearch
+}