summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-01-11 12:46:42 +0000
committerPacho Ramos <pacho@gentoo.org>2010-01-11 12:46:42 +0000
commit272fe1e5f5535d321f8a09d6004b3853c95209e0 (patch)
tree0dba464288834a45c171b8ede16918dc3ab23493 /www-client
parentRevbump, migrating to ruby-fakegem. Tests restricted due to an unpackaged git... (diff)
downloadgentoo-2-272fe1e5f5535d321f8a09d6004b3853c95209e0.tar.gz
gentoo-2-272fe1e5f5535d321f8a09d6004b3853c95209e0.tar.bz2
gentoo-2-272fe1e5f5535d321f8a09d6004b3853c95209e0.zip
Fix download dir reset
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/ChangeLog10
-rw-r--r--www-client/epiphany/epiphany-2.26.3-r3.ebuild93
-rw-r--r--www-client/epiphany/files/epiphany-2.26.3-revert-downloadir.patch39
3 files changed, 140 insertions, 2 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index d095bd3b5951..16f1611b37c0 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/epiphany
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.224 2009/12/21 23:11:11 eva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.225 2010/01/11 12:46:41 pacho Exp $
+
+*epiphany-2.26.3-r3 (11 Jan 2010)
+
+ 11 Jan 2010; Pacho Ramos <pacho@gentoo.org> +epiphany-2.26.3-r3.ebuild,
+ +files/epiphany-2.26.3-revert-downloadir.patch:
+ Fix download dir reset by preferences dialog, bug 292867
*epiphany-2.28.2 (21 Dec 2009)
diff --git a/www-client/epiphany/epiphany-2.26.3-r3.ebuild b/www-client/epiphany/epiphany-2.26.3-r3.ebuild
new file mode 100644
index 000000000000..3f79a716bc11
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.26.3-r3.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.26.3-r3.ebuild,v 1.1 2010/01/11 12:46:41 pacho Exp $
+
+EAPI="2"
+
+inherit gnome2 eutils multilib autotools
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="avahi doc networkmanager python spell"
+
+RDEPEND=">=dev-libs/glib-2.18.0
+ >=x11-libs/gtk+-2.16.0
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=x11-libs/libnotify-0.4
+ >=media-libs/libcanberra-0.3[gtk]
+ >=dev-libs/dbus-glib-0.71
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ avahi? ( >=net-dns/avahi-0.6.22 )
+ networkmanager? ( net-misc/networkmanager )
+ =net-libs/xulrunner-1.9*
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6 )
+ spell? ( app-text/enchant )
+ x11-themes/gnome-icon-theme"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ >=app-text/gnome-doc-utils-0.3.2
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --with-gecko=libxul-embedding
+ --with-distributor-name=Gentoo
+ --enable-canberra
+ $(use_enable avahi zeroconf)
+ $(use_enable networkmanager network-manager)
+ $(use_enable spell spell-checker)
+ $(use_enable python)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix libcanberra automagic support, bug #266232
+ epatch "${FILESDIR}/${PN}-2.26.1-automagic-libcanberra.patch"
+
+ # Fix sandbox violations, bug #263585
+ epatch "${FILESDIR}/${PN}-2.26-fix-sandbox-violations.patch"
+
+ # Fix detection of system plugin, bug #279417
+ epatch "${FILESDIR}/${P}-system-plugin.patch"
+
+ # Fix missing favicons of most web-sites, bug #290024
+ epatch "${FILESDIR}/${P}-favicon-cache.patch"
+
+ # Fix download location reset, bug #292867
+ epatch "${FILESDIR}/${P}-revert-downloadir.patch"
+
+ # Make it libtool-1 compatible
+ rm -v m4/lt* m4/libtool.m4 || die "removing libtool macros failed"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+
+ # All .la files are for plugins or extensions that are dlopened.
+ # Upstream should pass *_la_LIBTOOLFLAGS = --tag=disable-static to drop them instead
+ # but gecko is a dead branch for them, so do it ourselves:
+ find "${D}" -name '*.la' -delete
+}
diff --git a/www-client/epiphany/files/epiphany-2.26.3-revert-downloadir.patch b/www-client/epiphany/files/epiphany-2.26.3-revert-downloadir.patch
new file mode 100644
index 000000000000..b90f667afa04
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-2.26.3-revert-downloadir.patch
@@ -0,0 +1,39 @@
+From: Pacho Ramos <pacho@gentoo.org>
+Date: Wed, 06 Jan 2010 14:17:24 +0000
+Subject: Revert upstream commit 7dbe33b5bfd99ff4ef116f8ccf4777edd8ade788
+(Chdir to / in the factory, so we don't hog any mountpoints.)
+Discussed in:
+https://bugzilla.gnome.org/show_bug.cgi?id=583616
+http://bugs.gentoo.org/show_bug.cgi?id=292867
+---
+--- lib/ephy-file-chooser.c~ 2009-05-28 21:26:21.000000000 +0200
++++ lib/ephy-file-chooser.c 2010-01-06 15:13:23.000000000 +0100
+@@ -375,7 +375,6 @@
+ * run.
+ */
+
+- gtk_file_chooser_set_current_folder (GTK_FILE_CHOOSER (dialog), g_get_home_dir ());
+
+ if (persist_key != NULL)
+ {
+--- lib/ephy-file-helpers.c~ 2009-05-28 21:26:21.000000000 +0200
++++ lib/ephy-file-helpers.c 2010-01-06 15:14:09.000000000 +0100
+@@ -33,7 +33,6 @@
+ #include "ephy-string.h"
+
+ #include <glib.h>
+-#include <glib/gstdio.h>
+ #include <glib/gi18n.h>
+ #include <gio/gio.h>
+ #include <gio/gdesktopappinfo.h>
+@@ -264,10 +263,6 @@
+ {
+ const char *uuid;
+
+- /* Make sure the server process doesn't hog any mountpoints! */
+- if (chdir ("/") < 0)
+- g_warning ("Failed to chdir to /: %s", g_strerror (errno));
+-
+ /* See if we've been calling ourself, and abort if we have */
+ uuid = g_getenv (EPHY_UUID_ENVVAR);
+ if (uuid && strcmp (uuid, EPHY_UUID) == 0)