summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-03-15 21:42:52 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-03-15 21:42:52 +0000
commit39f51ba0494ce27262c2c30ebed0dd9220c3bea2 (patch)
tree36b0f34c27bf2d89b0daeea7c5a2370f0efe8748 /www-client/skipstone/skipstone-0.9.2.ebuild
parentChangeLog header fix (diff)
downloadgentoo-2-39f51ba0494ce27262c2c30ebed0dd9220c3bea2.tar.gz
gentoo-2-39f51ba0494ce27262c2c30ebed0dd9220c3bea2.tar.bz2
gentoo-2-39f51ba0494ce27262c2c30ebed0dd9220c3bea2.zip
Moved from net-www/skipstone to www-client/skipstone.
Diffstat (limited to 'www-client/skipstone/skipstone-0.9.2.ebuild')
-rw-r--r--www-client/skipstone/skipstone-0.9.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/www-client/skipstone/skipstone-0.9.2.ebuild b/www-client/skipstone/skipstone-0.9.2.ebuild
new file mode 100644
index 000000000000..e1c23a7d2d8f
--- /dev/null
+++ b/www-client/skipstone/skipstone-0.9.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/skipstone/skipstone-0.9.2.ebuild,v 1.1 2005/03/15 21:42:52 seemant Exp $
+
+inherit eutils
+
+IUSE="nls"
+
+DESCRIPTION="GTK+ based web browser based on the Mozilla engine"
+SRC_URI="http://www.muhri.net/skipstone/${P}.tar.gz"
+HOMEPAGE="http://www.muhri.net/skipstone/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND=">=net-www/mozilla-1.6
+ >=x11-libs/gtk+-2.0"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ if use nls; then
+ epatch ${FILESDIR}/${PN}-gentoo.patch
+ fi
+}
+
+src_compile() {
+ local myconf
+ use nls && myconf="${myconf} --enable-nls"
+ has_version '>=net-www/mozilla-1.7' && \
+ myconf="${myconf} --enable-cvs-mozilla"
+
+ econf ${myconf}
+ make PREFIX="/usr/lib/mozilla" || die
+}
+
+src_install() {
+ einstall \
+ PREFIX=${D}/usr \
+ LOCALEDIR=${D}/usr/share/locale
+ dodoc AUTHORS COPYING README README.copying
+}