summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-07-21 23:49:54 +0000
committerAron Griffis <agriffis@gentoo.org>2005-07-21 23:49:54 +0000
commitc0c6521868363923c0d4657a70ab589c70d43458 (patch)
tree2871fca122ad1d3f15ccfc3c707c7047057dedf5 /www-client/mozilla-firefox
parentInitial commit for bug 63819. (diff)
downloadgentoo-2-c0c6521868363923c0d4657a70ab589c70d43458.tar.gz
gentoo-2-c0c6521868363923c0d4657a70ab589c70d43458.tar.bz2
gentoo-2-c0c6521868363923c0d4657a70ab589c70d43458.zip
Sync minor changes from upcoming mozilla-1.7.10 ebuild. Install
documentation (LEGAL and LICENSE). Update the component registry in pkg_postrm() as well. (Portage version: 2.0.51.22-r2)
Diffstat (limited to 'www-client/mozilla-firefox')
-rw-r--r--www-client/mozilla-firefox/ChangeLog8
-rw-r--r--www-client/mozilla-firefox/mozilla-firefox-1.0.6-r1.ebuild24
2 files changed, 22 insertions, 10 deletions
diff --git a/www-client/mozilla-firefox/ChangeLog b/www-client/mozilla-firefox/ChangeLog
index 658c53154e7d..da844b1c84e2 100644
--- a/www-client/mozilla-firefox/ChangeLog
+++ b/www-client/mozilla-firefox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/mozilla-firefox
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/ChangeLog,v 1.50 2005/07/21 23:12:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/ChangeLog,v 1.51 2005/07/21 23:49:54 agriffis Exp $
+
+ 21 Jul 2005; Aron Griffis <agriffis@gentoo.org>
+ mozilla-firefox-1.0.6-r1.ebuild:
+ Sync minor changes from upcoming mozilla-1.7.10 ebuild. Install
+ documentation (LEGAL and LICENSE). Update the component registry in
+ pkg_postrm() as well.
21 Jul 2005; Aron Griffis <agriffis@gentoo.org>
mozilla-firefox-1.0.6-r1.ebuild:
diff --git a/www-client/mozilla-firefox/mozilla-firefox-1.0.6-r1.ebuild b/www-client/mozilla-firefox/mozilla-firefox-1.0.6-r1.ebuild
index 4c6dd7f18b19..ec1a56ff253c 100644
--- a/www-client/mozilla-firefox/mozilla-firefox-1.0.6-r1.ebuild
+++ b/www-client/mozilla-firefox/mozilla-firefox-1.0.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-1.0.6-r1.ebuild,v 1.2 2005/07/21 23:12:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-1.0.6-r1.ebuild,v 1.3 2005/07/21 23:49:54 agriffis Exp $
unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
inherit flag-o-matic toolchain-funcs eutils mozconfig mozilla-launcher makeedit multilib
@@ -191,8 +191,6 @@ src_install() {
#
####################################
- # Copy the include and idl files so that applications can build against
- # firefox just like they have traditionally built against mozilla
einfo "Installing includes and idl files..."
dodir ${MOZILLA_FIVE_HOME}/include/idl /usr/include
cd ${S}/dist
@@ -209,30 +207,32 @@ src_install() {
dosym ${MOZILLA_FIVE_HOME##*/} ${MOZILLA_FIVE_HOME%/*}/MozillaFirefox
# Fix firefox-config and install it
- cd ${S}/build/unix
sed -i -e "s|/usr/lib/firefox-${PV}|${MOZILLA_FIVE_HOME}|g
- s|/usr/include/firefox-${PV}|${MOZILLA_FIVE_HOME}/include|g" firefox-config
+ s|/usr/include/firefox-${PV}|${MOZILLA_FIVE_HOME}/include|g" \
+ ${S}/build/unix/firefox-config
exeinto ${MOZILLA_FIVE_HOME}
- doexe firefox-config
+ doexe ${S}/build/unix/firefox-config
# Fix pkgconfig files and install them
insinto /usr/$(get_libdir)/pkgconfig
- for x in *.pc; do
+ for x in ${S}/build/unix/*.pc; do
sed -i -e "s|^libdir=.*|libdir=${MOZILLA_FIVE_HOME}|
s|^includedir=.*|includedir=${MOZILLA_FIVE_HOME}/include|" ${x}
doins ${x}
done
- cd ${S}
# Install env.d snippet, which isn't necessary for running firefox, but
# might be necessary for programs linked against firefox
insinto /etc/env.d
doins ${FILESDIR}/10MozillaFirefox
dosed "s|/usr/lib|/usr/$(get_libdir)|" /etc/env.d/10MozillaFirefox
+
+ # Install docs
+ dodoc LEGAL LICENSE
}
pkg_postinst() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-firefox
# Update the component registry
MOZILLA_LIBDIR=${ROOT}${MOZILLA_FIVE_HOME} MOZILLA_LAUNCHER=firefox \
@@ -245,5 +245,11 @@ pkg_postinst() {
}
pkg_postrm() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-firefox
+
+ # Update the component registry
+ MOZILLA_LIBDIR=${ROOT}${MOZILLA_FIVE_HOME} MOZILLA_LAUNCHER=firefox \
+ /usr/libexec/mozilla-launcher -register
+
update_mozilla_launcher_symlinks
}