summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-07-01 14:32:23 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-07-01 14:32:23 +0000
commit49488a40f0742b9d6a0a3ca62632f77aab2bc956 (patch)
treef1cc1cbf5bcd703b0f5a29cfea6676d891c7491f /www-client/jd
parentia64/s390/sparc stable wrt #274903 (diff)
downloadgentoo-2-49488a40f0742b9d6a0a3ca62632f77aab2bc956.tar.gz
gentoo-2-49488a40f0742b9d6a0a3ca62632f77aab2bc956.tar.bz2
gentoo-2-49488a40f0742b9d6a0a3ca62632f77aab2bc956.zip
Version bumped.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'www-client/jd')
-rw-r--r--www-client/jd/ChangeLog8
-rw-r--r--www-client/jd/jd-2.4.1_beta090628.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/www-client/jd/ChangeLog b/www-client/jd/ChangeLog
index 631aed4992c9..d4f9464cebe9 100644
--- a/www-client/jd/ChangeLog
+++ b/www-client/jd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/jd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/jd/ChangeLog,v 1.13 2009/05/27 16:37:40 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/jd/ChangeLog,v 1.14 2009/07/01 14:32:23 matsuu Exp $
+
+*jd-2.4.1_beta090628 (01 Jul 2009)
+
+ 01 Jul 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +jd-2.4.1_beta090628.ebuild:
+ Version bumped.
*jd-2.4.0_p090522 (27 May 2009)
diff --git a/www-client/jd/jd-2.4.1_beta090628.ebuild b/www-client/jd/jd-2.4.1_beta090628.ebuild
new file mode 100644
index 000000000000..e75d54b6fc70
--- /dev/null
+++ b/www-client/jd/jd-2.4.1_beta090628.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/jd/jd-2.4.1_beta090628.ebuild,v 1.1 2009/07/01 14:32:23 matsuu Exp $
+
+inherit eutils autotools
+
+MY_P="${P/_p/-}"
+MY_P="${MY_P/_/-}"
+
+DESCRIPTION="gtk2 based 2ch browser written in C++"
+HOMEPAGE="http://jd4linux.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/jd4linux/40837/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa gnome gnutls migemo"
+
+RDEPEND=">=dev-cpp/gtkmm-2.8
+ >=dev-libs/glib-2
+ x11-misc/xdg-utils
+ alsa? ( >=media-libs/alsa-lib-1 )
+ gnome? ( >=gnome-base/libgnomeui-2 )
+ !gnome? (
+ x11-libs/libSM
+ x11-libs/libICE
+ )
+ gnutls? ( >=net-libs/gnutls-1.2 )
+ !gnutls? ( >=dev-libs/openssl-0.9 )
+ migemo? ( app-text/cmigemo )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ local myconf="--with-xdgopen"
+
+ # use gnomeui sm instead of Xorg SM/ICE
+ if use gnome ; then
+ myconf="${myconf} --with-sessionlib=gnomeui"
+ else
+ myconf="${myconf} --with-sessionlib=xsmp"
+ fi
+
+ econf \
+ $(use_with alsa) \
+ $(use_with !gnutls openssl) \
+ $(use_with migemo) \
+ $(use_with migemo migemodict /usr/share/migemo/migemo-dict) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ dodoc AUTHORS ChangeLog NEWS README
+}