summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-07-25 19:06:36 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-07-25 19:06:36 +0000
commit7bfb49d586515158bd268170004db0c5cf3477d7 (patch)
tree410f67ce4a20fee958aa3a43c5c4121d34436173 /www-client/firefox/files
parentAdd ewarn about wrong permissions when upgrading from bind 9.4.x. Comment vie... (diff)
downloadgentoo-2-7bfb49d586515158bd268170004db0c5cf3477d7.tar.gz
gentoo-2-7bfb49d586515158bd268170004db0c5cf3477d7.tar.bz2
gentoo-2-7bfb49d586515158bd268170004db0c5cf3477d7.zip
pkgmove from mozilla-firefox -> firefox
(Portage version: 2.1.8.3/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'www-client/firefox/files')
-rw-r--r--www-client/firefox/files/000_flex-configure-LANG.patch41
-rw-r--r--www-client/firefox/files/1000_fix_alignment.patch33
-rw-r--r--www-client/firefox/files/137-bz460917_reload_new_plugins-gentoo-update-3.6.4.patch60
-rw-r--r--www-client/firefox/files/801-enable-x86_64-tracemonkey.patch25
-rw-r--r--www-client/firefox/files/firefox-3.0-solaris64.patch14
-rw-r--r--www-client/firefox/files/firefox-default-prefs.js2
-rw-r--r--www-client/firefox/files/firefox.1125
-rw-r--r--www-client/firefox/files/gentoo-default-prefs.js12
-rw-r--r--www-client/firefox/files/icon/firefox-1.5-unbranded.desktop9
-rw-r--r--www-client/firefox/files/icon/firefox-1.5.desktop9
-rw-r--r--www-client/firefox/files/mozilla-filepicker.patch17
-rw-r--r--www-client/firefox/files/xulrunner-1.9.2-arm-fixes.patch35
-rw-r--r--www-client/firefox/files/xulrunner-1.9.2-noalsa-fixup.patch26
13 files changed, 408 insertions, 0 deletions
diff --git a/www-client/firefox/files/000_flex-configure-LANG.patch b/www-client/firefox/files/000_flex-configure-LANG.patch
new file mode 100644
index 000000000000..6d32a8537508
--- /dev/null
+++ b/www-client/firefox/files/000_flex-configure-LANG.patch
@@ -0,0 +1,41 @@
+The LANG vars aren't reset early enough so when sed tries to use [a-zA-Z] in
+option parsing, it may break.
+
+http://bugs.gentoo.org/103483
+
+--- configure~ 2009-07-31 20:07:25.087663220 -0500
++++ configure 2009-07-31 20:07:37.987684452 -0500
+@@ -468,6 +468,16 @@
+ infodir='${prefix}/info'
+ mandir='${prefix}/man'
+
++# NLS nuisances.
++# Only set these to C if already set. These must not be set unconditionally
++# because not all systems understand e.g. LANG=C (notably SCO).
++# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
++# Non-C LC_CTYPE values break the ctype check.
++if test "${LANG+set}" = set; then LANG=C; export LANG; fi
++if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
++if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
++if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
++
+ # Initialize some other variables.
+ subdirs=
+ MFLAGS= MAKEFLAGS=
+@@ -856,16 +866,6 @@
+ esac
+ done
+
+-# NLS nuisances.
+-# Only set these to C if already set. These must not be set unconditionally
+-# because not all systems understand e.g. LANG=C (notably SCO).
+-# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
+-# Non-C LC_CTYPE values break the ctype check.
+-if test "${LANG+set}" = set; then LANG=C; export LANG; fi
+-if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
+-if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
+-if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
+-
+ # confdefs.h avoids OS command line length limits that DEFS can exceed.
+ rm -rf conftest* confdefs.h
+ # AIX cpp loses on an empty file, so make sure it contains at least a newline.
diff --git a/www-client/firefox/files/1000_fix_alignment.patch b/www-client/firefox/files/1000_fix_alignment.patch
new file mode 100644
index 000000000000..2ef47c3d4787
--- /dev/null
+++ b/www-client/firefox/files/1000_fix_alignment.patch
@@ -0,0 +1,33 @@
+From: David Mandelin <dmandelin@mozilla.com>
+
+diff --git a/memory/jemalloc/jemalloc.c b/memory/jemalloc/jemalloc.c
+--- a/memory/jemalloc/jemalloc.c
++++ b/memory/jemalloc/jemalloc.c
+@@ -5792,24 +5792,24 @@ __attribute__((noinline))
+ #else
+ inline
+ #endif
+ void *
+ memalign(size_t alignment, size_t size)
+ {
+ void *ret;
+
+- assert(((alignment - 1) & alignment) == 0 && alignment >=
+- sizeof(void *));
++ assert(((alignment - 1) & alignment) == 0);
+
+ if (malloc_init()) {
+ ret = NULL;
+ goto RETURN;
+ }
+
++ alignment = alignment < sizeof(void*) ? sizeof(void*) : alignment;
+ ret = ipalloc(alignment, size);
+
+ RETURN:
+ #ifdef MALLOC_XMALLOC
+ if (opt_xmalloc && ret == NULL) {
+ _malloc_message(_getprogname(),
+ ": (malloc) Error in memalign(): out of memory\n", "", "");
+ abort();
+
diff --git a/www-client/firefox/files/137-bz460917_reload_new_plugins-gentoo-update-3.6.4.patch b/www-client/firefox/files/137-bz460917_reload_new_plugins-gentoo-update-3.6.4.patch
new file mode 100644
index 000000000000..5d0c93c3dea0
--- /dev/null
+++ b/www-client/firefox/files/137-bz460917_reload_new_plugins-gentoo-update-3.6.4.patch
@@ -0,0 +1,60 @@
+This patch has been ported to 3.6.4, may not be entirely correct.
+
+Original patch was from bmo 460917, att 350845
+
+---
+--- browser/base/content/browser.js
++++ browser/base/content/browser.js
+@@ -6009,9 +6009,18 @@
+ var pluginInfo = getPluginInfo(aEvent.target);
+ missingPluginsArray[pluginInfo.mimetype] = pluginInfo;
+
++
++ gBrowser.selectedBrowser.addEventListener("NewPluginInstalled",
++ gMissingPluginInstaller.refreshBrowser,
++ false);
++
+ openDialog("chrome://mozapps/content/plugins/pluginInstallerWizard.xul",
+ "PFSWindow", "chrome,centerscreen,resizable=yes",
+ {plugins: missingPluginsArray, browser: gBrowser.selectedBrowser});
++
++ gBrowser.selectedBrowser.removeEventListener("NewPluginInstalled",
++ gMissingPluginInstaller.refreshBrowser,
++ false);
+ },
+
+ // Callback for user clicking on a disabled plugin
+@@ -6107,11 +6116,19 @@
+ function showPluginsMissing() {
+ // get the urls of missing plugins
+ var missingPluginsArray = gBrowser.selectedBrowser.missingPlugins;
++
++ gBrowser.selectedBrowser.addEventListener("NewPluginInstalled",
++ gMissingPluginInstaller.refreshBrowser,
++ false);
++
+ if (missingPluginsArray) {
+ window.openDialog("chrome://mozapps/content/plugins/pluginInstallerWizard.xul",
+ "PFSWindow", "chrome,centerscreen,resizable=yes",
+ {plugins: missingPluginsArray, browser: gBrowser.selectedBrowser});
+ }
++ gBrowser.selectedBrowser.removeEventListener("NewPluginInstalled",
++ gMissingPluginInstaller.refreshBrowser,
++ false);
+ }
+
+ if (aEvent.type == "PluginBlocklisted") {
+@@ -6442,6 +6459,13 @@
+ notificationBox.removeNotification(notification);
+ }
+ // reload the browser to make the new plugin show.
++
++ // reload plugins
++ var pm = Components.classes["@mozilla.org/plugin/manager;1"]
++ .getService(Components.interfaces.nsIPluginManager);
++ pm.reloadPlugins(false);
++
++ // ... and reload the browser to activate new plugins available
+ browser.reload();
+ }
+ };
diff --git a/www-client/firefox/files/801-enable-x86_64-tracemonkey.patch b/www-client/firefox/files/801-enable-x86_64-tracemonkey.patch
new file mode 100644
index 000000000000..b72ad76b450e
--- /dev/null
+++ b/www-client/firefox/files/801-enable-x86_64-tracemonkey.patch
@@ -0,0 +1,25 @@
+--- js/src/configure.in.old 2009-11-08 19:50:54.299642792 -0500
++++ js/src/configure.in 2009-11-08 19:57:49.235621814 -0500
+@@ -2465,6 +2465,10 @@
+ ENABLE_JIT=1
+ NANOJIT_ARCH=i386
+ ;;
++x86_64*-*)
++ ENABLE_JIT=1
++ NANOJIT_ARCH=X64
++ ;;
+ arm*-*)
+ ENABLE_JIT=1
+ NANOJIT_ARCH=ARM
+@@ -2488,7 +2492,10 @@
+ i?86-*)
+ AC_DEFINE(AVMPLUS_IA32)
+ ;;
+-
++x86_64*-*)
++ AC_DEFINE(AVMPLUS_AMD64)
++ AC_DEFINE(AVMPLUS_64BIT)
++ ;;
+ arm*-*)
+ AC_DEFINE(AVMPLUS_ARM)
+ ;;
diff --git a/www-client/firefox/files/firefox-3.0-solaris64.patch b/www-client/firefox/files/firefox-3.0-solaris64.patch
new file mode 100644
index 000000000000..988b280f67ca
--- /dev/null
+++ b/www-client/firefox/files/firefox-3.0-solaris64.patch
@@ -0,0 +1,14 @@
+Don't use -G, it results in a relocation error against _DYNAMIC on
+amd64, use -shared instead per the manpage, and as it works as well.
+
+--- configure.in
++++ configure.in
+@@ -2481,7 +2481,7 @@
+ AC_LANG_RESTORE
+ else
+ ASFLAGS="$ASFLAGS -fPIC"
+- DSO_LDOPTS='-G'
++ DSO_LDOPTS='-shared'
+ _WARNINGS_CFLAGS=''
+ _WARNINGS_CXXFLAGS=''
+ if test "$OS_RELEASE" = "5.3"; then
diff --git a/www-client/firefox/files/firefox-default-prefs.js b/www-client/firefox/files/firefox-default-prefs.js
new file mode 100644
index 000000000000..f7c031ef1231
--- /dev/null
+++ b/www-client/firefox/files/firefox-default-prefs.js
@@ -0,0 +1,2 @@
+pref("browser.tabs.tabMinWidth", 15);
+pref("browser.backspace_action", 0);
diff --git a/www-client/firefox/files/firefox.1 b/www-client/firefox/files/firefox.1
new file mode 100644
index 000000000000..20863251004f
--- /dev/null
+++ b/www-client/firefox/files/firefox.1
@@ -0,0 +1,125 @@
+.TH FIREFOX 1 "August 07, 2001" firefox "Linux User's Manual"
+.SH NAME
+firefox \- a Web browser for X11 derived from the Mozilla browser
+
+.SH SYNOPSIS
+.B firefox
+[\fIOPTIONS\fR] [\fIURL\fR]
+
+.B firefox-bin
+[\fIOPTIONS\fR] [\fIURL\fR]
+
+.SH DESCRIPTION
+\fBMozilla Firefox\fR is an open-source web browser, designed for
+standards compliance, performance and portability.
+
+.SH USAGE
+\fBfirefox\fR is a simple shell script that will set up the
+environment for the actual executable, \fBfirefox-bin\fR.
+
+.SH OPTIONS
+A summary of the options supported by \fBfirefox\fR is included below.
+
+.SS "GTK options"
+\fB\-\-gdk-debug=\fR\fIFLAGS\fR
+Gdk debugging flags to set
+.TP
+\fB\-\-gdk-no-debug=\fR\fIFLAGS\fR
+Gdk debugging flags to unset
+.TP
+\fB\-\-gtk-debug=\fR\fIFLAGS\fR
+Gtk+ debugging flags to set
+.TP
+\fB\-\-gtk-no-debug=\fR\fIFLAGS\fR
+Gtk+ debugging flags to unset
+.TP
+\fB\-\-gtk-module=\fR\fIMODULE\fR
+Load an additional Gtk module
+
+.SS "X11 options"
+.TP
+.BI \-\-display= DISPLAY
+X display to use
+.TP
+.B \--sync
+Make X calls synchronous
+.TP
+.B \-\-no-xshm
+Don't use X shared memory extension
+.TP
+.BI \-\-xim-preedit= STYLE
+.TP
+.BI \-\-xim-status= STYLE
+.TP
+.B \-\-g-fatal-warnings
+Make all warnings fatal
+
+.SS "Firefox options"
+.TP
+\fB\-height\fR \fIvalue\fR
+Set height of startup window to \fIvalue\fR.
+.TP
+.B \-h, \-help
+Show summary of options.
+.TP
+.B \-installer
+Start with 4.x migration window.
+.TP
+\fB\-width\fR \fIvalue\fR
+Set width of startup window to \fIvalue\fR.
+.TP
+.B \-v, \-version
+Print \fB/usr/bin/firefox-bin\fR version.
+.TP
+\fB\-CreateProfile\fR \fIprofile\fR
+Create \fIprofile\fR.
+.TP
+\fB\-P\fR \fIprofile\fR
+Start with \fIprofile\fR.
+.TP
+.B \-ProfileWizard
+Start with profile wizard.
+.TP
+.B \-ProfileManager
+Start with profile manager.
+.TP
+.B \-SelectProfile
+Start with profile selection dialog.
+.TP
+\fB\-lang\fR \fIlang-region\fR
+Start with \fIlang-region\fR resources.
+.TP
+\fB\-remote\fR \fIcommand\fR
+Execute \fIcommand\fR in an already running Firefox process. For more info,
+see: \fIhttp://www.mozilla.org/unix/remote.html\fR
+.TP
+.B \-splash
+Enable splash screen.
+.TP
+.B \-jsconsole
+Start with Javascript Console
+.TP
+\fB\-chrome\fR \fIurl\fR
+Load the specified chrome.
+.TP
+
+.SH FILES
+\fI/usr/bin/firefox\fR - shell script wrapping
+\fBfirefox\fR
+.br
+\fI/usr/lib/mozilla/firefox-bin\fR - \fBfirefox\fR
+executable
+
+.SH VERSION
+1.0
+
+.SH BUGS
+To report a bug, please visit \fIhttp://bugzilla.mozilla.org/\fR
+
+.SH "SEE ALSO"
+.BR mozilla(1)
+
+.SH AUTHORS
+.TP
+.B The Mozilla Organization
+.I http://www.mozilla.org/about.html
diff --git a/www-client/firefox/files/gentoo-default-prefs.js b/www-client/firefox/files/gentoo-default-prefs.js
new file mode 100644
index 000000000000..5c4a653cb677
--- /dev/null
+++ b/www-client/firefox/files/gentoo-default-prefs.js
@@ -0,0 +1,12 @@
+pref("app.update.enabled", false);
+pref("app.update.autoInstallEnabled", false);
+pref("browser.display.use_system_colors", true);
+pref("browser.link.open_external", 3);
+pref("general.smoothScroll", true);
+pref("general.autoScroll", false);
+pref("browser.tabs.tabMinWidth", 15);
+pref("browser.backspace_action", 0);
+pref("browser.urlbar.hideGoButton", true);
+pref("accessibility.typeaheadfind", true);
+pref("browser.shell.checkDefaultBrowser", false);
+pref("browser.EULA.override", true);
diff --git a/www-client/firefox/files/icon/firefox-1.5-unbranded.desktop b/www-client/firefox/files/icon/firefox-1.5-unbranded.desktop
new file mode 100644
index 000000000000..dff2d63e32b4
--- /dev/null
+++ b/www-client/firefox/files/icon/firefox-1.5-unbranded.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Bon Echo
+Comment=Web Browser
+Exec=/usr/bin/firefox %U
+Icon=firefox-icon-unbranded
+Terminal=false
+Type=Application
+MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;
+Categories=Network;WebBrowser;
diff --git a/www-client/firefox/files/icon/firefox-1.5.desktop b/www-client/firefox/files/icon/firefox-1.5.desktop
new file mode 100644
index 000000000000..98d5fdf600f5
--- /dev/null
+++ b/www-client/firefox/files/icon/firefox-1.5.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Mozilla Firefox
+Comment=Web Browser
+Exec=/usr/bin/firefox %U
+Icon=firefox-icon
+Terminal=false
+Type=Application
+MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;
+Categories=Network;WebBrowser;
diff --git a/www-client/firefox/files/mozilla-filepicker.patch b/www-client/firefox/files/mozilla-filepicker.patch
new file mode 100644
index 000000000000..b20b23b8f37a
--- /dev/null
+++ b/www-client/firefox/files/mozilla-filepicker.patch
@@ -0,0 +1,17 @@
+diff -Naur a/xpfe/components/filepicker/src/nsFilePicker.js.in b/xpfe/components/filepicker/src/nsFilePicker.js.in
+--- a/xpfe/components/filepicker/src/nsFilePicker.js.in 2005-01-25 12:57:29.000000000 +0100
++++ b/xpfe/components/filepicker/src/nsFilePicker.js.in 2006-06-05 17:40:44.000000000 +0200
+@@ -272,11 +272,9 @@
+
+ compMgr.registerFactoryLocation(FILEPICKER_CID,
+ "FilePicker JS Component",
+-#ifndef MOZ_WIDGET_GTK2
++
+ FILEPICKER_CONTRACTID,
+-#else
+- "",
+-#endif
++
+ fileSpec,
+ location,
+ type);
diff --git a/www-client/firefox/files/xulrunner-1.9.2-arm-fixes.patch b/www-client/firefox/files/xulrunner-1.9.2-arm-fixes.patch
new file mode 100644
index 000000000000..a726209e6373
--- /dev/null
+++ b/www-client/firefox/files/xulrunner-1.9.2-arm-fixes.patch
@@ -0,0 +1,35 @@
+Fix arm OS detection
+
+https://bugs.gentoo.org/327783
+https://bugzilla.mozilla.org/show_bug.cgi?id=577319
+---
+--- configure.in
++++ configure.in
+@@ -1424,9 +1424,11 @@
+ CPU_ARCH="$OS_TEST"
+ ;;
+
+-arm)
++arm*)
+ if test "$OS_TARGET" = "WINCE"; then
+ CPU_ARCH="$OS_TEST"
++ else
++ CPU_ARCH="arm"
+ fi
+ ;;
+ esac
+--- js/src/configure.in
++++ js/src/configure.in
+@@ -1162,9 +1162,11 @@
+ CPU_ARCH="$OS_TEST"
+ ;;
+
+-arm)
++arm*)
+ if test "$OS_TARGET" = "WINCE"; then
+ CPU_ARCH="$OS_TEST"
++ else
++ CPU_ARCH="arm"
+ fi
+ ;;
+ esac
diff --git a/www-client/firefox/files/xulrunner-1.9.2-noalsa-fixup.patch b/www-client/firefox/files/xulrunner-1.9.2-noalsa-fixup.patch
new file mode 100644
index 000000000000..1fc7b6f87e65
--- /dev/null
+++ b/www-client/firefox/files/xulrunner-1.9.2-noalsa-fixup.patch
@@ -0,0 +1,26 @@
+diff -urN mozilla-1.9.2-orig/content/base/src/nsDocument.cpp mozilla-1.9.2/content/base/src/nsDocument.cpp
+--- mozilla-1.9.2-orig/content/base/src/nsDocument.cpp 2010-01-28 22:16:08.683135912 -0600
++++ mozilla-1.9.2/content/base/src/nsDocument.cpp 2010-01-28 22:17:57.605126833 -0600
+@@ -169,7 +169,9 @@
+ #include "nsIPropertyBag2.h"
+ #include "nsIDOMPageTransitionEvent.h"
+ #include "nsFrameLoader.h"
++#ifdef MOZ_MEDIA
+ #include "nsHTMLMediaElement.h"
++#endif
+
+ #include "mozAutoDocUpdate.h"
+
+diff -urN mozilla-1.9.2-orig/content/base/src/nsNodeUtils.cpp mozilla-1.9.2/content/base/src/nsNodeUtils.cpp
+--- mozilla-1.9.2-orig/content/base/src/nsNodeUtils.cpp 2010-01-28 22:16:08.686138846 -0600
++++ mozilla-1.9.2/content/base/src/nsNodeUtils.cpp 2010-01-28 22:17:14.618150370 -0600
+@@ -55,7 +55,9 @@
+ #endif
+ #include "nsBindingManager.h"
+ #include "nsGenericHTMLElement.h"
++#ifdef MOZ_MEDIA
+ #include "nsHTMLMediaElement.h"
++#endif
+
+ // This macro expects the ownerDocument of content_ to be in scope as
+ // |nsIDocument* doc|