summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2007-10-26 12:54:28 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2007-10-26 12:54:28 +0000
commitebe0d61365058a68523d60e1da035a09efeaa3e6 (patch)
tree61ebd775dbfd47bb030464278cc523d503748f99 /www-apps
parentAdd ~sparc keyword --- Bug #197103 --- see ChangeLog for comment. (diff)
downloadgentoo-2-ebe0d61365058a68523d60e1da035a09efeaa3e6.tar.gz
gentoo-2-ebe0d61365058a68523d60e1da035a09efeaa3e6.tar.bz2
gentoo-2-ebe0d61365058a68523d60e1da035a09efeaa3e6.zip
Update to tikiwiki-1.9.8.2 in response to sec issue #195503.
(Portage version: 2.1.3.14)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/tikiwiki/ChangeLog7
-rw-r--r--www-apps/tikiwiki/files/digest-tikiwiki-1.9.8.23
-rw-r--r--www-apps/tikiwiki/tikiwiki-1.9.8.2.ebuild72
3 files changed, 81 insertions, 1 deletions
diff --git a/www-apps/tikiwiki/ChangeLog b/www-apps/tikiwiki/ChangeLog
index 6f0471fc1b23..96c7b61d1427 100644
--- a/www-apps/tikiwiki/ChangeLog
+++ b/www-apps/tikiwiki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/tikiwiki
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.46 2007/10/18 16:43:22 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.47 2007/10/26 12:54:28 wrobel Exp $
+
+*tikiwiki-1.9.8.2 (26 Oct 2007)
+
+ 26 Oct 2007; wrobel@gentoo.org +tikiwiki-1.9.8.2.ebuild:
+ Update to tikiwiki-1.9.8.2 in response to sec issue #195503.
18 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
tikiwiki-1.9.8.1.ebuild:
diff --git a/www-apps/tikiwiki/files/digest-tikiwiki-1.9.8.2 b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.8.2
new file mode 100644
index 000000000000..77d09c35aed4
--- /dev/null
+++ b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.8.2
@@ -0,0 +1,3 @@
+MD5 2b0e737c3ab73456a0873e597e14b5f9 tikiwiki-1.9.8.2.tar.bz2 6352619
+RMD160 792a8e32b53a39896b8813808bc2cc5a78c52c34 tikiwiki-1.9.8.2.tar.bz2 6352619
+SHA256 db95daf5ee6a7e9651d11ebb08c0293cac989f69d2b0a8894440e0744649b5a3 tikiwiki-1.9.8.2.tar.bz2 6352619
diff --git a/www-apps/tikiwiki/tikiwiki-1.9.8.2.ebuild b/www-apps/tikiwiki/tikiwiki-1.9.8.2.ebuild
new file mode 100644
index 000000000000..66a854bee2b3
--- /dev/null
+++ b/www-apps/tikiwiki/tikiwiki-1.9.8.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/tikiwiki-1.9.8.2.ebuild,v 1.1 2007/10/26 12:54:28 wrobel Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Full-featured Web Content Management System using PHP and Smarty Templates"
+HOMEPAGE="http://tikiwiki.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+IUSE="mysql postgres graphviz"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="virtual/httpd-cgi
+ graphviz? ( media-gfx/graphviz )
+"
+
+need_php_httpd
+
+pkg_setup () {
+ webapp_pkg_setup
+ use mysql && require_php_with_use mysql
+ use postgres && require_php_with_use postgres
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local DIR
+ local DIRENTRY
+ local DIRS="backups db dump files img/trackers img/wiki
+ img/wiki_up modules/cache temp
+ templates_c templates styles maps whelp mods
+ lib/Galaxia/processes"
+
+ # Ensure that directories exist, some don't.
+ # (part of setup.sh)
+ for DIR in ${DIRS}; do
+ mkdir -p ${DIR}
+ done
+
+ # Remove the execute permission from the setup.sh script
+ # and rename it. Its actions have been incorporated here.
+ chmod a-x setup.sh
+ mv setup.sh setup.sh.done
+
+ # Install the minimal doc (points to web page)
+ #
+ dodoc doc/readme.txt doc/htaccess doc/htaccess.readme INSTALL README
+
+ # The bulk goes into htdocs
+ # but don't copy INSTALL and README
+ cp -pPR [[:lower:]]* "${D}"/"${MY_HTDOCSDIR}"
+
+ # Recursively set server ownership to allow server to write
+ # This is the rough equivalent of the setup.sh script
+ # provided in the distribution.
+ # Note: Cannot use xargs or find -exec here because
+ # these don't work with shell functions.
+ #
+ webapp_serverowned "${MY_HTDOCSDIR}"
+ for DIR in ${DIRS}; do
+ find ${DIR} | while read DIRENTRY; do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${DIRENTRY}
+ done
+ done
+ webapp_serverowned "${MY_HTDOCSDIR}"/tiki-install.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}