summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Marineau <marineam@gentoo.org>2006-07-10 00:48:53 +0000
committerMichael Marineau <marineam@gentoo.org>2006-07-10 00:48:53 +0000
commit678275d85447e495a08f95ca42f46992d1d042b6 (patch)
tree21d0ad74e24cb32f9312668fe60ccfe0c0334800 /www-apps
parentMarked stable on amd64 per bug #139716 (diff)
downloadgentoo-2-678275d85447e495a08f95ca42f46992d1d042b6.tar.gz
gentoo-2-678275d85447e495a08f95ca42f46992d1d042b6.tar.bz2
gentoo-2-678275d85447e495a08f95ca42f46992d1d042b6.zip
Add the current beta version
(Portage version: 2.1-r1)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/ampache/ChangeLog9
-rw-r--r--www-apps/ampache/ampache-3.3.1.7.ebuild4
-rw-r--r--www-apps/ampache/ampache-3.3.2_beta3.ebuild44
-rw-r--r--www-apps/ampache/files/ampache-webinstall.txt23
-rw-r--r--www-apps/ampache/files/digest-ampache-3.3.1.72
-rw-r--r--www-apps/ampache/files/digest-ampache-3.3.2_beta33
6 files changed, 82 insertions, 3 deletions
diff --git a/www-apps/ampache/ChangeLog b/www-apps/ampache/ChangeLog
index 36b069664935..a3c28e3bdb6d 100644
--- a/www-apps/ampache/ChangeLog
+++ b/www-apps/ampache/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/ampache
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ChangeLog,v 1.11 2006/06/07 16:34:20 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ChangeLog,v 1.12 2006/07/10 00:48:52 marineam Exp $
+
+*ampache-3.3.2_beta3 (10 Jul 2006)
+
+ 10 Jul 2006; Michael Marineau <marineam@gentoo.org>
+ -files/ampache-3.3.1.7-webinstall.txt, +files/ampache-webinstall.txt,
+ ampache-3.3.1.7.ebuild, +ampache-3.3.2_beta3.ebuild:
+ Add beta version
07 Jun 2006; Michael Marineau <marineam@gentoo.org>
ampache-3.3.1.7.ebuild:
diff --git a/www-apps/ampache/ampache-3.3.1.7.ebuild b/www-apps/ampache/ampache-3.3.1.7.ebuild
index c5d6f3654962..ee1bf0f2a21f 100644
--- a/www-apps/ampache/ampache-3.3.1.7.ebuild
+++ b/www-apps/ampache/ampache-3.3.1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ampache-3.3.1.7.ebuild,v 1.2 2006/06/07 16:34:20 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ampache-3.3.1.7.ebuild,v 1.3 2006/07/10 00:48:52 marineam Exp $
inherit webapp depend.php
@@ -36,7 +36,7 @@ src_install() {
cp -R . ${D}${MY_HTDOCSDIR}
- webapp_postinst_txt en ${FILESDIR}/${P}-webinstall.txt
+ webapp_postinst_txt en ${FILESDIR}/ampache-webinstall.txt
webapp_src_install
}
diff --git a/www-apps/ampache/ampache-3.3.2_beta3.ebuild b/www-apps/ampache/ampache-3.3.2_beta3.ebuild
new file mode 100644
index 000000000000..27a534631c60
--- /dev/null
+++ b/www-apps/ampache/ampache-3.3.2_beta3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ampache-3.3.2_beta3.ebuild,v 1.1 2006/07/10 00:48:52 marineam Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Ampache is a PHP-based tool for managing, updating and playing your audio files via a web interface."
+HOMEPAGE="http://www.ampache.org/"
+SRC_URI="http://www.ampache.org/downloads/${P/_beta/-beta}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/httpd-php
+ dev-db/mysql"
+DEPEND=""
+
+need_php
+
+S=${WORKDIR}/${P/_beta/-beta}
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ require_php_with_use pcre session unicode iconv xml mysql gd zlib
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc ${S}/docs/*
+ rm -rf ${S}/docs/*
+
+ cp -R . ${D}${MY_HTDOCSDIR}
+
+ webapp_postinst_txt en ${FILESDIR}/ampache-webinstall.txt
+ webapp_src_install
+}
+
diff --git a/www-apps/ampache/files/ampache-webinstall.txt b/www-apps/ampache/files/ampache-webinstall.txt
new file mode 100644
index 000000000000..b7c023447d2d
--- /dev/null
+++ b/www-apps/ampache/files/ampache-webinstall.txt
@@ -0,0 +1,23 @@
+Installing Using the Web Interface:
+
+As of 3.3-Beta3 Ampache includes an web based installation script. In order
+for the script to work correctly you will need a user that has Database
+create and modify rights for your mysql server. To use this script simply
+visit /install.php. If you get a Access Denied make sure that your /config
+directory does not contain an existing ampache.cfg
+
+ Step 1 - Inserting the database, this requires you to enter
+ a username/pass for MySQL that is able to create
+ a brand new database and insert new tables. This does
+ not have to be the user you actually run ampache as
+ Step 2 - Creating the Config file, this step asks for a 'user'
+ level account for MySQL that has full access over
+ the newly created ampache database, this can be the
+ same as the last step, but it is not recommended.
+ Ampache will attempt to write the config file directly
+ to the /config directory, if it isn't able to it
+ should prompt you to download the ampache.cfg simply
+ put it into /config and then visit the login page.
+ Step 3 - Creating the Initial User Account, you will be asked
+ for a username and password for the administrator
+ account.
diff --git a/www-apps/ampache/files/digest-ampache-3.3.1.7 b/www-apps/ampache/files/digest-ampache-3.3.1.7
index b636c1c5de19..31e3c6ca9c70 100644
--- a/www-apps/ampache/files/digest-ampache-3.3.1.7
+++ b/www-apps/ampache/files/digest-ampache-3.3.1.7
@@ -1 +1,3 @@
MD5 7e97eaae5fbf912646e882aeb5500fed ampache-3.3.1.7.tar.gz 1613218
+RMD160 653d49171a2b64673177b8fef54615aeccb1916a ampache-3.3.1.7.tar.gz 1613218
+SHA256 3db93e2ad5eb3c5ac92c66ef394de6032ae3bba3a9efe9bbcea9dde5e504b151 ampache-3.3.1.7.tar.gz 1613218
diff --git a/www-apps/ampache/files/digest-ampache-3.3.2_beta3 b/www-apps/ampache/files/digest-ampache-3.3.2_beta3
new file mode 100644
index 000000000000..1a3bd9c37a49
--- /dev/null
+++ b/www-apps/ampache/files/digest-ampache-3.3.2_beta3
@@ -0,0 +1,3 @@
+MD5 d3c19238cdffd79aac4c2a5052f5414b ampache-3.3.2-beta3.tar.gz 1716258
+RMD160 58080406912b549d31913ca9c254723e3b31590e ampache-3.3.2-beta3.tar.gz 1716258
+SHA256 717bebea119b62cc6caf8dc509d3b709377f3937b706da9496208fa76bd61a54 ampache-3.3.2-beta3.tar.gz 1716258