summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2015-07-12 14:09:52 +0000
committerDirkjan Ochtman <djc@gentoo.org>2015-07-12 14:09:52 +0000
commit019bcfc586f2edacc7ea46f7a0cb7d198348c833 (patch)
tree67662c276faaa94c04e966a2ee3a0f49b78e6c7b /www-apps
parentSwitch back to sourceforge packages to avoid a dep on lua. See bug #554302. (diff)
downloadgentoo-2-019bcfc586f2edacc7ea46f7a0cb7d198348c833.tar.gz
gentoo-2-019bcfc586f2edacc7ea46f7a0cb7d198348c833.tar.bz2
gentoo-2-019bcfc586f2edacc7ea46f7a0cb7d198348c833.zip
Version bump trac to 1.0.6
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/trac/ChangeLog7
-rw-r--r--www-apps/trac/trac-1.0.6_p2.ebuild129
2 files changed, 135 insertions, 1 deletions
diff --git a/www-apps/trac/ChangeLog b/www-apps/trac/ChangeLog
index d12c1e8d84a1..53c3727ab2b9 100644
--- a/www-apps/trac/ChangeLog
+++ b/www-apps/trac/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/trac
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/ChangeLog,v 1.156 2015/07/12 13:57:52 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/ChangeLog,v 1.157 2015/07/12 14:09:52 djc Exp $
+
+*trac-1.0.6_p2 (12 Jul 2015)
+
+ 12 Jul 2015; Dirkjan Ochtman <djc@gentoo.org> +trac-1.0.6_p2.ebuild:
+ Version bump trac to 1.0.6
12 Jul 2015; Dirkjan Ochtman <djc@gentoo.org> -trac-1.0.2.ebuild,
-trac-1.0.3.ebuild:
diff --git a/www-apps/trac/trac-1.0.6_p2.ebuild b/www-apps/trac/trac-1.0.6_p2.ebuild
new file mode 100644
index 000000000000..9c92ec034920
--- /dev/null
+++ b/www-apps/trac/trac-1.0.6_p2.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/trac-1.0.6_p2.ebuild,v 1.1 2015/07/12 14:09:52 djc Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='sqlite?'
+
+DISTUTILS_SINGLE_IMPL=Yes
+
+inherit distutils-r1 eutils user webapp
+
+MY_PV=${PV/_p/.post}
+MY_P=Trac-${MY_PV}
+
+DESCRIPTION="Trac is a minimalistic web-based project management, wiki and bug/issue tracking system"
+HOMEPAGE="http://trac.edgewall.com/ http://pypi.python.org/pypi/Trac"
+SRC_URI="http://ftp.edgewall.com/pub/trac/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="cgi fastcgi i18n +highlight +restructuredtext mysql postgres +sqlite subversion test"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/genshi[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ i18n? ( >=dev-python/Babel-0.9.5[${PYTHON_USEDEP}] )
+ highlight? (
+ || (
+ dev-python/pygments[${PYTHON_USEDEP}]
+ app-text/silvercity
+ app-text/pytextile
+ app-text/enscript
+ )
+ )
+ restructuredtext? ( dev-python/docutils[${PYTHON_USEDEP}] )
+ cgi? ( virtual/httpd-cgi )
+ fastcgi? ( virtual/httpd-fastcgi )
+ mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/psycopg-2[${PYTHON_USEDEP}] )
+ sqlite? ( >=dev-db/sqlite-3.3.4:3 )
+ subversion? ( dev-vcs/subversion[python,${PYTHON_USEDEP}] )
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/twill[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ webapp_pkg_setup
+
+ enewgroup tracd
+ enewuser tracd -1 -1 -1 tracd
+}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ distutils-r1_src_test
+}
+
+python_test() {
+ PYTHONPATH=. "${PYTHON}" trac/test.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_test_all() {
+ if use i18n; then
+ make check
+ fi
+}
+
+python_install() {
+ if use cgi; then
+ python_scriptinto "${MY_CGIBINDIR}"
+ python_doscript contrib/cgi-bin/trac.cgi
+ fi
+ if use fastcgi; then
+ python_scriptinto "${MY_CGIBINDIR}"
+ python_doscript contrib/cgi-bin/trac.fcgi
+ fi
+ distutils-r1_python_install
+}
+
+# the default src_compile just calls setup.py build
+# currently, this switches i18n catalog compilation based on presence of Babel
+
+src_install() {
+ webapp_src_preinst
+ distutils-r1_src_install
+
+ # project environments might go in here
+ keepdir /var/lib/trac
+
+ # Use this as the egg-cache for tracd
+ dodir /var/lib/trac/egg-cache
+ keepdir /var/lib/trac/egg-cache
+ fowners tracd:tracd /var/lib/trac/egg-cache
+
+ # documentation
+ dodoc -r contrib
+
+ # tracd init script
+ newconfd "${FILESDIR}"/tracd.confd tracd
+ newinitd "${FILESDIR}"/tracd.initd tracd
+
+ for lang in en; do
+ webapp_postinst_txt ${lang} "${FILESDIR}"/postinst-${lang}.txt
+ webapp_postupgrade_txt ${lang} "${FILESDIR}"/postupgrade-${lang}.txt
+ done
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+}