summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2005-10-24 14:19:14 +0000
committerRenat Lumpau <rl03@gentoo.org>2005-10-24 14:19:14 +0000
commitd836f70c72c429a08cacdc3eecd851acf01de2e3 (patch)
tree6c47047ae964fbbe7d745609276282d218c059bc /www-apps/rt
parentMarked ~ppc. (diff)
downloadgentoo-2-d836f70c72c429a08cacdc3eecd851acf01de2e3.tar.gz
gentoo-2-d836f70c72c429a08cacdc3eecd851acf01de2e3.tar.bz2
gentoo-2-d836f70c72c429a08cacdc3eecd851acf01de2e3.zip
Fix for bug #109745.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'www-apps/rt')
-rw-r--r--www-apps/rt/ChangeLog6
-rw-r--r--www-apps/rt/Manifest13
-rw-r--r--www-apps/rt/files/3.4.2/Callback.patch38
-rw-r--r--www-apps/rt/rt-3.4.3.ebuild3
4 files changed, 47 insertions, 13 deletions
diff --git a/www-apps/rt/ChangeLog b/www-apps/rt/ChangeLog
index 76001ff1aa83..474823fce543 100644
--- a/www-apps/rt/ChangeLog
+++ b/www-apps/rt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/rt
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/ChangeLog,v 1.23 2005/10/24 14:00:13 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/ChangeLog,v 1.24 2005/10/24 14:19:14 rl03 Exp $
+
+ 24 Oct 2005; Renat Lumpau <rl03@gentoo.org> +files/3.4.2/Callback.patch,
+ rt-3.4.3.ebuild:
+ Fix for bug #109745.
24 Oct 2005; Renat Lumpau <rl03@gentoo.org> -rt-3.4.2-r1.ebuild,
rt-3.4.3.ebuild:
diff --git a/www-apps/rt/Manifest b/www-apps/rt/Manifest
index b62db6fc0284..3faaaff281b6 100644
--- a/www-apps/rt/Manifest
+++ b/www-apps/rt/Manifest
@@ -1,7 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 c6ad11fb5960b43189687370b23f3956 rt-3.4.3.ebuild 5967
+MD5 0956a98f67d42ea9ca893fc8e3f0aadf rt-3.4.3.ebuild 6030
MD5 939107934a799efb520c62c057341273 rt-3.2.1.ebuild 4362
MD5 29197b69d7a3cb53503620e0f1aa46a2 ChangeLog 3969
MD5 224c312cc23d02aa06c26a4da3cc1f90 metadata.xml 221
@@ -15,12 +12,6 @@ MD5 3a24e1ccdc0d6b7c6b0d40e19c586365 files/3.4.2/postinstall-en.txt 703
MD5 3d2e627499ec86839cc0099719fcc3bd files/3.4.2/rt_apache.conf 574
MD5 c807deb11e08ab9f37a658bd5e971c7f files/3.4.2/rt.conf.d 405
MD5 54a1cd04dc0d0788ce920d941e5601d0 files/3.4.2/rt.init.d 1019
+MD5 cee32ca276838f6d74230c66d0bfc961 files/3.4.2/Callback.patch 1567
MD5 bf81df666e02df7b1e6f73ee9908a767 files/3.4.2/reconfig 1206
MD5 73c354dd8ba0f64a74e5c6cd01b33834 files/3.4.2/rt_apache2_fcgi.conf 993
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDXOkFEzitwsaoONoRAtLcAJ9kXFdVOAfm8wTP0QDEjdp28oDZtQCgjAAX
-8uckmYdsRjaVw9WOEJMLBfw=
-=KgcW
------END PGP SIGNATURE-----
diff --git a/www-apps/rt/files/3.4.2/Callback.patch b/www-apps/rt/files/3.4.2/Callback.patch
new file mode 100644
index 000000000000..e3850e21cfb4
--- /dev/null
+++ b/www-apps/rt/files/3.4.2/Callback.patch
@@ -0,0 +1,38 @@
+diff -upr rt-3.4.3/html/Elements/Callback rt-3.4.3_fixed/html/Elements/Callback
+--- rt-3.4.3/html/Elements/Callback 2005-02-01 09:20:40.000000000 -0500
++++ rt-3.4.3_fixed/html/Elements/Callback 2005-10-24 10:13:58.000000000 -0400
+@@ -53,14 +53,27 @@ my $CacheKey = "Callback--$Page--$_Callb
+ my $callbacks = $cache{$CacheKey} || $m->notes($CacheKey);
+
+ if (!$callbacks) {
+- my $path = "/Callbacks/*$Page/$_CallbackName";
+-
+- $callbacks = [
+- # Skip backup files, and files without a leading package name
+- grep { !/^\.|~$/ and $_ ne "/Callbacks/$Page/$_CallbackName" }
+- $m->interp->resolver->glob_path($path)
+- ];
++ my $path = "/Callbacks/*$Page/$_CallbackName";
+
++ # Due to API changes after Mason 1.28, we have to check for which
++ # version we're running when getting the component roots
++ my @roots = map { $_->[1] }
++ $HTML::Mason::VERSION <= 1.28
++ ? $m->interp->resolver->comp_root_array
++ : $m->interp->comp_root_array;
++
++ my %seen;
++
++ for my $root (@roots) {
++ push @$callbacks,
++ # Skip backup files, files without a leading package name,
++ # and files we've already seen
++ grep { !/^\.|~$/
++ and $_ ne "/Callbacks/$Page/$_CallbackName"
++ and not $seen{$_}++ }
++ $m->interp->resolver->glob_path($path, $root);
++ }
++
+ $m->notes($CacheKey => $callbacks);
+ $cache{$Page,$_CallbackName} = $callbacks if !$RT::DevelMode;
+ }
diff --git a/www-apps/rt/rt-3.4.3.ebuild b/www-apps/rt/rt-3.4.3.ebuild
index e730304bde08..e064d95f1cc9 100644
--- a/www-apps/rt/rt-3.4.3.ebuild
+++ b/www-apps/rt/rt-3.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.4.3.ebuild,v 1.6 2005/10/24 14:00:13 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.4.3.ebuild,v 1.7 2005/10/24 14:19:14 rl03 Exp $
inherit webapp eutils
@@ -143,6 +143,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/3.4.2/Callback.patch # fix for bug #109745
# add Gentoo-specific layout
cat ${FILESDIR}/3.4.2/config.layout-gentoo >> config.layout