summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-05 00:55:15 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-05 00:55:15 +0000
commit7f4f91fd7341b75b0d86e1b6ab1e742187a22346 (patch)
treef041582c50cb212a9af1613b6beeb009d9d320c2 /www-apps/moinmoin
parentany mod support will do (diff)
downloadgentoo-2-7f4f91fd7341b75b0d86e1b6ab1e742187a22346.tar.gz
gentoo-2-7f4f91fd7341b75b0d86e1b6ab1e742187a22346.tar.bz2
gentoo-2-7f4f91fd7341b75b0d86e1b6ab1e742187a22346.zip
Version bump (bug #374389 by Robert Trace).
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/moinmoin')
-rw-r--r--www-apps/moinmoin/ChangeLog10
-rw-r--r--www-apps/moinmoin/files/postinstall-en-1.9.4.txt16
-rw-r--r--www-apps/moinmoin/files/reconfig-1.9.417
-rw-r--r--www-apps/moinmoin/moinmoin-1.9.4.ebuild101
4 files changed, 142 insertions, 2 deletions
diff --git a/www-apps/moinmoin/ChangeLog b/www-apps/moinmoin/ChangeLog
index 0b2cae830162..7c38853f8a34 100644
--- a/www-apps/moinmoin/ChangeLog
+++ b/www-apps/moinmoin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/moinmoin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moinmoin/ChangeLog,v 1.72 2011/04/20 19:11:38 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moinmoin/ChangeLog,v 1.73 2012/09/05 00:55:15 radhermit Exp $
+
+*moinmoin-1.9.4 (05 Sep 2012)
+
+ 05 Sep 2012; Tim Harder <radhermit@gentoo.org> +files/reconfig-1.9.4,
+ +moinmoin-1.9.4.ebuild, +files/postinstall-en-1.9.4.txt:
+ Version bump (bug #374389 by Robert Trace).
20 Apr 2011; Tim Harder <radhermit@gentoo.org> moinmoin-1.8.8.ebuild:
Restrict to at most dev-lang/python-2.6* since 2.7 won't work.
diff --git a/www-apps/moinmoin/files/postinstall-en-1.9.4.txt b/www-apps/moinmoin/files/postinstall-en-1.9.4.txt
new file mode 100644
index 000000000000..6a6baf764ead
--- /dev/null
+++ b/www-apps/moinmoin/files/postinstall-en-1.9.4.txt
@@ -0,0 +1,16 @@
+Now please read the installation manual at
+/usr/share/doc/${PF}/html
+
+MoinMoin can work with a variety of webservers. Simple Apache instructions
+are given below:
+
+1. ExecCGI needs to be enabled in your Moinmoin directory by doing:
+# echo "Options ExecCGI" > ${MY_INSTALLDIR}/.htaccess
+# echo "AddHandler cgi-script .cgi" >> ${MY_INSTALLDIR}/.htaccess
+
+2. Add the following lines to your Apache configs:
+ScriptAlias /mywiki "${MY_INSTALLDIR}/moin.cgi"
+
+3. Restart Apache
+
+4. Go to http://${VHOST_HOSTNAME}/mywiki/ and follow the instructions there.
diff --git a/www-apps/moinmoin/files/reconfig-1.9.4 b/www-apps/moinmoin/files/reconfig-1.9.4
new file mode 100644
index 000000000000..698da419fdb5
--- /dev/null
+++ b/www-apps/moinmoin/files/reconfig-1.9.4
@@ -0,0 +1,17 @@
+#!/bin/bash
+
+die() {
+ echo "#####"
+ echo $1
+ echo "#####"
+ exit 1
+}
+
+if [ $1 = "install" ]; then
+ sed -e "s|^#\(.*\)/path/to/wikiconfigdir|\1${VHOST_ROOT}/${PN}-${PVR}|g" -i ${MY_INSTALLDIR}/moin.cgi || die "sed failed"
+ sed -e "s|#url_prefix_static|url_prefix_static|" -i ${VHOST_ROOT}/${PN}-${PVR}/wikiconfig.py || die "sed failed"
+ sed -e "s|//|/|" -i ${VHOST_ROOT}/${PN}-${PVR}/wikiconfig.py || die "sed failed"
+
+elif [ $1 = "clean" ]; then
+ echo $1
+fi
diff --git a/www-apps/moinmoin/moinmoin-1.9.4.ebuild b/www-apps/moinmoin/moinmoin-1.9.4.ebuild
new file mode 100644
index 000000000000..c0b8cd51651d
--- /dev/null
+++ b/www-apps/moinmoin/moinmoin-1.9.4.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moinmoin/moinmoin-1.9.4.ebuild,v 1.1 2012/09/05 00:55:15 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.5"
+PYTHON_MODNAME="MoinMoin"
+
+inherit distutils webapp
+
+MY_PN="moin"
+
+DESCRIPTION="Python WikiClone"
+HOMEPAGE="http://moinmo.in/"
+SRC_URI="http://static.moinmo.in/files/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/docutils-0.4
+ >=dev-python/flup-1.0.2
+ >=dev-python/pygments-1.1.1
+ >=dev-python/werkzeug-0.7.0"
+
+need_httpd_cgi
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+WEBAPP_MANUAL_SLOT="yes"
+
+pkg_setup() {
+ if has_version "<www-apps/moinmoin-1.9" ; then
+ ewarn
+ ewarn "You already have a version of moinmoin prior to 1.9 installed."
+ ewarn "moinmoin-1.9 has a very different configuration than 1.8 (among"
+ ewarn "other changes, static content is no longer installed under the"
+ ewarn "htdocs directory)."
+ ewarn
+ ewarn "Please read http://moinmo.in/MoinMoinRelease1.9 and"
+ ewarn "README.migration in /usr/share/doc/${PF}"
+ ewarn
+ fi
+
+ python_set_active_version 2
+ python_pkg_setup
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ # remove bundled -- parsedatetime and xappy not packaged yet
+ rm -r MoinMoin/support/{pygments,werkzeug,flup} || die
+ sed -i "/\(flup\|pygments\|werkzeug\)/d" setup.py || die
+}
+
+src_install() {
+ webapp_src_preinst
+ distutils_src_install
+
+ dodoc README docs/CHANGES* docs/README.migration
+ dohtml docs/INSTALL.html
+ rm -rf README docs/
+
+ cd "${D}"/usr/share/moin
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r server/moin.cgi
+ fperms +x "${MY_HTDOCSDIR}/moin.cgi"
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}
+ doins -r data underlay config/wikiconfig.py
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}/altconfigs
+ doins -r config
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}/altserver
+ doins -r server
+
+ # data needs to be server owned per moin devs
+ cd "${D}/${MY_HOSTROOTDIR}"/${PF}
+ for file in $(find data underlay); do
+ webapp_serverowned "${MY_HOSTROOTDIR}/${PF}/${file}"
+ done
+
+ webapp_configfile "${MY_HOSTROOTDIR}"/${PF}/wikiconfig.py
+ webapp_hook_script "${FILESDIR}"/reconfig-${PV}
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-${PV}.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you are upgrading from an older version, please read"
+ ewarn "README.migration in /usr/share/doc/${PF}"
+ ewarn
+
+ distutils_pkg_postinst
+ webapp_pkg_postinst
+}