summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2004-08-29 00:07:24 +0000
committerRenat Lumpau <rl03@gentoo.org>2004-08-29 00:07:24 +0000
commit1e21dcb1ccccc26ad596310213c62f7fc660d057 (patch)
tree887b5b2fc11f8bf525b1a7c504374c8048d2147e /www-apps/metadot
parentInitial ebuild, metadot dependency (Manifest recommit) (diff)
downloadgentoo-2-1e21dcb1ccccc26ad596310213c62f7fc660d057.tar.gz
gentoo-2-1e21dcb1ccccc26ad596310213c62f7fc660d057.tar.bz2
gentoo-2-1e21dcb1ccccc26ad596310213c62f7fc660d057.zip
Initial ebuild, requested in 61002
Diffstat (limited to 'www-apps/metadot')
-rw-r--r--www-apps/metadot/ChangeLog10
-rw-r--r--www-apps/metadot/Manifest6
-rw-r--r--www-apps/metadot/files/digest-metadot-6.1.61
-rw-r--r--www-apps/metadot/files/postinstall-en.txt48
-rw-r--r--www-apps/metadot/files/reconfig5
-rw-r--r--www-apps/metadot/metadata.xml5
-rw-r--r--www-apps/metadot/metadot-6.1.6.ebuild60
7 files changed, 135 insertions, 0 deletions
diff --git a/www-apps/metadot/ChangeLog b/www-apps/metadot/ChangeLog
new file mode 100644
index 000000000000..a982c73f99b6
--- /dev/null
+++ b/www-apps/metadot/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for www-apps/metadot
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/metadot/ChangeLog,v 1.1 2004/08/29 00:07:24 rl03 Exp $
+
+*metadot-6.1.6 (28 Aug 2004)
+
+ 28 Aug 2004; Renat Lumpau <rl03@gentoo.org> +metadata.xml,
+ +files/postinstall-en.txt, +files/reconfig, +metadot-6.1.6.ebuild:
+ Initial ebuild. Requested in #61002.
+
diff --git a/www-apps/metadot/Manifest b/www-apps/metadot/Manifest
new file mode 100644
index 000000000000..de30d9cd881c
--- /dev/null
+++ b/www-apps/metadot/Manifest
@@ -0,0 +1,6 @@
+MD5 5cf02b4257e74820437b29a5f0e085d6 metadot-6.1.6.ebuild 1296
+MD5 854fd4f3fe5a1a5fd08abd7a99b07677 ChangeLog 317
+MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
+MD5 20d7f02a98e7e1bdd83cc868dc128863 files/postinstall-en.txt 1567
+MD5 04f2425090275b79624c2ef14ef107ff files/digest-metadot-6.1.6 65
+MD5 c7ad307b2475e81f9e5a15c731185dd4 files/reconfig 337
diff --git a/www-apps/metadot/files/digest-metadot-6.1.6 b/www-apps/metadot/files/digest-metadot-6.1.6
new file mode 100644
index 000000000000..c399710b3058
--- /dev/null
+++ b/www-apps/metadot/files/digest-metadot-6.1.6
@@ -0,0 +1 @@
+MD5 589abc3eeb79725c45eae4eefd20b85c metadot6.1.6.tar.gz 3754969
diff --git a/www-apps/metadot/files/postinstall-en.txt b/www-apps/metadot/files/postinstall-en.txt
new file mode 100644
index 000000000000..5a25713e1b02
--- /dev/null
+++ b/www-apps/metadot/files/postinstall-en.txt
@@ -0,0 +1,48 @@
+
+1. Set up your database:
+cd ${MY_INSTALLDIR}/default_data
+If using MySQL-3*: mysql -uroot -p mysql < createdbanduser.sql
+If using MySQL-4*: mysql -uroot -p mysql < createdbanduser4x.sql
+
+Then change the default password:
+mysql -uroot -p mysql
+mysql> update user set password = password('<newpassword>') where user = 'metadot';
+mysql> flush privileges;
+mysql> quit
+
+Now,
+mysql -umetadot -p<newpassword> metadotdb < sampledata.sql
+
+2. Edit the Metadot configuration file:
+edit ${MY_INSTALLDIR}/etc/metadot.conf
+Set your database password from step 1.
+Read the online docs! Especially if you want to use virtual servers.
+
+3. Configure Apache:
+Add the follwing to you apache.conf or .htaccess:
+
+Alias /images/ ${MY_INSTALLDIR}/html/images/
+Alias /js/ ${MY_INSTALLDIR}/html/js/
+Alias /metadot/ ${MY_INSTALLDIR}/metadot/
+Alias /public/ ${MY_INSTALLDIR}/sitedata/public/
+Alias /skins/ ${MY_INSTALLDIR}/sitedata/skins/
+Alias /htmlarea3/ ${MY_INSTALLDIR}/html/htmlarea3/
+
+<Location "/metadot/">
+ SetHandler perl-script
+ PerlHandler Apache::Registry
+ Options +ExecCGI
+</Location>
+
+To quote the docs:
+"Make sure that this directory is owned by apache:apache"
+Read the section about configuring your MIME types.
+Now restart Apache.
+
+4. Configure cronjobs.
+Read the relevant section in the docs, and be sure to specify the right paths.
+HINT: /home/metadot is not used, everything is in ${MY_INSTALLDIR}/${PN}
+
+5. Now go to http://${VHOST_HOSTNAME}/metadot/index.pl
+Hopefully everything worked. Now go read the docs and set up your Metadot, and
+change the default Admin password.
diff --git a/www-apps/metadot/files/reconfig b/www-apps/metadot/files/reconfig
new file mode 100644
index 000000000000..c70721fcbe27
--- /dev/null
+++ b/www-apps/metadot/files/reconfig
@@ -0,0 +1,5 @@
+#!/bin/bash
+if [ $1 = "start" -o $1 = "install" ]; then
+ sed -e "s|skin_template_dir = /home/metadot/metadot/sitedata/skins|skin_template_dir = ${MY_INSTALLDIR}/sitedata/skins|
+ s|public_uploads_dir = /home/metadot/metadot/sitedata/public|public_uploads_dir = ${MY_INSTALLDIR}/sitedata/public|" -i ${MY_INSTALLDIR}/etc/metadot.conf
+fi
diff --git a/www-apps/metadot/metadata.xml b/www-apps/metadot/metadata.xml
new file mode 100644
index 000000000000..95c06f0095bb
--- /dev/null
+++ b/www-apps/metadot/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+</pkgmetadata>
diff --git a/www-apps/metadot/metadot-6.1.6.ebuild b/www-apps/metadot/metadot-6.1.6.ebuild
new file mode 100644
index 000000000000..79f528efbab0
--- /dev/null
+++ b/www-apps/metadot/metadot-6.1.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/metadot/metadot-6.1.6.ebuild,v 1.1 2004/08/29 00:07:24 rl03 Exp $
+
+inherit webapp
+MY_P=${P/-/}
+S=${WORKDIR}/${PN}
+
+IUSE=""
+
+DESCRIPTION="Metadot is a CMS with file, page and link management, and collaboration features."
+HOMEPAGE="http://www.metadot.com"
+SRC_URI="http://download.metadot.com/${MY_P}.tar.gz"
+
+KEYWORDS="~x86"
+
+DEPEND="$DEPEND"
+RDEPEND="
+ ${DEPEND}
+ >=dev-db/mysql-3.23
+ >=net-www/apache-1.3.6
+ >=dev-lang/perl-5.005
+ >=dev-perl/mod_perl-1.21
+ dev-perl/DBI
+ dev-perl/DBD-mysql
+ dev-perl/Apache-DBI
+ dev-perl/XML-RSS
+ dev-perl/Storable
+ dev-perl/perl-ldap
+ dev-perl/Log-Agent
+ dev-perl/Mail-POP3Client
+ dev-perl/IO-stringy
+ dev-perl/MailTools
+ dev-perl/MIME-tools
+ dev-perl/Unicode-String
+ dev-perl/Spreadsheet-WriteExcel
+ dev-perl/Date-Calc
+ dev-perl/AppConfig
+ dev-perl/ImageSize
+ dev-perl/Template-Toolkit
+ dev-perl/Time-HiRes
+ dev-perl/Lingua-EN-NameParse
+ dev-perl/Number-Format
+ dev-perl/XML-Simple
+ dev-perl/Text-CSV
+ dev-perl/Archive-Zip
+"
+
+LICENSE="GPL-2"
+
+src_install() {
+ webapp_src_preinst
+ dodir ${MY_HOSTROOTDIR}/${PN}
+
+ dodoc CHANGELOG README
+ cp -R [[:lower:]][[:lower:]]* ${D}/${MY_HTDOCSDIR}
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_hook_script ${FILESDIR}/reconfig
+ webapp_src_install
+}