summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-09-17 10:16:44 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-09-17 10:16:44 +0000
commit4ca983976277049c80e86658e247801a82eb43fe (patch)
treeb6838a855e83bf4732aead66ea4dca250468833b /www-apache
parentAdd myself as a maintainer. (diff)
downloadgentoo-2-4ca983976277049c80e86658e247801a82eb43fe.tar.gz
gentoo-2-4ca983976277049c80e86658e247801a82eb43fe.tar.bz2
gentoo-2-4ca983976277049c80e86658e247801a82eb43fe.zip
version bump wrt #253537
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_suphp/ChangeLog10
-rw-r--r--www-apache/mod_suphp/mod_suphp-0.6.2-r3.ebuild113
-rw-r--r--www-apache/mod_suphp/mod_suphp-0.7.1.ebuild93
3 files changed, 101 insertions, 115 deletions
diff --git a/www-apache/mod_suphp/ChangeLog b/www-apache/mod_suphp/ChangeLog
index 29bf8ab471e3..cc0108fcbad2 100644
--- a/www-apache/mod_suphp/ChangeLog
+++ b/www-apache/mod_suphp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_suphp
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_suphp/ChangeLog,v 1.21 2008/08/23 04:37:54 cardoe Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_suphp/ChangeLog,v 1.22 2009/09/17 10:16:44 hollow Exp $
+
+*mod_suphp-0.7.1 (17 Sep 2009)
+
+ 17 Sep 2009; Benedikt Böhm <hollow@gentoo.org>
+ -mod_suphp-0.6.2-r3.ebuild, +mod_suphp-0.7.1.ebuild:
+ version bump wrt #253537
23 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/www-apache/mod_suphp/mod_suphp-0.6.2-r3.ebuild b/www-apache/mod_suphp/mod_suphp-0.6.2-r3.ebuild
deleted file mode 100644
index 757f6652ec20..000000000000
--- a/www-apache/mod_suphp/mod_suphp-0.6.2-r3.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_suphp/mod_suphp-0.6.2-r3.ebuild,v 1.4 2008/03/23 12:02:17 hollow Exp $
-
-inherit apache-module autotools eutils
-
-MY_P="${P/mod_/}"
-
-SETIDMODES="mode-force mode-owner mode-paranoid"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-
-DESCRIPTION="A PHP wrapper for Apache2"
-HOMEPAGE="http://www.suphp.org/"
-SRC_URI="http://www.suphp.org/download/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="checkpath ${SETIDMODES}"
-
-S="${WORKDIR}/${MY_P}"
-
-APXS2_S="${S}/src/apache2"
-APACHE2_MOD_CONF="70_${PN}"
-APACHE2_MOD_DEFINE="SUPHP"
-
-need_apache2_2
-
-pkg_setup() {
- modecnt=0
- for mode in ${SETIDMODES} ; do
- if use ${mode} ; then
- if [[ ${modecnt} -eq 0 ]] ; then
- SUPHP_SETIDMODE=${mode/mode-}
- let modecnt++
- elif [[ ${modecnt} -ge 1 ]] ; then
- die "You can only select ONE mode in your USE flags!"
- fi
- fi
- done
-
- if [[ ${modecnt} -eq 0 ]] ; then
- ewarn
- ewarn "No mode selected, defaulting to paranoid!"
- ewarn
- ewarn "If you want to choose another mode, put mode-force OR mode-owner"
- ewarn "into your USE flags and run emerge again."
- ewarn
- SUPHP_SETIDMODE=paranoid
- fi
-
- elog
- elog "Using ${SUPHP_SETIDMODE/mode-} mode"
- elog
- elog "You can manipulate several configure options of this"
- elog "ebuild through environment variables:"
- elog
- elog "SUPHP_MINUID: Minimum UID, which is allowed to run scripts (default: 1000)"
- elog "SUPHP_MINGID: Minimum GID, which is allowed to run scripts (default: 100)"
- elog "SUPHP_APACHEUSER: Name of the user Apache is running as (default: apache)"
- elog "SUPHP_LOGFILE: Path to suPHP logfile (default: /var/log/apache2/suphp_log)"
- elog
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-handler.patch
- eautoreconf
-}
-
-src_compile() {
- local myargs=""
- use checkpath || myargs="${myargs} --disable-checkpath"
-
- : ${SUPHP_MINUID:=1000}
- : ${SUPHP_MINGID:=100}
- : ${SUPHP_APACHEUSER:="apache"}
- : ${SUPHP_LOGFILE:="/var/log/apache2/suphp_log"}
-
- myargs="${myargs} \
- --with-setid-mode=${SUPHP_SETIDMODE} \
- --with-min-uid=${SUPHP_MINUID} \
- --with-min-gid=${SUPHP_MINGID} \
- --with-apache-user=${SUPHP_APACHEUSER} \
- --with-logfile=${SUPHP_LOGFILE} \
- --with-apxs=${APXS} \
- --with-apr=/usr/bin/apr-1-config"
- econf ${myargs} || die "econf failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- apache-module_src_install
- dosbin src/suphp
- fperms 4755 /usr/sbin/suphp
-
- dodoc ChangeLog doc/CONFIG
-
- docinto apache
- dodoc doc/apache/CONFIG doc/apache/INSTALL
-
- insinto /etc
- doins "${FILESDIR}/suphp.conf"
-}
-
-pkg_postinst() {
- # Make sure the suphp binary is set setuid
- chmod 4755 "${ROOT}"/usr/sbin/suphp
-
- apache-module_pkg_postinst
-}
diff --git a/www-apache/mod_suphp/mod_suphp-0.7.1.ebuild b/www-apache/mod_suphp/mod_suphp-0.7.1.ebuild
new file mode 100644
index 000000000000..994cf25604ba
--- /dev/null
+++ b/www-apache/mod_suphp/mod_suphp-0.7.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_suphp/mod_suphp-0.7.1.ebuild,v 1.1 2009/09/17 10:16:44 hollow Exp $
+
+EAPI="2"
+
+inherit apache-module confutils
+
+DESCRIPTION="suPHP is a tool for executing PHP scripts with the permissions of their owners."
+HOMEPAGE="http://www.suphp.org/"
+SRC_URI="http://www.suphp.org/download/suphp-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="checkpath mode-force mode-owner +mode-paranoid"
+
+S="${WORKDIR}/suphp-${PV}"
+
+APXS2_S="${S}/src/apache2"
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="SUPHP"
+
+need_apache2_2
+
+pkg_setup() {
+ confutils_require_one mode-force mode-owner mode-paranoid
+
+ if use mode-force; then
+ SUPHP_SETIDMODE="force"
+ elif use mode-owner; then
+ SUPHP_SETIDMODE="owner"
+ else
+ SUPHP_SETIDMODE="paranoid"
+ fi
+
+ elog
+ elog "Using ${SUPHP_SETIDMODE} mode"
+ elog
+ elog "You can manipulate several configure options of this"
+ elog "ebuild through environment variables:"
+ elog
+ elog "SUPHP_MINUID: Minimum UID, which is allowed to run scripts (default: 1000)"
+ elog "SUPHP_MINGID: Minimum GID, which is allowed to run scripts (default: 100)"
+ elog "SUPHP_APACHEUSER: Name of the user Apache is running as (default: apache)"
+ elog "SUPHP_LOGFILE: Path to suPHP logfile (default: /var/log/apache2/suphp_log)"
+ elog
+}
+
+src_configure() {
+ local myargs=""
+ use checkpath || myargs="--disable-checkpath"
+
+ : ${SUPHP_MINUID:=1000}
+ : ${SUPHP_MINGID:=100}
+ : ${SUPHP_APACHEUSER:="apache"}
+ : ${SUPHP_LOGFILE:="/var/log/apache2/suphp_log"}
+
+ econf ${myargs} \
+ --with-setid-mode=${SUPHP_SETIDMODE} \
+ --with-min-uid=${SUPHP_MINUID} \
+ --with-min-gid=${SUPHP_MINGID} \
+ --with-apache-user=${SUPHP_APACHEUSER} \
+ --with-logfile=${SUPHP_LOGFILE} \
+ --with-apxs=${APXS} \
+ --with-apr=/usr/bin/apr-1-config \
+ || die "econf failed"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ apache-module_src_install
+ dosbin src/suphp
+ fperms 4755 /usr/sbin/suphp
+
+ dodoc ChangeLog doc/CONFIG
+
+ docinto apache
+ dodoc doc/apache/CONFIG doc/apache/INSTALL
+
+ insinto /etc
+ doins "${FILESDIR}/suphp.conf"
+}
+
+pkg_postinst() {
+ # Make sure the suphp binary is set setuid
+ chmod 4755 "${ROOT}"/usr/sbin/suphp
+
+ apache-module_pkg_postinst
+}