summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-01-06 20:32:42 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-01-06 20:32:42 +0000
commitf83d4d4d3f14372223588c407f76c08a0732f9f1 (patch)
treef874324be8861cac27518104b2a31d025cb7547a /www-apache/mod_python
parentAdd cross-compile support. (diff)
downloadgentoo-2-f83d4d4d3f14372223588c407f76c08a0732f9f1.tar.gz
gentoo-2-f83d4d4d3f14372223588c407f76c08a0732f9f1.tar.bz2
gentoo-2-f83d4d4d3f14372223588c407f76c08a0732f9f1.zip
cleanup
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'www-apache/mod_python')
-rw-r--r--www-apache/mod_python/ChangeLog8
-rw-r--r--www-apache/mod_python/files/16_mod_python.conf8
-rw-r--r--www-apache/mod_python/files/digest-mod_python-3.2.103
-rw-r--r--www-apache/mod_python/mod_python-3.2.10.ebuild60
4 files changed, 8 insertions, 71 deletions
diff --git a/www-apache/mod_python/ChangeLog b/www-apache/mod_python/ChangeLog
index ab7f21640848..1b4f713a0352 100644
--- a/www-apache/mod_python/ChangeLog
+++ b/www-apache/mod_python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/mod_python
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_python/ChangeLog,v 1.8 2007/11/23 13:24:14 drac Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_python/ChangeLog,v 1.9 2008/01/06 20:32:41 hollow Exp $
+
+ 06 Jan 2008; Benedikt Böhm <hollow@gentoo.org> files/16_mod_python.conf,
+ -mod_python-3.2.10.ebuild:
+ cleanup
23 Nov 2007; Samuli Suominen <drac@gentoo.org> mod_python-3.3.1.ebuild:
amd64 stable wrt #199815
diff --git a/www-apache/mod_python/files/16_mod_python.conf b/www-apache/mod_python/files/16_mod_python.conf
index c2df73cf8ff2..ae4657e89776 100644
--- a/www-apache/mod_python/files/16_mod_python.conf
+++ b/www-apache/mod_python/files/16_mod_python.conf
@@ -1,10 +1,6 @@
<IfDefine PYTHON>
- <IfModule !mod_python.c>
- LoadModule python_module modules/mod_python.so
- </IfModule>
-</IfDefine>
+LoadModule python_module modules/mod_python.so
-<IfModule mod_python.c>
#
# Mod_python is a module that embeds the Python language interpreter
# within the server, allowing Apache handlers to be written in Python.
@@ -37,4 +33,4 @@
# PythonHandler mod_python.publisher
#</Location>
-</IfModule>
+</IfDefine>
diff --git a/www-apache/mod_python/files/digest-mod_python-3.2.10 b/www-apache/mod_python/files/digest-mod_python-3.2.10
deleted file mode 100644
index 6d9dfb733230..000000000000
--- a/www-apache/mod_python/files/digest-mod_python-3.2.10
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 cc6439f546a6e70cfff7ca51b8c62541 mod_python-3.2.10.tgz 365768
-RMD160 2afdd0a80c815f8b9a1b33258e04ae17a12b7dbd mod_python-3.2.10.tgz 365768
-SHA256 ac404c02ee052dcfbd8e303fe9148866c561be9b9a8a12cffee25276e147f13c mod_python-3.2.10.tgz 365768
diff --git a/www-apache/mod_python/mod_python-3.2.10.ebuild b/www-apache/mod_python/mod_python-3.2.10.ebuild
deleted file mode 100644
index a05bb01e5cc6..000000000000
--- a/www-apache/mod_python/mod_python-3.2.10.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_python/mod_python-3.2.10.ebuild,v 1.1 2007/08/19 11:53:43 phreak Exp $
-
-inherit python apache-module multilib autotools
-
-KEYWORDS="alpha amd64 ia64 ppc sparc x86"
-
-DESCRIPTION="An Apache2 module providing an embedded Python interpreter."
-HOMEPAGE="http://www.modpython.org/"
-SRC_URI="mirror://apache/httpd/modpython/${P}.tgz"
-LICENSE="Apache-1.1"
-SLOT="0"
-IUSE=""
-
-DEPEND="dev-lang/python"
-RDEPEND="${DEPEND}"
-
-APACHE2_MOD_CONF="16_${PN}"
-APACHE2_MOD_DEFINE="PYTHON"
-
-DOCFILES="README NEWS CREDITS COPYRIGHT"
-
-need_apache2
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Remove optimisations, we do that outside Portage
- sed -ie 's:--optimize 2:--no-compile:' "dist/Makefile.in"
-
- # Fix compilation when using Python 2.3 or newer
- if has_version ">=dev-lang/python-2.3" ; then
- sed -ie 's:LONG_LONG:PY_LONG_LONG:g' "${S}/src/requestobject.c"
- fi
-
- eautoconf
-}
-
-src_compile() {
- econf --with-apxs=${APXS2} || die "econf failed"
- emake OPT="`apxs2 -q CFLAGS` -fPIC" || die "econf failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dohtml -r doc-html/*
- apache-module_src_install
-}
-
-pkg_postinst() {
- python_version
- python_mod_optimize "/usr/$(get_libdir)/python${PYVER}/site-packages/mod_python"
- apache-module_pkg_postinst
-}
-
-pkg_postrm() {
- python_mod_cleanup
-}