summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2005-04-13 02:09:57 +0000
committerChristian Parpart <trapni@gentoo.org>2005-04-13 02:09:57 +0000
commitff5bbbdd1717481eb84c33d11ff25b439beba741 (patch)
treeee333b127b2a0494230915b1e1fe83a08bfe9ae6 /www-apache/mod_gnutls
parentadding missing "Listen 443" line and comment to config file (diff)
downloadgentoo-2-ff5bbbdd1717481eb84c33d11ff25b439beba741.tar.gz
gentoo-2-ff5bbbdd1717481eb84c33d11ff25b439beba741.tar.bz2
gentoo-2-ff5bbbdd1717481eb84c33d11ff25b439beba741.zip
typofix
(Portage version: 2.0.51.19)
Diffstat (limited to 'www-apache/mod_gnutls')
-rw-r--r--www-apache/mod_gnutls/files/47_mod_gnutls.conf6
-rw-r--r--www-apache/mod_gnutls/mod_gnutls-0.1.1-r1.ebuild15
2 files changed, 16 insertions, 5 deletions
diff --git a/www-apache/mod_gnutls/files/47_mod_gnutls.conf b/www-apache/mod_gnutls/files/47_mod_gnutls.conf
index 5cf125a79a0e..c9b7df69a2e8 100644
--- a/www-apache/mod_gnutls/files/47_mod_gnutls.conf
+++ b/www-apache/mod_gnutls/files/47_mod_gnutls.conf
@@ -1,12 +1,12 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_gnutls/files/47_mod_gnutls.conf,v 1.2 2005/04/13 02:03:08 trapni Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_gnutls/files/47_mod_gnutls.conf,v 1.3 2005/04/13 02:09:57 trapni Exp $
<IfDefine GNUTLS>
LoadModule gnutls_module modules/mod_gnutls.so
</IfDefine>
-<IfDefine mod_gnutls.c>
+<IfModule mod_gnutls.c>
# Listen on standard SSL port.
# Enable this by default to keep default config in sync with mod_ssl.
# Though, this should make migrating from mod_ssl to mod_gnutls easier.
@@ -20,7 +20,7 @@
# The Default method is to use a DBM backed Cache. It isn't super fast, but
# it is portable and does not require another server to be running like memcached.
GnuTLSCache dbm conf/gnutls_cache
-</IfDefine>
+</IfModule>
# the following is an example virtual-host as you could configure it.
# however, this is just an example. You should always put your own
diff --git a/www-apache/mod_gnutls/mod_gnutls-0.1.1-r1.ebuild b/www-apache/mod_gnutls/mod_gnutls-0.1.1-r1.ebuild
index eb6fdd3c6599..f3f6d8bc510c 100644
--- a/www-apache/mod_gnutls/mod_gnutls-0.1.1-r1.ebuild
+++ b/www-apache/mod_gnutls/mod_gnutls-0.1.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_gnutls/mod_gnutls-0.1.1-r1.ebuild,v 1.2 2005/04/13 01:05:18 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_gnutls/mod_gnutls-0.1.1-r1.ebuild,v 1.3 2005/04/13 02:09:57 trapni Exp $
-inherit apache-module
+inherit apache-module ssl-cert
DESCRIPTION="mod_gnutls uses the GnuTLS library to provide SSL v3, TLS 1.0 and \
TLS 1.1 encryption for Apache HTTPD. It is similar to mod_ssl in purpose, but \
@@ -36,7 +36,18 @@ src_install() {
insinto ${APACHE2_CONFDIR}
doins data/rsafile data/dhfile
+ keepdir ${APACHE2_CONFDIR}/ssl
+
apache-module_src_install
}
+#pkg_postinst() {
+# if [ ! -f "${APACHE2_CONFDIR}/ssl/server.crt" ]; then
+# docert "${APACHE2_CONFDIR}/ssl/server"
+# else
+# einfo "Skipping generation of SSL server certificates,"
+# einfo "as it seem you already have some."
+# fi
+#}
+
# vim:ts=4