summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-19 07:58:37 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-19 07:58:37 +0000
commitc1a19b7034999cc5be8b23f9761afdf6d9be2f70 (patch)
treea9410600b092ae15597fddb94c6491f962c1a5da /virtual
parentSwitch the dep back to dev-python/unittest2 due to bug #450658. (diff)
downloadgentoo-2-c1a19b7034999cc5be8b23f9761afdf6d9be2f70.tar.gz
gentoo-2-c1a19b7034999cc5be8b23f9761afdf6d9be2f70.tar.bz2
gentoo-2-c1a19b7034999cc5be8b23f9761afdf6d9be2f70.zip
Finally stop pulling in unittest2 for py<2.7 & py<3.2, since all dependent packages have correct deps now.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'virtual')
-rw-r--r--virtual/python-unittest2/ChangeLog8
-rw-r--r--virtual/python-unittest2/python-unittest2-1-r2.ebuild23
2 files changed, 30 insertions, 1 deletions
diff --git a/virtual/python-unittest2/ChangeLog b/virtual/python-unittest2/ChangeLog
index 49dbfc7a6d5d..4e5a6ed0d4bb 100644
--- a/virtual/python-unittest2/ChangeLog
+++ b/virtual/python-unittest2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for virtual/python-unittest2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-unittest2/ChangeLog,v 1.6 2013/06/30 15:40:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-unittest2/ChangeLog,v 1.7 2013/07/19 07:58:37 mgorny Exp $
+
+*python-unittest2-1-r2 (19 Jul 2013)
+
+ 19 Jul 2013; Michał Górny <mgorny@gentoo.org> +python-unittest2-1-r2.ebuild:
+ Finally stop pulling in unittest2 for py<2.7 & py<3.2, since all dependent
+ packages have correct deps now.
*python-unittest2-1-r1 (30 Jun 2013)
diff --git a/virtual/python-unittest2/python-unittest2-1-r2.ebuild b/virtual/python-unittest2/python-unittest2-1-r2.ebuild
new file mode 100644
index 000000000000..b4b25ed9733d
--- /dev/null
+++ b/virtual/python-unittest2/python-unittest2-1-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-unittest2/python-unittest2-1-r2.ebuild,v 1.1 2013/07/19 07:58:37 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+inherit python-r1
+
+DESCRIPTION="A virtual for packages needing unittest2 in Python 2.5, 2.6, 3.1"
+HOMEPAGE=""
+SRC_URI=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+LICENSE=""
+SLOT="0"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ python_targets_python2_5? ( dev-python/unittest2[python_targets_python2_5] )
+ python_targets_python2_6? ( dev-python/unittest2[python_targets_python2_6] )
+ python_targets_python3_1? ( dev-python/unittest2[python_targets_python3_1] )"