summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-09-26 14:08:51 +0000
committerFabian Groffen <grobian@gentoo.org>2009-09-26 14:08:51 +0000
commitb86a3454f34886395aa5c1321d312ae1fae3fe88 (patch)
tree8f2484bb81c10b8f72b08e51564d50a6c6ce8b9c /sys-process
parentamd64 stable, security bug #283370 (diff)
downloadgentoo-2-b86a3454f34886395aa5c1321d312ae1fae3fe88.tar.gz
gentoo-2-b86a3454f34886395aa5c1321d312ae1fae3fe88.tar.bz2
gentoo-2-b86a3454f34886395aa5c1321d312ae1fae3fe88.zip
Add sys-process/unixtop from the Prefix tree
(Portage version: 2.2.00.14411-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/unixtop/ChangeLog13
-rw-r--r--sys-process/unixtop/files/unixtop-3.8_beta1-memleak-fix.patch28
-rw-r--r--sys-process/unixtop/files/unixtop-3.8_beta1-ncurses.patch14
-rw-r--r--sys-process/unixtop/files/unixtop-3.8_beta1-no-AX-macros.patch22
-rw-r--r--sys-process/unixtop/files/unixtop-3.8_beta1-renice-segfault.patch21
-rw-r--r--sys-process/unixtop/metadata.xml5
-rw-r--r--sys-process/unixtop/unixtop-3.8_beta1-r1.ebuild47
7 files changed, 150 insertions, 0 deletions
diff --git a/sys-process/unixtop/ChangeLog b/sys-process/unixtop/ChangeLog
new file mode 100644
index 000000000000..dac0995b1c03
--- /dev/null
+++ b/sys-process/unixtop/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sys-process/unixtop
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/unixtop/ChangeLog,v 1.1 2009/09/26 14:08:50 grobian Exp $
+
+*unixtop-3.8_beta1-r1 (05 Apr 2009)
+
+ 05 Apr 2009; Fabian Groffen <grobian@gentoo.org>
+ +files/unixtop-3.8_beta1-memleak-fix.patch,
+ +files/unixtop-3.8_beta1-renice-segfault.patch, metadata.xml,
+ -unixtop-3.8_beta1.ebuild, +unixtop-3.8_beta1-r1.ebuild:
+ Bump for two patches from OpenSolaris folks to fix a memleak and a
+ segfault
+
diff --git a/sys-process/unixtop/files/unixtop-3.8_beta1-memleak-fix.patch b/sys-process/unixtop/files/unixtop-3.8_beta1-memleak-fix.patch
new file mode 100644
index 000000000000..d8c6e556e197
--- /dev/null
+++ b/sys-process/unixtop/files/unixtop-3.8_beta1-memleak-fix.patch
@@ -0,0 +1,28 @@
+http://defect.opensolaris.org/bz/show_bug.cgi?id=5482
+http://sourceforge.net/tracker/?func=detail&aid=2593511&group_id=72892&atid=536042
+
+--- top-3.8beta1/machine/m_sunos5.c
++++ top-3.8beta1/machine/m_sunos5.c
+@@ -2059,11 +2059,11 @@
+ /* make sure we have a valid descriptor and the file's current size */
+ if (fd >= 0 && fstat(fd, &st) != -1)
+ {
+- char *p;
++ char *p, *p0;
+ int i;
+
+ /* read the whole file */
+- p = malloc(st.st_size);
++ p = p0 = malloc(st.st_size);
+ (void)pread(fd, p, st.st_size, 0);
+
+ /* cache the file descriptor if we can */
+@@ -2148,7 +2148,7 @@
+ op->oldtime = TIMESPEC_TO_DOUBLE(lwpp->pr_time);
+ op->seen = 1;
+ }
+- free(p);
++ free(p0);
+ }
+ #endif
+
diff --git a/sys-process/unixtop/files/unixtop-3.8_beta1-ncurses.patch b/sys-process/unixtop/files/unixtop-3.8_beta1-ncurses.patch
new file mode 100644
index 000000000000..73cd88b72826
--- /dev/null
+++ b/sys-process/unixtop/files/unixtop-3.8_beta1-ncurses.patch
@@ -0,0 +1,14 @@
+* check ncurses first, such that we only link agains (system) termcap if
+ necessary (never the case in prefix) -- grobian@gentoo.org
+
+--- configure.ac
++++ configure.ac
+@@ -174,7 +174,7 @@
+ AC_CHECK_LIB(kvm, kvm_open)
+ # -lmld -lmach
+ AC_CHECK_LIB(mach, vm_statistics)
+-AC_SEARCH_LIBS(tgetent, termcap curses ncurses)
++AC_SEARCH_LIBS(tgetent, ncurses curses termcap)
+ AC_CHECK_LIB(m, exp)
+
+ # check for libraries required by extension
diff --git a/sys-process/unixtop/files/unixtop-3.8_beta1-no-AX-macros.patch b/sys-process/unixtop/files/unixtop-3.8_beta1-no-AX-macros.patch
new file mode 100644
index 000000000000..f5d34a4a9ae9
--- /dev/null
+++ b/sys-process/unixtop/files/unixtop-3.8_beta1-no-AX-macros.patch
@@ -0,0 +1,22 @@
+* no idea where these macros are, but we can surely do without this, for
+ now -- grobian@gentoo.org
+
+--- configure.ac
++++ configure.ac
+@@ -504,16 +504,6 @@
+
+ AC_MSG_RESULT($result)
+
+-# add extra cflags if the compiler accepts them
+-AX_CFLAGS_WARN_ALL
+-MODULE_CFLAGS=""
+-if test "$ax_cv_c_compiler_vendor" = "gnu"; then
+- AX_CFLAGS_GCC_OPTION([-fno-strict-aliasing], [MODULE_CFLAGS])
+- if test "$target_cpu" = "alpha"; then
+- AX_CFLAGS_GCC_OPTION([-mfp-trap-mode=sui -mtrap-precision=i])
+- fi
+-fi
+-
+ # Define man page supplement
+ MAN_SUPPLEMENT=machine/m_$MODULE.man
+ AC_SUBST_FILE(MAN_SUPPLEMENT)
diff --git a/sys-process/unixtop/files/unixtop-3.8_beta1-renice-segfault.patch b/sys-process/unixtop/files/unixtop-3.8_beta1-renice-segfault.patch
new file mode 100644
index 000000000000..afea694b59ad
--- /dev/null
+++ b/sys-process/unixtop/files/unixtop-3.8_beta1-renice-segfault.patch
@@ -0,0 +1,21 @@
+http://defect.opensolaris.org/bz/show_bug.cgi?id=6580
+
+--- top-3.8beta1/commands.c
++++ top-3.8beta1/commands.c
+@@ -501,13 +501,15 @@
+ if (procnum == -1 || prio < PRIO_MIN || prio > PRIO_MAX)
+ {
+ message_error(" renice: bad priority value");
++ return;
+ }
+ #endif
+
+ /* move to the first process number */
+ if ((str = next_field(str)) == NULL)
+ {
+- message_error(" remice: no processes specified");
++ message_error(" renice: no processes specified");
++ return;
+ }
+
+ #ifdef HAVE_SETPRIORITY
diff --git a/sys-process/unixtop/metadata.xml b/sys-process/unixtop/metadata.xml
new file mode 100644
index 000000000000..4561e552bd04
--- /dev/null
+++ b/sys-process/unixtop/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>prefix</herd>
+</pkgmetadata>
diff --git a/sys-process/unixtop/unixtop-3.8_beta1-r1.ebuild b/sys-process/unixtop/unixtop-3.8_beta1-r1.ebuild
new file mode 100644
index 000000000000..6cf7034be57b
--- /dev/null
+++ b/sys-process/unixtop/unixtop-3.8_beta1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/unixtop/unixtop-3.8_beta1-r1.ebuild,v 1.1 2009/09/26 14:08:50 grobian Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="top for UNIX systems"
+HOMEPAGE="http://unixtop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/unixtop/top-${PV/_/}.tar.bz2"
+
+LICENSE="unixtop"
+SLOT="0"
+KEYWORDS="~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/top-${PV/_/}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-ncurses.patch
+ epatch "${FILESDIR}"/${P}-no-AX-macros.patch
+ epatch "${FILESDIR}"/${P}-renice-segfault.patch
+ epatch "${FILESDIR}"/${P}-memleak-fix.patch
+ eautoreconf
+}
+
+src_compile() {
+ local myconf=
+
+ # don't do bi-arch cruft on hosts that support that, such as Solaris
+ export enable_dualarch=no
+
+ # configure demands an override because on OSX this is "experimental"
+ [[ ${CHOST} == *-darwin* ]] && myconf="${myconf} --with-module=macosx"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README FAQ Y2K
+}